Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
DMA dropping DVD/cdrom b0rked?
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: DMA dropping DVD/cdrom b0rked?

  1. #1
    Guest

    DMA dropping DVD/cdrom b0rked?

    Ok here is one for you folks. I use Arch Linux which uses devfs. I have a CDRW as slave on the secondary ide and my DVD/CDROM is pimary on that bus. This device worked fine in Gentoo (with some tweaking) and on Libranet but with Arch the DMA keeps getting dropped when I try to mount the drive or watcha dvd. this results in very jerky play. Now this DMA dropping will happen even if the settings are saved in hdparm. It makes no difference if it is a DVD or regular CD in the drive the DMA gets dropped.

    None of the solutions that worked elsewhere have not worked yet here and i am beginning to think that it may be hardware related.

    (so you know the CDRW is scsi emulated the DVD is not. IDE-CD is compiled in and IDE-SCSI is a module. All necessary components for viewing DVDs with xine are installed and functioning properly.)

  2. #2
    Guest

    Re:DMA dropping DVD/cdrom b0rked?

    which program are you using? Im am using ogle right now. I did have some problems with DMA but thanks to lovechild overcoming my ignorance, it works now. Something else you might want to check, dont know if it will be applicable to you, but try setting the xvattributes. There is some buffer in there that does something...wait one.

    Code:
    There seems to be some problems with Xv and nVidia cards (GeForce...).
    Setting the attribute XV_DOUBLE_BUFFER to 0 should make the video smooth. You can use 'xvattr' to do this.

  3. #3

    Re:DMA dropping DVD/cdrom b0rked?

    hello,
    i am not sure if it matters but do make sure you ahve the mtrr option turned in in your kernel.

  4. #4
    Guest

    Re:DMA dropping DVD/cdrom b0rked?

    ok i will check out both of those options. (i use xine BTW) I am concerned about the DMA dropping though in general because it will drop even if i just mount the drive with a regular cd in it. I tested my old regular cdrom and it does not happen with it that is why i suspect it may be hardware related

  5. #5

    Re:DMA dropping DVD/cdrom b0rked?

    Hi Sarah; you're having MUCH better luck than I am, I keep getting a "No suitable plugin found" in xine when I try to play a DVD in Debian Woody. I've re-installed 3 times, and I get the same damned thing. I may give OGLE a try.
    BTW: it's nice to see you around (this is keating305).
    Keep the faith!

  6. #6
    Guest

    Re:DMA dropping DVD/cdrom b0rked?

    Hiya quite the kick i got from Libranet eh? Any way you need to have either dvdnav, d4d, or d5d. Also you need to have libdvdread and libdvdcss in stalled. When all that is done just go into the set up and give it the proper path to your dvd device.

    xine is the only thing that works for me. Ogle has lousy controls and mplayer has never been able to do much for me despite trying to set it up correctlyn (according to TFM).

  7. #7

    Re:DMA dropping DVD/cdrom b0rked?

    Hey, all you were doing was expressing an opinion; same as me. I told 'em what I thought, they didn't like it, but they seemed to unload on you pretty unfairly- oh, well I've got Debian, I'm happy.
    I've already tried all the things you suggested, but I'm hard-headed, I'll keep butting that wall until SOMETHING breaks; me or it.
    Life is just a bowl of cherries; I HATE cherries!! ;D

  8. #8
    Guest

    Re:DMA dropping DVD/cdrom b0rked?

    Sigh turning off the double buffer did nothing. MTRR is compiled into the kernel. I had this problem in Gentoo which i solved by modprobing the ide-cd module in but it is already compiled in here my only other idea is perhaps the ide-scsi modules are interfering with this drive which i set as ide. (for some reason making it scsi emulated prevents me from mounting it).



  9. #9

    Re:DMA dropping DVD/cdrom b0rked?

    huh, i have my dvd drive set as a scsi emuated device and it works well....
    have you had a look at the BIOS settings?

  10. #10
    Guest

    Re:DMA dropping DVD/cdrom b0rked?

    anything that would be causing a problem in the BIOS is disabled. Ran it scsi emulated in Gentoo and Libranet without issue.

Similar Threads

  1. cdrom
    By svar in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 12-23-2008, 05:29 PM
  2. DSL connection keeps dropping
    By pdavis68 in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 02-26-2005, 11:02 PM
  3. LAN connection dropping [Very Annoying Issue]
    By shebang in forum Linux - Hardware, Networking & Security
    Replies: 8
    Last Post: 05-30-2004, 04:31 PM
  4. CDRom
    By pinehead in forum Linux - General Topics
    Replies: 2
    Last Post: 05-22-2003, 10:11 PM
  5. b0rked, very b0rked...
    By phpgeek in forum Linux - General Topics
    Replies: 13
    Last Post: 12-13-2001, 11:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •