Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Another cd-burner thread (kinda long)

  1. #1

    Another cd-burner thread (kinda long)

    Yes I am following the PET lets start basic info: cd/dvd on hda and cd/writer on hdc. Slackware 8.1 (with, correct me if I'm wrong, scsi general (sg) built into the kernel)

    LILO:

    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/hde8
    label = Slackware
    read-only
    append="hda=ide-scsi hdc=ide-scsi"
    # Linux bootable partition config ends
    On boot up:

    scsi0: scsi host adapter emulation for IDE ATAPI devices
    Vendor: NEC Model: DV-5800B Rev: G9A3 Type: cdrom ANSI scsi revision: 02
    Vendor: PHILIPS Model: PCRW804 Rev: 2.0 Type: cdrom ANSI scsi revision: 02
    Attached scsi CDROM sr0 at scsi0, channel 0, id 0, lun0
    Attached scsi CDROM sr1 at scsi0, channel 0, id 1, lun0
    sr0: scsi3_mmc drive: 20x/48x cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver revision: 3.12
    sr1: scsi3_mmc drive: 32x/32x writer xa/form2 cdda tray
    fstab:
    /dev/hde9 swap swap defaults 0 0
    /dev/hde8 / reiserfs defaults 1 1
    /dev/hde10 /home reiserfs defaults 1 2
    /dev/hde7 /fat32-mp3 vfat defaults 1 0
    /dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,ro,defaults,users 0 0
    /dev/cdrom2 /mnt/cdrom2 iso9660 noauto,owner,ro,defaults,users 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    I have also added modprobe ide-scsi and modprobe sg to the rc.local, the modprobe gs gives and error I believe thats because it in the Kernel not a module.
    Also, I've tried symbolic links to scd0 and scs1, sr0 and sr1, hda and hdc, sda and sdc. All with the same result, the mount point doesnt exist.

    Sorry about the cut'n'paste happy crap.

    Any thoughts guys? All will be welcome, thanks

  2. #2

    Re:Another cd-burner thread (kinda long)

    I used to get the same error on my system. I edited /ext/fstab to use /dev/sr0 instead of /dev/cdrom, and it fixed it for me.

  3. #3

    Re:Another cd-burner thread (kinda long)

    Wow that was fast!

    So just ditch the ln -s and run with sr0, cool

    Thanks

  4. #4

    Re:Another cd-burner thread (kinda long)

    Dang, no go. Any other ideas?

  5. #5
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:Another cd-burner thread (kinda long)

    Dude, are you getting anything out of cdrecord -- look at this:

    sudo cdrecord -scanbus
    Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
    cdrecord: No such file or directory. Cannot open SCSI driver.
    cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root


    This is my work's workstation, so I dont have a CDR drive attatched. So if you get this output, the SCSI emulation and generic driver arent working correctly. Chances are that you need to pass to the kernel that you want /dev/hdc (or whatever) to be using the SCSI not IDE driver. This was always my #1 test to see if it is getting the kernel config is configured correctly.

    HTH

  6. #6

    Re:Another cd-burner thread (kinda long)

    Try checking if /mnt/cdrom1 and /mnt/cdrom2 exist. If they don't, then do a mkdir /mnt/cdrom1 and mkdir /mnt/cdrom2
    Try then mounting them manually. mount /dev/sr0 -t iso9660 -r /mnt/cdrom1

  7. #7

    Re:Another cd-burner thread (kinda long)

    Schotty: I get something like this:
    bash-2.05a$ su
    Password:
    bash-2.05a# sudo cdrecord -scanbus
    Cdrecord 1.11a24 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
    Linux sg driver version: 3.1.22
    Using libscg version 'schily-0.6'
    scsibus0:
    0,0,0 0) '_NEC ' 'DV-5800B ' 'G9H3' Removable CD-ROM
    0,1,0 1) 'PHILIPS ' 'PCRW804 ' ' 2,0' Removable CD-ROM
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) *
    0,7,0 7) *
    Well I guess that means that it loaded ok

    Thanks, that ones goin' into the notebook.


  8. #8

    Re:Another cd-burner thread (kinda long)

    Trickster that was it! (I feel really stupid now ;D) It was probably working all along I just didnt have the mount point /mnt/cdrom1 for fstab to find.

    Thank you greatly

  9. #9

    Re:Another cd-burner thread (kinda long)

    Doh... thats what I get for opening my big mouth.

    Now I get a Kernel panic when I:
    mount /dev/sr1 -t iso9660 -r /mnt/cdrom2

    I'll copy down the error message if it does anyone any good, I'll do it again tonight.

    Thanks

  10. #10

    Re:Another cd-burner thread (kinda long)

    hello,
    so the PET did not help 'eh. well please let me know where it was wrong or not helpful.

    also what is the -r argument for ? Have you loaded modules sg and ide-scsi ?

    BTW - what kernel are ya using?

Similar Threads

  1. Been kinda slow around here lately...
    By jro in forum General Chat
    Replies: 6
    Last Post: 10-29-2004, 05:56 AM
  2. I'm kinda happy
    By trickster in forum General Chat
    Replies: 5
    Last Post: 01-07-2003, 06:58 PM
  3. This was kinda weird...
    By trickster in forum General Chat
    Replies: 3
    Last Post: 10-30-2002, 07:57 PM
  4. Since I felt the other thread kinda got off-track...
    By noblestknight in forum Announcements and Suggestions
    Replies: 2
    Last Post: 10-08-2002, 02:08 PM
  5. Working with long long in C
    By kenshi in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 12-03-2001, 12:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •