Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: no screens found

  1. #1

    no screens found

    I realize that I may not be posting enough info for an answer right away, but I have been doing searches about this problem and not really finding any real answers.

    I am building a new system and have purchased a GeForce4 PCI card. When running xf86config, I have tried choosing the nvidia GeForce selection, and also just a "generic VGA" selection. Both still give me the "no screens found" error when I try to startx. Is the problem with the video card, or I was also reading that not choosing proper monitor settings will also cause this error? But I have the manual for the monitor and think I am choosing the right things there... ???

    I'm not necessarily looking for an answer (though that would be super), but more of a list of things to check out so I can fix this problem Oh I am running Slack 8.0 if that makes a difference.

  2. #2

    Re:no screens found

    hmm if you have already made an XF86Config you could post it here - so it would be easier to help you - else you could try to make a new one with
    xf86config

    /etc/X11/XF86Config should be the file ..

  3. #3

    Re:no screens found

    I'm on my Win98 box right now, so cutting-and-pasting the config file isn't that simple, but I will try to show you the monitor and card configurations as well as the error message I get when I startx. Hopefully that will be ok...

    in XF86Config:
    Section "Monitor"
    Identifier "MAG19"
    HorizSync 31-80
    VertRefresh 60-100
    End Section

    Section "Device"
    Identifier "Standard VGA"
    VendorName "Unknown"
    BoardName "Unknown"
    Driver "vga"
    End Section

    Section "Device"
    Identifier "GeForce4MX420"
    Driver "nv"
    #VideoRam 65536
    End Section

    Section "Screen"
    Identifier "Screen 1"
    Device "GeForce4MX420"
    Monitor "MAG19"
    DefaultDepth 24

    ** some subsections on Displays...they are all defaults, I didn't mess with them **

    End Section

    Section "ServerLayout"
    Identifier "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    End Section
    And here is the error I get from startx:
    (II) Primary Device is: PCI 00:09:0
    (--) Assigning device section with no busID to primary device
    (EE) No devices detected.

    Fatal server error:
    no screens found
    looking above that, it seems as if the "nv" driver does not support the GeForce4 cards. If this is the case (which I now think it is), where do I get updated drivers from? (the box the card came in claimed "complete Linux display and OpenGL drivers support&quot and how do I properly install these drivers to allow this card to work?

    Thanks for reading such a long post and helping me with this basic question

  4. #4

    Re:no screens found

    You could try the nvidia driver from www.nvidia.com, and follow the readme

  5. #5

    Re:no screens found

    wow...*whap self repeatedly*...this is what happens when you sit in front of something for too long...the obvious answer sits right in front of your nose and gets ignored.

    *flogs self with wet noodle*

    thanks for the link

  6. #6

    Re:no screens found

    Okay...I got the files I needed but am running into problems with the make install on the kernel module. I have read the README but don't quite understand what they are talking about...again I am running Slack 8.0, kernel 2.2.19. I got the tarball file (not the rpm) and when I did the make install, I got these errors

    depmod: *** Unresolved symbols in /lib/modules/2.2.19/video/NVdriver
    /lib/modules/2.2.19/video/NVdriver: unresolved symbol __global_cli
    /lib/modules/2.2.19/video/NVdriver: unresolved symbol tqueue_lock
    /lib/modules/2.2.19/video/NVdriver: unresolved symbol __global_save_flags
    /lib/modules/2.2.19/video/NVdriver: unresolved symbol __global_restore_flags
    /lib/modules/2.2.19/video/NVdriver: insmod /lib/modules/2.2.19/video/NVdriver failed
    /lib/modules/2.2.19/video/NVdriver: insmod NVdriver failed
    make: *** [package-install] Error 255
    The README file says
    If you receive errors about unresolved symbols, then the kernel module has most likely been built using header files for a different kernel revision than what you are running. You can explicitly control what kernel header files are used by building NVdriver from the NVIDIA_kernel tar file with: 'make install SYSINCLUDE=/path/to/kernel/headers'.
    Okay...where would I even begin to look for these kernel headers? When I try to include /usr/src/linux-2.2.19/kernel in the make install, it dumps right out, refusing to do the make. Does this require a kernel upgrade or recompile?

    Thanks in advance

  7. #7
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:no screens found

    Just configure the kernel and do a make dep. I think that will do it.
    CP

  8. #8

    Re:no screens found

    hello,
    i usually need to make link in /usr/include called linux to /usr/src/linux/include/linux/ . if /usr/include/linux alredy exists i rename it.e.g.
    mv /usr/include/linux /usr/include/old_sys_headers
    ln -s /usr/src/linux/include/linux /usr/include/linux

  9. #9

    Re:no screens found

    [quote author=pbharris link=board=6;threadid=4722;start=0#47027 date=1030329853]
    hello,
    i usually need to make link in /usr/include called linux to /usr/src/linux/include/linux/ . if /usr/include/linux alredy exists i rename it.e.g.
    mv /usr/include/linux /usr/include/old_sys_headers
    ln -s /usr/src/linux/include/linux /usr/include/linux

    [/quote]

    I tried that and got the same errors/results...thanks for the advice though!

    CP, what/how do you configure the kernel? Are there certain things that need to be included in that? Thanks in advance...

  10. #10

    Re:no screens found

    Nevermind the last message...I fixed the problem simply by compiling kernel 2.4.5. Now I can startx with no problems, but when KDE starts up, the resolution is really huge. I only see the top left quadrant of the "screen" (i.e. 75% of the desktop is off the screen). I assume this is something in my XF86Config file, and I will mess with it tomorrow...but thanks again for all the advice and help

Similar Threads

  1. Vile white screens
    By deimos in forum Linux - General Topics
    Replies: 0
    Last Post: 12-20-2005, 07:57 PM
  2. SDL 1.1 not found when I already have 1.2?
    By Snake785 in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 12-01-2002, 07:52 AM
  3. scanner not found
    By bleeding toejam in forum Mandriva
    Replies: 3
    Last Post: 04-14-2002, 11:33 AM
  4. fatal error: no screens found
    By S_D_Willie in forum Linux - General Topics
    Replies: 7
    Last Post: 03-26-2002, 11:55 AM
  5. Unable to startx -  no screens found
    By Infohawk in forum Linux - General Topics
    Replies: 24
    Last Post: 02-27-2002, 02:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •