Results 1 to 7 of 7

Thread: Samba Server woes

  1. #1

    Samba Server woes

    Hi I recently configured SAMBA on my laptop but i can't access my linux box from my win2k box. I can see the host in Network Neighborhood, but when i attempt to access the box, i'm prompted for a username and password. I've tried all user acounts on the system with no avail. here is my smb.conf file am I missing anything?

    Ryan

    # Samba config file created using SWAT
    # from Skynet.localdomain (127.0.0.1)
    # Date: 2002/08/17 10:22:33

    # Global parameters
    [global]
    netbios name = SKYNET
    server string = Inispiron Samba Server
    encrypt passwords = Yes
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    guest account = guest
    hosts allow = 192.168.1. 127.
    printing = lprng

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    guest ok = Yes

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [SHARED]
    comment = Shared Stuff on MY Linux Box
    path = /tmp/share


  2. #2

    Re:Samba Server woes

    I tried something else now, i toggle all the pam options off, and i set "encrypt passwords" to no. Now when i try to enter the system via my win2k box, i get no password prompt but i do get a error message stating "The account is not authorized to log in from this station" Now i thought i could still use guest accounts? Where am i going wrong here?

    Here is the updated smb.conf file.

    Samba config file created using SWAT
    # from Skynet.localdomain (127.0.0.1)
    # Date: 2002/08/17 15:46:34

    # Global parameters
    [global]
    netbios name = SKYNET
    server string = Inispiron Samba Server
    passwd program = /usr/bin/passwd %u passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    guest account = guest
    hosts allow = 192.168.1. 127.
    printing = lprng

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    guest ok = Yes

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [SHARED]
    comment = Shared Stuff on MY Linux Box
    path = /tmp/share


  3. #3

    Re:Samba Server woes

    Hello,
    As root on your samba server type: smbpasswd -a <username> hit enter and type the new password. This user should already have a regular unix account on your box if I remember correctly.

  4. #4

    Re:Samba Server woes

    so you think the problem is that my local users aren't in /etc/smbpassword?

  5. #5
    Junior Member
    Join Date
    May 2001
    Posts
    92

    Re:Samba Server woes

    Hi,

    Total Samba newbie here, but might you have typo in the name of your laptop? Is it an Inspiron instead of Inispiron?

    server string = Inispiron Samba Server

    M

  6. #6
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:Samba Server woes

    [quote author=Funky Data link=board=4;threadid=4599;start=0#46072 date=1029618779]
    so you think the problem is that my local users aren't in /etc/smbpassword?

    [/quote]
    Exactly. The Samba user acoounts are totally different from your Linux system accounts.

    You will have to do "smbpasswd" thing.

    And Guest accounts are only for browsing but not for logging on since guest logon in Linux is disabled by default. With Win2K, you need "encrypted passwords".

  7. #7
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:Samba Server woes

    [quote author=Mip link=board=4;threadid=4599;start=0#46239 date=1029732643]
    Hi,

    Total Samba newbie here, but might you have typo in the name of your laptop? Is it an Inspiron instead of Inispiron?

    server string = Inispiron Samba Server

    M
    [/quote]

    Server string has no affect on the way Samba behave since it's only for information use. For example, if you are using Lan browsing and click on the SKYNET server name, the server string "Inispiron Samba Server" will only show up in the message box. So if you haver typo, it will show as a typo word. The only important thing is to have NetBIOS name correct.

Similar Threads

  1. Samba Server Help
    By stalwarts in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 07-08-2004, 11:04 AM
  2. Samba Server
    By -JhAzEr- in forum Linux - General Topics
    Replies: 1
    Last Post: 04-23-2003, 04:52 PM
  3. Samba Woes
    By Wolverine in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 03-28-2003, 04:12 AM
  4. Samba server
    By flandercan in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 06-24-2002, 10:54 AM
  5. Samba Server
    By Kaiser_Sose in forum Linux - Hardware, Networking & Security
    Replies: 22
    Last Post: 02-02-2002, 04:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •