Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: SAMBA on Debian 3.0 > 2000 workstation

  1. #1
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    SAMBA on Debian 3.0 > 2000 workstation

    Hi!

    Anybody got any tips on getting a Debian 3.0 box to talk to a Windows 2000 box?

    Both are able to ping each other fine. Both daemons are running in Debian as well.

    Do I need a hosts configuration line in smb.config file? Currently, there isn't a sections for hosts in this file. I've been reading around on Debian's website and they mention something about having this in there.

    Also, what services to I need to enable on 2000? I've put netbeui on there, rebooted and found that debserv (debian box) was trying to send netbios datagrams to it. I know this because Zone Alarm was picking this up.

    Do I need to enable NETBIOS over TCP/IP in 2000? That's scary for me, and I don't want to leave on if people can get through my Netgear NAT Gateway/Router.

    Thanks for the replies.

  2. #2
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:SAMBA on Debian 3.0 > 2000 workstation

    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45411 date=1029097898]
    Do I need a hosts configuration line in smb.config file? Currently, there isn't a sections for hosts in this file. I've been reading around on Debian's website and they mention something about having this in there.[/quote]
    There is no such thing as "hosts configuration" in "smb.conf" file.

    May be you are referring to hosts configuration in your Debian system. It's "/etc/hosts" file. You need to modify it to be able to refer your Win2K box with only the name instead of its IP address. What I have in my /etc/hosts file is
    Code:
    127.0.0.1   localhost.localdomain   localhost
    192.168.2.2   mycomputer.mydomain.net   mycomputer
    Also, what services to I need to enable on 2000?
    You need to define your share in your Win2K drive that's whatever drive you want to share. Do I need to explain more since you are pretty familar with Windows stuff?
    A hint though, it's right-mouse click on the drive and choose sharing.

    I've put netbeui on there, rebooted and found that debserv (debian box) was trying to send netbios datagrams to it. I know this because Zone Alarm was picking this up.
    That's because it's the broadcast data looking for the Wins server. I don't trust NetBEUI since it's not routable protocol. Drop the NetBEUI since Microsoft also dropped it. Go for pure TCP/IP.

    Do I need to enable NETBIOS over TCP/IP in 2000? That's scary for me, and I don't want to leave on if people can get through my Netgear NAT Gateway/Router.
    It's non-sense. If people can get to your Debian box with SAMBA, then they will be able to get to your Win2K box with NetBEUI since they will have a means of connection anyway. Plus, the protocol has nothing to do with how secure your box is. As long as you keep patching your Windows box, you should be fine.
    Thanks for the replies.
    You're welcome. ;D

  3. #3
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    Re:SAMBA on Debian 3.0 > 2000 workstation

    [quote author=Compunuts link=board=4;threadid=4540;start=0#45423 date=1029116474]
    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45411 date=1029097898]
    May be you are referring to hosts configuration in your Debian system. It's "/etc/hosts" file. You need to modify it to be able to refer your Win2K box with only the name instead of its IP address. What I have in my /etc/hosts file is
    Code:
    127.0.0.1   localhost.localdomain   localhost
    192.168.2.2   mycomputer.mydomain.net   mycomputer
    I'm lost again. The only thing I have for my 2000 box is an IP. There's no fully qualified domain name that I'm aware of, is there? Also, does the computer name go beside the ip in this file? :-\
    I put :

    192.168.0.2 computername

    I tried connecting and it still doesn't work. Do I need to restart the services?[/quote][/quote]

  4. #4
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:SAMBA on Debian 3.0 > 2000 workstation

    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45426 date=1029119918]
    I'm lost again. The only thing I have for my 2000 box is an IP. There's no fully qualified domain name that I'm aware of, is there?[/quote]
    No, there is not. And that's why you need to put that info in your hosts file. In Linux, it's /etc/hosts. In Windows, it's in your Windows directory. Both have the same name ( guess who copy who? )

    Just FYI though that if yave FQDN - Fully Qualified Domain Name, then you do not need to have the info put into the hosts file. Resolving name to IP address is what DNS does.

    Also, does the computer name go beside the ip in this file? :-\
    I put :

    192.168.0.2 computername
    That would do it.

    I tried connecting and it still doesn't work. Do I need to restart the services?
    Yes, you need to restart smb and nmbd services. And also, make sure that you have all the sharing set up in Win2K box as well as sharing info in smb.conf file in Linux box.

    Check this article out. This will walk you through what you are trying to do. Except some local files location, the set up should be the same.

    http://www.linuxorbit.com/modules.ph...&artid=288

  5. #5
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    Re:SAMBA on Debian 3.0 > 2000 workstation

    I went through the article, and still no dice. I knew it. Hours and hours of this crap and nothing works. It always happens in linux.

    So far, I've been to samba.org and glanced through pdf files, and html files. I've even looked through "Running Linux" but I can't find any easy answers.

    I also don't know what you mean about "sharing" in Win 2k. I should be able to open up My Network Places, and browse to it. I can't do that. I try mapping a drive, to \\homedeb but it says it doesn't exist.

    I can't find any errors in testparm either.

    I can ping BOTH IP addresses.

    I can't ping machine names.

  6. #6
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:SAMBA on Debian 3.0 > 2000 workstation

    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45436 date=1029131344]
    I knew it. Hours and hours of this crap and nothing works. It always happens in linux.[/quote]
    So you are sure that it's not Windows problem?? I mean how easy is it for Windows to be able to use UNIX native drive?? It will be equally the same.

    I also don't know what you mean about "sharing" in Win 2k. I should be able to open up My Network Places, and browse to it.
    Not true. All of Win2K's default share drives are hidden. You have to define/create your own what you want to share. Try it with Windows to Windows first and see how it's.

    I can't do that. I try mapping a drive, to \\homedeb but it says it doesn't exist.
    You can't because you have no share defined.

    I can ping BOTH IP addresses.

    I can't ping machine names.
    Did you create hosts files in both machine?? Both machine are setup with correct host names??

  7. #7
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    Re:SAMBA on Debian 3.0 > 2000 workstation

    I'll try that when I get home.

    Sorry, just a little frustrated with my own lack of knowledge. I really need to learn this stuff, and I know that the learning curve isn't easy when you're going from Windows to Linux.

    Sorry about the rant, I was just tired.

    By the way, I have a minimal install of debian without a GUI, and I love it. I use Midnight Commander to browse and edit files; nice, simple, and fast. No fancy GUI shit, just the basics.

  8. #8
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    Re:SAMBA on Debian 3.0 > 2000 workstation


    Not true. All of Win2K's default share drives are hidden. You have to define/create your own what you want to share. Try it with Windows to Windows first and see how it's.
    How??? How do I "create" a share? Is this the same thing as 'map network drive'? No? Then HOW is it done?

    You can't because you have no share defined.
    Great! Now if only someone can clue me into defining a share in Windows 2000, and how to create one.


    Did you create hosts files in both machine?? Both machine are setup with correct host names??
    I wasn't aware that 2000 needed a share name in it's hosts file. I've done this and still no dice. Maybe a magic reboot would help.

  9. #9
    Junior Member
    Join Date
    Jul 2001
    Posts
    90

    Re:SAMBA on Debian 3.0 > 2000 workstation

    Hey look! I rebooted and NOTHING. They still can't see each other.

    <frustrated sigh>

  10. #10
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:SAMBA on Debian 3.0 > 2000 workstation

    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45496 date=1029176229]
    Sorry, just a little frustrated with my own lack of knowledge. I really need to learn this stuff, and I know that the learning curve isn't easy when you're going from Windows to Linux.

    Sorry about the rant, I was just tired.
    [/quote]
    No need to apologize. I understand your frustration since I was in your shoe a few years ago.

    By the way, I have a minimal install of debian without a GUI, and I love it. I use Midnight Commander to browse and edit files; nice, simple, and fast. No fancy GUI shit, just the basics.
    Now, THAT's what I like. If you want to really learn stuff, stay away from GUI stuff.

    [quote author=Goughmezz link=board=4;threadid=4540;start=0#45529 date=1029196729]
    How??? How do I "create" a share? Is this the same thing as 'map network drive'? No? Then HOW is it done?[/quote]
    I already answered that...
    From earlier post
    A hint though, it's right-mouse click on the drive and choose sharing.
    So, when you choose "Sharing", you will see a window with tabs for "General, Tools, Hardware, Sharing". At the Sharing area, you will see that your drive - whatever letter is - proceed by a "$" sign. That means in Windows, it's hidden ( but the smart Engineers decided to leave those default to your drive letter such as C and D but how hard it's to guess that??? ). If you clicked on "New Share", it will give you a dialog box with options like ShareName; Comment;User Limit and Permission. You need to properly set that up. If you are new to this, just do a world writable and allow guess log in.

    Great! Now if only someone can clue me into defining a share in Windows 2000, and how to create one.
    Get a WinNT administrator book from some old book shops or library or something. Those fundamentals still the same with Win2K and WinNT.


    I wasn't aware that 2000 needed a share name in it's hosts file.
    The share name is NOT in hosts file. Hosts file is only for name to IP address translation. That's all. Share is in SMB protocols that's used by Windows Networking. If you do not define your sharing, then your Windows SMB protocol doesn't know what to share.

    Maybe a magic reboot would help.
    Many times but it's not the only solution and certainly not a reliable one especially when the fault is in user rather than software program itself.

Similar Threads

  1. Replies: 7
    Last Post: 03-29-2007, 01:46 PM
  2. Windows Server 2003 SP1 and NT4 Workstation
    By cward in forum Windows - General Topics
    Replies: 2
    Last Post: 03-14-2006, 03:03 PM
  3. Workstation service
    By elovkoff in forum Windows - General Topics
    Replies: 5
    Last Post: 06-24-2003, 07:03 PM
  4. Debian problem with workstation accessing gateway
    By in forum Linux - Hardware, Networking & Security
    Replies: 14
    Last Post: 03-02-2003, 08:01 PM
  5. CUPS Config from Remote Workstation
    By fark in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 02-12-2002, 12:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •