Results 1 to 8 of 8

Thread: HP printer setup woes

  1. #1
    Join Date
    Apr 2002

    HP printer setup woes

    Trying to print to a HP Officejet v40 color printer/fax/scanner USB device. The PC made a sound when the USB cable was connected to the PC, but I'm not sure how to tell if the device is recognized by the system.

    I get the following error message on an attempt to print:

    A print error occured. Error message received from system:

    /usr/bin/lpr -P 'lp' '-#1' '/tmp/kde-dan/kdeprint_r4ZQDEQ' : execution failed with message:
    Get_local_host: hostname '24-240-113-61' bad

    I get the same error when trying to print a test page from the YaST GUI config page (I'm running SuSE 8.0 Pro)

    I DID download, compile and install current drivers. The YaST config tool provided a list of devices to config for, one being the 'officet V series', so I'm not sure if SuSE bundles drivers or YaST found the drivers I downloaded?

    I suspect my problem is in the USB connection and that maybe the PC is expecting a printer connected on a parallel port??

    Not sure where to start for diagnosing. Help ...

  2. #2

    Re:HP printer setup woes

    if you have usbview run it and see what is connected. also run it and make sure the moduels are loaded. i take it this gets a IP address from a DHCP server - right?

  3. #3
    Join Date
    Apr 2002

    Re:HP printer setup woes

    Thanks pbharris,

    I did run usbview and have displayed the 'USB UHCI Root Hub' device with the sub listing 'OfficeJet V40'. Both listed devices display configuration information in the right pane of the GUI. The hub displays a 2-port setup. The font color of the Officejet device is red rather than black ... not sure if that indicates there is a problem with the device or that's the default font color for a sub-level device?

    I'm not sure what modules you mention. Again, I get the same error when attempting to configure the device with the YaST config. tool.

    Thanks for the response!

  4. #4

    Re:HP printer setup woes

    alrighty - so the device is getting seen - this is good. I am not sure why you would get the message about Get_local_host: hostname '24-240-113-61' bad because that implies a network issue with LPd, and i assume the tool you are using to set it up on is not trying to set the printer up as a remote printer, when you do a /sbin/lsmod do the modules for the printer show up ?

    Also lets tell SUSE it is a regular PS printer hooked up to lp0 to see if LPRng is hosed, it may query the port but i would hoe it would not care if the printer were actually there or not.

  5. #5
    Join Date
    Apr 2002

    Re:HP printer setup woes

    Results of /sbin/lsmod:

    dan@24-216-40-27:~> /sbin/lsmod
    Module Size Used by Tainted: P
    snd-pcm-oss 45152 0 (autoclean)
    snd-mixer-oss 11136 1 (autoclean)
    agpgart 29664 3 (autoclean)
    NVdriver 946752 10 (autoclean)
    ipv6 123424 -1 (autoclean)
    snd-ens1371 12036 1
    snd-pcm 58528 0 [snd-pcm-oss snd-ens1371]
    snd-timer 11456 0 [snd-pcm]
    snd-rawmidi 13536 0 [snd-ens1371]
    snd-seq-device 4336 0 [snd-rawmidi]
    snd-ac97-codec 24196 0 [snd-ens1371]
    snd 31720 0 [snd-pcm-oss snd-mixer-oss snd-ens1371 snd-pcm snd-timer snd-rawmidi snd-seq-device sn d-ac97-codec]
    soundcore 3268 6 [snd]
    isa-pnp 27816 0
    joydev 5728 0 (unused)
    evdev 3904 0 (unused)
    input 3072 0 [joydev evdev]
    usb-uhci 20996 0 (unused)
    usbcore 55136 1 [usb-uhci]
    af_packet 11528 1 (autoclean)
    8139too 13504 1
    mii 1040 0 [8139too]
    reiserfs 158816 1

    Note the username address. I think I have something goofy with my /etc/hosts file which may be related to this printer error. It looks like my usb root device module is loaded - I don't recognize anything related to the printer.

    I just tried running the YaST printer setup again ... got the same error as before except with the new IP as shown in the lsmod listing.

    Here's my /etc/hosts file:

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts g4600linux

  6. #6

    Re:HP printer setup woes

    when you set up the printer did you set it up as the USB one or did you pick another attached to lp0 ?

    i am not sure what to make out of that hosts file, mine looks nothing like that, not sure if this is a ipv6 or suse convention...

  7. #7
    Join Date
    Apr 2002

    Re:HP printer setup woes

    I don't understand the ipv lines either, but the localhost line should be familiar.

    I don't understand the entirely, but 'g4600linux' is the computer name and is the domain name of my ISP.

    I tried adding a line to this file, something like just kicks/giggles ... to no avail. Then, of course, I tried a reboot and was assigned a different IP anyway.

    This is way over my head. Here is one area that Windows (unfortunately?) is way ahead of Linux - hardware setup ... at least in this specific case.

    Frustrated ...

  8. #8

    Re:HP printer setup woes

    yea - i gots to agree in this case

Similar Threads

  1. Unable to setup a NIS server setup on CentOS system
    By swatidas in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 01-19-2010, 02:42 PM
  2. RPM woes
    By mrkeef in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 01-01-2004, 01:21 AM
  3. Konica 7075 printer setup
    By datamike in forum Linux - General Topics
    Replies: 2
    Last Post: 07-02-2003, 06:06 PM
  4. Printer setup with Samba
    By Kaiser_Sose in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 02-09-2002, 03:34 AM
  5. printer setup
    By agar in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 12-13-2001, 08:55 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts