I have been trying to get some of the stock xscreensavers to work on my machine. I'm running Slackware 8.1 and I have downloaded and installed the latest XFree86 source according to the PET. Everything seemed to go ok but when I look at the x output log I get the following.

XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 18 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-2002 i686 [ELF]
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Jul 22 13:06:38 2002
(==) Using config file: "/etc/X11/XF86Config"
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Xlib: extension "GLX" missing on display ":0.0".
DCOPServer up and running.
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Mutex destroy failure: Device or resource busy
Mutex destroy failure: Device or resource busy
Xlib: extension "GLX" missing on display ":0.0".
Mutex destroy failure: Device or resource busy
Xlib: extension "GLX" missing on display ":0.0".
mcop warning: user defined signal handler found for SIG_PIPE, overriding
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
mcop warning: user defined signal handler found for SIG_PIPE, overriding
Xlib: extension "GLX" missing on display ":0.0".
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/DigitalClock) Negative sizes (2,-4) are not possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/QLabel) Negative sizes (49,-4) are not possible
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

I seem to be at a loss on this one and haven't been able to find a lot of info or info that I understand as a new Linux user. Ok you pro Linux folks I would sure appreciate some help...By the way do I need to have the kernel source installed before I install the XFree86 from source? :-\