Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
kde-libs error:
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: kde-libs error:

  1. #1

    kde-libs error:

    hey,

    on redhat 7.3 i guess all the kde headers werent installed by default maybe. when trying to ./configure krabber (and another app) i get the error saying:
    __________________________________________________ __________

    checking for kde headers installed... configure: error: your system is not able to compile a small KDE application!
    Check, if you installed the KDE header files correctly.
    __________________________________________________ __________

    i searched through all my rpms with the 3 redhat cd's and installed kde-libs, kde-libs-devel and what not but still cant get it to configure. google didnt come up with what i needed so i had to post. if i need to add something to /etc/ld.conf.so please say so. ive been using kde 3 so far and its been pretty good to me. thanks

    SD

  2. #2
    Guest

    Re:kde-libs error:

    export KDEDIR=/path/to/ur/kde/installation

    then rerun configure (if there's a config.cache file present, delete it)

  3. #3

    Re:kde-libs error:

    this might sound stupid but would a whereis kde give me the proper path so i can add it to that command? also, im guessing that the config.cache would be within the directory im trying to run the ./configure, right?
    thx

    SD

  4. #4
    Guest

    Re:kde-libs error:

    [quote author=S.D.Willie link=board=2;threadid=4280;start=0#42367 date=1027348074]
    this might sound stupid but would a whereis kde give me the proper path so i can add it to that command?
    [/quote]

    try 'which startkde'
    on my system, i get something like: /usr/local/kde3/bin/startkde
    so then $KDEDIR would have to be /usr/local/kde3

    also, im guessing that the config.cache would be within the directory im trying to run the ./configure, right?
    thx
    yes
    it's not necessarily there though... some packages keep a config.cache file, some don't
    if it's there it's safer to just delete it before u rerun configure because if the file is present it might use some of the values of that files, even though they might've been changed recently... like the value of $KDEDIR for instance

  5. #5

    Re:kde-libs error:

    which startkde gives me : /usr/bin/startkde

    whereis kde3 gives me : /usr/lib/kde3


    export KDEDIR=/usr/bin/startkde...................... didnt work neither did

    export KDEDIR=/usr/lib/kde3

    and i deleted config.cache each time. still wondering.......


    ???

  6. #6
    Guest

    Re:kde-libs error:

    well, redhat apparantly installed KDE with prefix=/usr

    so $KDEDIR should be set to /usr in ur case

  7. #7

    Re:kde-libs error:

    export KDEDIR=/usr

    ok, im losing patience on this one. that didnt work although i appreciate your help. im starting to think maybe i dont have all the libs installed? any possibility on knowing which ones i need?

  8. #8
    Guest

    Re:kde-libs error:

    well, the error ur getting implies that something is seriously wrong because configure will test to see if it can compile a small kde application. at first i thought the problem was that the include files weren't found so i suggested setting $KDEDIR to the right directory. but since that didn't help i'm affraid i have no idea what the problem is.

    could u post the content of config.log (located in the directory with the source code of the app ur trying to install)? preferably only the part where it starts to go wrong

  9. #9

    Re:kde-libs error:

    well there's a few different points and im unsure about the error so i hope you dont mind i'll send it to you in an email after this message. the subject will be config.log so you'll know who its from. thanks

    SD

  10. #10
    Guest

    Re:kde-libs error:

    well, i figured out what the problem is

    krabber was written for KDE1
    thus it won't compile with KDE3, the other application ur trying to compile may also be for KDE1 or KDE2...

    i know now that krabber is a program to rip audiofiles from cd's and to encode them... if you want i can put an older version of grip online. it's version 2.96 (that's the last version of it that doesn't require u to have a full gnome desktop installed) and it works great to rip and encode tracks.

    another thing u should try is this:
    put an audiocd in ur drive
    open konqueror and type: audiocd:/
    now u'll see a bunch of directories... one being mp3 and probably another one called ogg or something. if u go into the mp3 directory, and then u drag the files to another directory KDE will rip and encode the files using the settings specified at Kcontrol - Sound - Audio CD IO-Slave and then Ogg Vorbis Settings or MP3 settings

Similar Threads

  1. upgrading to KDE 3.1 - libs missing
    By xobbit in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 04-07-2003, 03:02 PM
  2. JPEG Shared Libs
    By Ashcrow in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 12-22-2002, 07:12 PM
  3. error installing packages "krb5-libs" ; AND NVIDIA troubles
    By SaTaNcLaUz in forum Linux - General Topics
    Replies: 23
    Last Post: 11-14-2002, 09:26 PM
  4. jpeg libs on netBSD
    By kornp in forum BSD
    Replies: 4
    Last Post: 07-18-2002, 07:59 PM
  5. Installing gnome-libs on LFS
    By Onewingdove in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 03-30-2002, 09:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •