Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
POS VIA onboard sound
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: POS VIA onboard sound

Hybrid View

  1. #1
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    POS VIA onboard sound

    I am having real trouble with my onboard sound. It is a VT82C686 chip. I have compiled my kernel with module support for it, and am running the modules ac97_codec, via82cxxx_audio and uart401. My problem is that only one program is able to use sound at once. This isn't a huge problem in itself, its just that if I xmms playing, and something else wants to use the soundcard, it will wait until the song has finished and then play its sound. Quite often this locks the sound so no apps can use it at all. I have gone right through every running process and none of them should be playing sound. Sometimes it recovers from this, and I can play my music again. And other times I cant. I am running Slack 8.1 with KDE 3.1. I wanted to install the actual drivers from the via site, but they seem to have drivers for redhat, mandrake, redflag and suse only. Anyone got any suggestions for this.
    Cheers
    CP

  2. #2

    Re:POS VIA onboard sound

    hello,
    this is the reason for sound deamons - is they cause more trouble then they solve for people who use one one sound making app at a time - but for you it may help - be forewarned i am not an expert and have spent more time disabling my sound deamon

    i use ESD (Enlightenment Sound Deamon), i know others use ARTS, which i think comes with KDE.

    also, have you tried the drtvers from VIA? they are obver there -> http://www.viaarena.com/?PageID=60

  3. #3
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:POS VIA onboard sound

    I have aRts installed, but don't really know how to configure it or anything. I have looked at the via drivers, but they do not have source or slack, which leaves me out. I'll just try to make sense of aRts.
    Cheers
    CP

  4. #4

    Re:POS VIA onboard sound

    cheers to you CP!

    good luck

  5. #5
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,925

    Re:POS VIA onboard sound

    [quote author=CP link=board=3;threadid=4279;start=0#42314 date=1027298525]
    I have aRts installed, but don't really know how to configure it or anything. I have looked at the via drivers, but they do not have source or slack, which leaves me out. I'll just try to make sense of aRts.
    Cheers
    CP
    [/quote]

    Do they have the src.rpm? Might you be able to use alien or possibly the rpm function that Slackware has (thankfully it's not a supported feature)? I know that I don't install rpm when I install Slackware 8.0, but I do have a buddy who does. Just a thought.

  6. #6
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:POS VIA onboard sound

    It looks like they have no source at all. Only the different packages for each distro.
    Cheers
    CP

  7. #7
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,925

    Re:POS VIA onboard sound

    [quote author=CP link=board=3;threadid=4279;start=0#42343 date=1027316038]
    It looks like they have no source at all. Only the different packages for each distro.
    Cheers
    CP
    [/quote]

    That truely sucks butt. Is there an OSS driver module for it? Maybe that would work. Dang, why can't these clowns give us the source!

  8. #8
    Guest

    Re:POS VIA onboard sound

    Have you checked with the ALSA project to see if they have a driver for you ?

  9. #9
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,925

    Re:POS VIA onboard sound

    [quote author=Lovechild link=board=3;threadid=4279;start=0#42361 date=1027338637]
    Have you checked with the ALSA project to see if they have a driver for you ?
    [/quote]

    Have they back ported the alsa drivers into any of the 2.4.x kernels yet?

  10. #10
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:POS VIA onboard sound

    OK, there is alsa support for it, which means I now need to learn about alsa. BTW I have been considering getting a 'real' soundcard. Any suggestions?
    Cheers
    CP
    <edit> Is it just me, or is there no docs for installing alsa on kernel 2.4.*??? </edit>

Similar Threads

  1. Onboard Sound
    By johnmann in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 12-03-2003, 03:02 PM
  2. Onboard sound
    By johnqpublic in forum Linux Distros
    Replies: 2
    Last Post: 11-28-2003, 02:02 AM
  3. onboard sound problem!!
    By dox in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 09-15-2003, 12:39 AM
  4. Onboard Sound
    By kornp in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 10-03-2002, 01:02 AM
  5. SoundCard: onboard sound vs PCI card
    By Blaqb0x in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 05-26-2002, 10:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •