Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
ssh prob
Results 1 to 9 of 9

Thread: ssh prob

  1. #1

    ssh prob

    Hi!

    I'm trying to ssh into my gateway/firwall here at home. I get this:

    Code:
    black666@starbase:~> ssh 192.168.0.1
    ssh: connect to address 192.168.0.1 port 22: Connection refused
    black666@starbase:~>
    My first guess was that a firewall rule refuses my connection - but there are no rules defined and the defaults for input, output and forward are ALLOW. There is only a masquerading all rule in the nat table.

    Then I did a search at the RedHat Homepage and found this:
    http://kb.redhat.com/view.php?eid=223
    I've tried many things with hosts.allow (sshd:ALL, sshd:192.168.0.2,...), still no effect.

    I even tried a "ssh localhost" at the firewall itself ... same message.

    I'm now at the point where I don't know what to try/search for next ...

    Any comments what the problem may be or what I can search for?

  2. #2
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re:ssh prob

    Sounds like you ssh daemon is not running. Try as root
    Code:
    /etc/rc.d/init.d/ssh start
    (I think that's where RedHat keeps startup scripts, but I might be wrong). It is also possible that your ssh daemon is running, but not on the standard port 22. Check your ssh config file for that.

  3. #3

    Re:ssh prob

    ps ax | more and see if sshd is running at all ...

  4. #4

    Re:ssh prob

    Mhmm, no sshd running ???

    But I installed every ssh package like the manual at the RedHat page told me

    Code:
    rpm -Uvh openssh*.rpm
    I checked the openssh package and this is what rpm told me is in the package:

    /etc/ssh
    /etc/ssh/moduli
    /usr/bin/scp
    /usr/bin/ssh-keygen
    /usr/libexec/openssh
    /usr/libexec/openssh/ssh-keysign
    /usr/share/doc/openssh-3.4p1
    /usr/share/doc/openssh-3.4p1/CREDITS
    /usr/share/doc/openssh-3.4p1/ChangeLog
    /usr/share/doc/openssh-3.4p1/INSTALL
    /usr/share/doc/openssh-3.4p1/LICENCE
    /usr/share/doc/openssh-3.4p1/OVERVIEW
    /usr/share/doc/openssh-3.4p1/README
    /usr/share/doc/openssh-3.4p1/README.privsep
    /usr/share/doc/openssh-3.4p1/README.smartcard
    /usr/share/doc/openssh-3.4p1/RFC.nroff
    /usr/share/doc/openssh-3.4p1/TODO
    /usr/share/doc/openssh-3.4p1/WARNING.RNG
    /usr/share/man/man1/scp.1.gz
    /usr/share/man/man1/ssh-keygen.1.gz
    /usr/share/man/man8/ssh-keysign.8.gz

    Isn't sshd missing in this rpm??
    Plus, when I do a "locate sshd" I get the following:


    Code:
    /etc/log.d/conf/services/sshd.conf
    /etc/log.d/conf/services/sshd2.conf
    /etc/log.d/scripts/services/sshd
    /etc/log.d/scripts/services/sshd2
    /usr/share/doc/pam_krb5-1.55/krb5afs-pam.d/sshd
    /usr/share/doc/pam_krb5-1.55/pam.d/sshd
    I checked the files ... nothing of use ...
    Seems like usr/sbin/sshd is missing .... is RedHat cooking their own soup here? I'm running RedHat 7.3 and installed all openssh* packages on their cd-roms and no sshd executable??

    This is what my Suse 8.0 installation gives me with "locate sshd" where sshd works perfect:

    Code:
    /etc/init.d/rc3.d/K15sshd
    /etc/init.d/rc3.d/S08sshd
    /etc/init.d/rc5.d/K15sshd
    /etc/init.d/rc5.d/S08sshd
    /etc/init.d/sshd
    /etc/pam.d/sshd
    /etc/ssh/sshd_config
    /usr/sbin/rcsshd
    /usr/sbin/sshd
    /usr/share/man/man8/sshd.8.gz
    /var/run/sshd.pid
    This differs completely from what I get at RedHat 7.3 ...

    Any comments?

  5. #5

    Re:ssh prob

    UPDATE!!!

    It's working now .... I browsed the other RedHat CDs and found additional openssh packages. I installed them and now everything works fine - So my fealing was right that there was something missing.

    Btw: Good idea RedHat to distribute the openssh packages on different CDs > ???

  6. #6
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:ssh prob

    <Shameless plug>
    apt-get install openssh

    that's all you need with Debian ... :P
    </shameless plug>

  7. #7

    Re:ssh prob

    <more plugs>
    cd /usr/ports/net/ssh/ && make install clean
    </modre plugs>

  8. #8

    Re:ssh prob

    yeah yeah ... :-[ : ;D

    So far I'm happy with my Suse and RedHat here at home.
    I installed Debian 3.0 at my PC at work and still have some problems ... First I need to get some things sorted with debian before trying it at home.

  9. #9
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:ssh prob

    [quote author=Ashcrow link=board=2;threadid=4062;start=0#40352 date=1025933170]
    <more plugs>
    cd /usr/ports/net/ssh/ && make install clean
    </modre plugs>
    [/quote]

    Why is it we like those blowfish and these goll darn red hats ?

    ;D

Similar Threads

  1. CPU Prob FC5
    By mojo jojo in forum Redhat / Fedora
    Replies: 5
    Last Post: 03-24-2006, 04:51 AM
  2. Prob when installing AA.
    By Zerone_null in forum Linux - General Topics
    Replies: 10
    Last Post: 03-22-2005, 05:32 AM
  3. Red Hat installation prob
    By kantplayalik in forum Linux - General Topics
    Replies: 2
    Last Post: 01-13-2005, 12:15 PM
  4. XFree86 4.xx prob
    By gmoreno in forum Linux - General Topics
    Replies: 2
    Last Post: 01-07-2003, 04:54 PM
  5. after install prob
    By harrison71 in forum Linux - General Topics
    Replies: 1
    Last Post: 06-25-2002, 02:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •