Results 1 to 5 of 5

Thread: compiling fluxbox thru cvs, got errors

  1. #1

    compiling fluxbox thru cvs, got errors


    i decided to try getting the cvs version rather than the source which has worked in the past. when i do the ./configure it tells me i need the x window system and libraries to continue. now this is in kde on drake im working on this so obviousy i have x installed. can anyone tell me what i need specifically?

    one other thing, i see that you can do updates for the cvs version. does that mean that after fluxbox is installed i can just do updates and it basically updates the software? thanks for any help.


  2. #2

    Re:compiling fluxbox thru cvs, got errors

    sounds like the configure can't find stuff - can ua do a ./configure --help - there should be options to include libs - e.g. /usr/X11R6/lib/

  3. #3

    Re:compiling fluxbox thru cvs, got errors

    hey paul, good to see you. here are my options:
    __________________________________________________ ________
    Usage: configure [options] [host]
    Options: [defaults in brackets after descriptions]
    --cache-file=FILE cache test results in FILE
    --help print this message
    --no-create do not create output files
    --quiet, --silent do not print `checking...' messages
    --version print the version of autoconf that created configure
    Directory and file names:
    --prefix=PREFIX install architecture-independent files in PREFIX
    --exec-prefix=EPREFIX install architecture-dependent files in EPREFIX
    [same as prefix]
    --bindir=DIR user executables in DIR [EPREFIX/bin]
    --sbindir=DIR system admin executables in DIR [EPREFIX/sbin]
    --libexecdir=DIR program executables in DIR [EPREFIX/libexec]
    --datadir=DIR read-only architecture-independent data in DIR
    --sysconfdir=DIR read-only single-machine data in DIR [PREFIX/etc]
    --sharedstatedir=DIR modifiable architecture-independent data in DIR
    --localstatedir=DIR modifiable single-machine data in DIR [PREFIX/var]
    --libdir=DIR object code libraries in DIR [EPREFIX/lib]
    --includedir=DIR C header files in DIR [PREFIX/include]
    --oldincludedir=DIR C header files for non-gcc in DIR [/usr/include]
    --infodir=DIR info documentation in DIR [PREFIX/info]
    --mandir=DIR man documentation in DIR [PREFIX/man]
    --srcdir=DIR find the sources in DIR [configure dir or ..]
    --program-prefix=PREFIX prepend PREFIX to installed program names
    --program-suffix=SUFFIX append SUFFIX to installed program names
    run sed PROGRAM on installed program names
    Host type:
    --build=BUILD configure for building on BUILD [BUILD=HOST]
    --host=HOST configure for HOST [guessed]
    --target=TARGET configure for TARGET [TARGET=HOST]
    Features and packages:
    --disable-FEATURE do not include FEATURE (same as --enable-FEATURE=no)
    --enable-FEATURE[=ARG] include FEATURE [ARG=yes]
    --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
    --without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
    --x-includes=DIR X include files are in DIR
    --x-libraries=DIR X library files are in DIR
    --enable and --with options recognized:
    --enable-shared[=PKGS] build shared libraries [default=yes]
    --enable-static[=PKGS] build static libraries [default=yes]
    --enable-fast-install[=PKGS] optimize for fast installation [default=yes]
    --with-gnu-ld assume the C compiler uses GNU ld [default=no]
    --disable-libtool-lock avoid locking (might break parallel builds)
    --with-pic try to use only PIC/non-PIC objects [default=use both] --with-x use the X Window System
    --enable-shape enable support of the XShape extension [default=yes]
    --enable-slit include code for the Slit [default=yes]
    --enable-newspec include code for the new WM Spec (DOES NOTHING)
    --enable-interlace include code for image interlacing [default=yes]
    --enable-ordered-pseudo include code for ordered pseudocolor (8bpp)
    dithering [default=no]
    --enable-debug include verbose debugging code [default=no]
    --enable-nls include natural language support [default=yes]
    --enable-timed-cache use new timed pixmap cache [default=yes]
    --enable-kde KDE slit support [default=no]
    --enable-gnome GNOME support [default=no]
    --enable-xinerama enable xinerama extension [default=no]
    [sd@localhost fluxbox]$

    __________________________________________________ _______

    options ive tried so far with the same x window error were:

    any options you might think would work instead?


  4. #4

    Re:compiling fluxbox thru cvs, got errors

    hi SD!!
    --x-libraries=/usr/X11R6/lib/ --x-includes=/usr/X11R6/include/X11/ is what i would try, the header are in there for good measure, although from what i see you may not need that.

  5. #5

    Re:compiling fluxbox thru cvs, got errors

    hey dude,

    i think i nailed it with a few urpmi commands. i got it working now, thanks


Similar Threads

  1. errors while compiling device drivers
    By yeah in forum Redhat / Fedora
    Replies: 1
    Last Post: 09-08-2007, 08:52 AM
  2. Fluxbox + gtk
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 03-24-2005, 12:13 AM
  3. Kernel Compiling Errors
    By N0thing in forum General Chat
    Replies: 3
    Last Post: 01-16-2005, 07:15 PM
  4. Errors compiling Gaim
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 03-22-2002, 02:17 PM
  5. Compiling MPlayer gives errors
    By in forum Linux - Software, Applications & Programming
    Replies: 18
    Last Post: 01-16-2002, 06:19 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts