Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Booting with Win2K
Results 1 to 7 of 7

Thread: Booting with Win2K

  1. #1
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Booting with Win2K

    I can't get lilo to recognise win2k and therefore have to boot linux with a bootdisk. Is there another boot loader that will work?? ie Grub. Or can I set up the 2K bootloader to do it?
    Cheers
    CP
    I'm using slack 8.1 now BTW

  2. #2
    Junior Member
    Join Date
    Jun 2001
    Posts
    51

    Re:Booting with Win2K

    Why doesn't lilo recognize W2K???
    Anyway, you can use W2K's bootloader:
    Copy the bootsector (supposing it's on hda2):
    # dd if=/dev/hda2 of=bootlinux bs=1 count=512
    Copy the file 'bootlinux' to C:\
    Edit C:\boot.ini, make it point to this file. (Only read about this, never tried it.)

  3. #3
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:Booting with Win2K

    so have I. It doesnt seem to work for me. The dd command does nothing. I know what it should do. But it doesnt. Lilo has trouble recognising my win partition. It is fat32 as well. So there should be no probs there. Would Grub work any better?

  4. #4
    Junior Member
    Join Date
    May 2002
    Posts
    50

    Re:Booting with Win2K

    I'm assuming that you installed LILO in the MBR ... I had a similar problem when I installed RH7.3 and just had to change my /etc/lilo.conf

    Do an fdisk -l /dev/hda if you dont know what partition XP is on, and then add something like the following to the end of your lilo.conf :


    other = /dev/hda?
    optional
    label = XP
    table = /dev/hda
    loader = /boot/chain.b


    Don't forget to run /sbin/lilo once you're all done modifying

    That fixed my prob., as I wasn't getting linux to even give XP as a boot option. Don't know if this will work exactly the same way since you're running Slack, but give it a try.

  5. #5
    Senior Member
    Join Date
    May 2001
    Posts
    472

    Re:Booting with Win2K

    Setup lilo so that it writes to your / partition. Then do the dd thing. Assuming your / is /dev/hdb1, do

    dd if=/dev/hdb1 of=/root/bootsect.lnx bs=512 count=1

    Then copy the /root/bootsect.lnx file to where NT/2k/XP can read it. Modify the c:\boot.ini file to have a reference to the bootsect.lnx file, and then when you reboot, NTLDR should give you a option to boot Linux (or whatever label you've given it).

  6. #6
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:Booting with Win2K


  7. #7
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:Booting with Win2K

    I have now got it working. I don't know why lilo wont work, and I don't even have a boot.ini file anywhere on my PC. I am using a bootloader called bootit NG or something along those lines. It is all gui and nice and does everything for me. I like it, and its easy. I also have lilo working for linux, so I can have multiple distros/kernels. Thanks for all the help guys.
    CP

Similar Threads

  1. Tomcat and Win2k
    By Ashcrow in forum Windows - General Topics
    Replies: 2
    Last Post: 11-18-2003, 12:37 PM
  2. Anyone want a job as a Win2k admin?
    By tolstoy in forum Windows - General Topics
    Replies: 1
    Last Post: 08-07-2003, 04:36 AM
  3. Linux or Win2k
    By tommyboy in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 02-24-2003, 04:18 PM
  4. Need help with LILO and WIN2K Please
    By papanohair in forum Linux - General Topics
    Replies: 6
    Last Post: 11-04-2002, 06:25 PM
  5. ^$#%^$# win2k sux0rz!!!!!!!!
    By Spot in forum Linux - General Topics
    Replies: 8
    Last Post: 02-20-2002, 12:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •