Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Tux
Results 1 to 8 of 8

Thread: Tux

  1. #1
    mugs
    Guest

    Tux

    I am trying to install "TUX" I get through ./configure, but when I type make, I get these errors. Please let me know what I am doing wrong or what I am missing. Thanks.




    linux:/home/mugs/Desktop/tux/tux_aqfh-1.0.13 # make
    Making all in src
    make[1]: Entering directory `/home/mugs/Desktop/tux/tux_aqfh-1.0.13/src'
    c++ -DPACKAGE=\"tux_aqfh\" -DVERSION=\"1.0.13\" -DHAVE_LIBGL=1 -DHAVE_LIBGLU=1 -DHAVE_LIBGLUT=1 -DHAVE_GL_GL_H=1 -DLINUX_JOYSTICK_IS_PRESENT=1 -DTUX_AQFH_DATADIR=\"/usr/local/share/games/tux_aqfh\" -I. -I. -g -O2 -O6 -Wall -c camera.cxx
    In file included from camera.cxx:1:
    tux.h:18: plib/ssg.h: No such file or directory
    In file included from tux.h:20,
    from camera.cxx:1:
    /usr/include/GL/glut.h:11: GL/glu.h: No such file or directory
    In file included from camera.cxx:1:
    tux.h:21: plib/ssgKeyFlier.h: No such file or directory
    tux.h:23: plib/sl.h: No such file or directory
    tux.h:24: plib/js.h: No such file or directory
    tux.h:25: plib/fnt.h: No such file or directory
    In file included from tux.h:60,
    from camera.cxx:1:
    penguin.h:11: plib/ssg.h: No such file or directory
    penguin.h:12: plib/ssgKeyFlier.h: No such file or directory
    In file included from tux.h:61,
    from camera.cxx:1:
    rocket.h:10: plib/ssg.h: No such file or directory
    In file included from tux.h:62,
    from camera.cxx:1:
    orca.h:11: plib/ssg.h: No such file or directory
    orca.h:12: plib/ssgKeyFlier.h: No such file or directory
    make[1]: *** [camera.o] Error 1
    make[1]: Leaving directory
    `/home/mugs/Desktop/tux/tux_aqfh-1.0.13/src'
    make: *** [all-recursive] Error 1

  2. #2
    Aaron_Adams
    Guest

    Re:Tux

    From the looks of the errors you don't have the plib library installed. You can get it here http://plib.sourceforge.net

    Also the line :
    /usr/include/GL/glut.h:11: GL/glu.h: No such file or directory
    Would make me think you might not have OpenGL installed which may be required.

    Your best bet is to install the plib library and try again.

    Good Luck

  3. #3
    mugs
    Guest

    Re:Tux

    thanks. I tried to install PLIB, but got the same error of :

    linux:/home/mugs/Desktop/plib-1.4.2 # make
    Making all in src
    make[1]: Entering directory `/home/mugs/Desktop/plib-1.4.2/src'
    Making all in util
    make[2]: Entering directory `/home/mugs/Desktop/plib-1.4.2/src/util'
    c++ -DPACKAGE=\"plib\" -DVERSION=\"1.4.2\" -DHAVE_LIBDL=1 -DHAVE_LIBGL=1 -DHAVE_LIBGLU=1 -DHAVE_LIBGLUT=1 -DSTDC_HEADERS=1 -DHAVE_GL_GL_H=1 -DLINUX_JOYSTICK_IS_PRESENT=1 -I. -I. -I/usr/local/include -g -O2 -O6 -Wall -c ul.cxx
    In file included from ul.cxx:25:
    ul.h:82: GL/glu.h: No such file or directory
    make[2]: *** [ul.o] Error 1
    make[2]: Leaving directory `/home/mugs/Desktop/plib-1.4.2/src/util'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/mugs/Desktop/plib-1.4.2/src'
    make: *** [all-recursive] Error 1
    linux:/home/mugs/Desktop/plib-1.4.2 #

    So, I guess I need OpenGL. When I searched for it, it seemed to say it was for Windows. Can you kindly tell me where to get it?

    Thanks

  4. #4
    Aaron_Adams
    Guest

    Re:Tux

    OpenGL support is supplied by your videocard drivers. So depending on what card you have, I can tell you what drivers to download

  5. #5
    mugs
    Guest

    Re:Tux

    Thanks, I have NVIDIA GEFORCE 2 with 64MB. I saw that OpenGL was supposed to be part of the distro....?

  6. #6

    Re:Tux

    you might still need the nvidia drivers. get them from www.nvidia.com
    whatdoyougetwhenyoumultiplysixbynine??

  7. #7
    mugs
    Guest

    Re:Tux

    I already have the correct NVIDIA drivers.

  8. #8
    mugs
    Guest

    Re:Tux

    Maybe I am getting the hang of this thing...but mostly it is because all of the good advice I get here on GLO...but I got it installed. Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •