Results 1 to 3 of 3

Thread: Problems mounting NTFS partition

  1. #1

    Problems mounting NTFS partition

    Hello there folks,

    I have recently installed Debian Woody to dual boot with XP on my main box. Everything is moving along even if somewhat slowly but have a few probs that i can't seem to shift. NTFS partition mounting being the question here.

    I have the following entry in my fstab:

    /dev/hde5 /mnt/store ntfs defaults,ro,user 0 0

    now the partition mounts alright and i can mount it and unmount it even as a user but i can only browse it as root.

    I followed pbharris's PET on but seem to have everything that he says to do done.

    What i have found out is that the permissions for /mnt/store change from this when the partition is umounted, which is the same as all the other mount points on my system
    drwxr-xr-x 2 root root 4096 Jun 11 2002 store
    to this
    dr-x------ 1 root root 4096 Jan 2 17:38 store
    when it is mounted

    what am i doing wrong? It really does seem rather odd to me as it is the only partition that gave this problem and i set them all up at the same time.



    Under the guidence of SpookyEddy I tried this to mount the partition
    mount -t ntfs -o umask=644 /dev/hde5 /mnt/store
    this changes the permissions of the directory to
    dr-xr-x--x 1 root root
    well with this mount method i can now browse to the directory /mnt/store as user, couldn't do that before but i still can't see anything in the partition although root sees all
    compairing the permissions to the other mount points there seemse to be a 'r' read permission still missing.

    ps i tried making a mount point as user in the home directory but still no change

    FINAL UP-Date

    Thanks to Spookeddy for this link

    fstab line now looks like this
    /dev/hde5 /mnt/store ntfs defaults,ro,user, umask=002,gid=100 0 0

    now all is sorted
    thanks eddy

  2. #2

    Re:Problems mounting NTFS partition

    thanks griobhta!

  3. #3

    Re:Problems mounting NTFS partition

    Thank you, griobhta, for posting here a solution that was worked out elsewhere, I had been browsing my ntfs partitions by suing to root and using the command line for a few months, now I can finally mount them user readable, thank you.
    And to those who helped you, well, they have helped me too.

Similar Threads

  1. Mounting NTFS
    By veejay in forum Linux - General Topics
    Replies: 2
    Last Post: 09-18-2003, 05:00 PM
  2. Problems mounting winXP partition ...
    By bafalouk in forum Linux - General Topics
    Replies: 3
    Last Post: 05-31-2002, 08:13 PM
  3. Mounting WinXP NTFS partition
    By mariusdumitrache in forum Suse
    Replies: 11
    Last Post: 05-28-2002, 05:20 PM
  4. 7.3 Having trouble mounting NTFS
    By InvidMatrix in forum Redhat / Fedora
    Replies: 1
    Last Post: 05-10-2002, 09:22 PM
  5. NTFS mounting
    By RAGEAngel9 in forum Linux - General Topics
    Replies: 1
    Last Post: 01-31-2002, 02:44 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts