eth0 = 216.x.x.x real connection to the internet. Working
eth1 = 192.168.0.1 gate to lan / win word
I am trying to get iptables to work on slack8
I used the script from the PET section on sharing.

Code:
#!/bin/bash 
# Load the NAT module (this pulls in all the others). 
/sbin/modprobe iptable_nat 
/sbin/modprobe ip_conntrack_ftp 
/sbin/modprobe ip_nat_ftp 


# MASQUERADE the connection (-j MASQUERADE). 
/sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE 
# Turn on IP forwarding 
echo 1 > /proc/sys/net/ipv4/ip_forward
Thats script gets called at boot time by rc.local.
After I reboot i do iptables -L and get error see below.
Code:
root@serverx:~# iptables -L                         
iptables v1.2.2: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
root@serverx:~#
Any ideas. I am coming off of ipchains.
Thanx fellas