Quote Originally Posted by jmcdaniel View Post
I finally understand now. Has been in front of me the whole time. Unfortunately, it was contained in serveral different posts.

Without recapping the above. I needed dhcpd to serve addresses for X number of VLANs. While not serving the subnet dhcpd is actually on. The individual VLANs are NOT on the same subnet (DO NOT USE shared-network).
I just never saw a post with a complete config.

Instead, delare the dhcpd servers own subnet.

# i.e. your dhcp servers interface is: 172.16.0.25/24

subnet 172.16.0.0 netmask 255.255.255.0 {
}

#This will get rid of the error received about not having #an ethernet adaptor attached to the networks your #serving. That error is specifically for this subdomain. It #is not necessary to create additional subinterfaces or #even add addition network cards for the subnets you #wish to serve.

#NOW add the additional subnets you are serving:

subnet 10.200.10.0 netmask 255.255.255.0 {

option routers 10.200.10.1;
range 10.200.10.20 10.200.10.100;
}

subnet 10.200.20.0 netmask 255.255.255.0 {

option routers 10.200.20.1;
range 10.200.20.20 10.200.20.100;
}

subnet 10.210.20.0 netmask 255.255.255.0 {

option routers 10.210.20.1;
range 10.210.20.20 10.210.20.100;
}
#... etc ...

#DONE

The first example given above is how to extend a network that the given subnets ARE on the same network. They would have a router elsewhere joining them. While my routers are keeping them separate with inter-vlan routing (actually here I'm using a layer 3 switch).

SHARING THE SAME WIRE. Well in a sense both of them do. I didn't physically separate the network. However, I am logically separating it by the use of VLANs. So, if your network is using VLANs, they DO NOT use the "same" wire. That being said. I understand how mine is working with VLANs, I still don't understand how to use "shared-network" from the example given above without breaking something. It would appear some networks would still get the wrong information without them sharing the same gateway?

Thanks! this trick was what I was looking for!