I followed the instructions at iptablesrocks.org to set up a firewall for my home network. It's working great, and I can see the benefits immediately just by checking the logs.

Problem is I have this box connected to 3 other windows machines and 1 mac via samba. Samba worked beautifully before I installed the iptables rules. I've scoured the web for instructions on how to fix this, but can't seem to get it working. Any assistance would be greatly appreciated.

ifconfig results:

Code:
eth0      Link encap:Ethernet  HWaddr 00:08:74:C2:95:16  
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::208:74ff:fec2:9516/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:101305914 errors:684749 dropped:331602 overruns:0 frame:115992
          TX packets:203890532 errors:0 dropped:0 overruns:0 carrier:12
          collisions:0 txqueuelen:1000 
          RX bytes:564101728 (537.9 Mb)  TX bytes:3956813268 (3773.5 Mb)
          Interrupt:11 

eth1      Link encap:Ethernet  HWaddr 00:00:C5:53:21:88  
          inet addr:192.168.1.110  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::200:c5ff:fe53:2188/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:7335394 dropped:0 overruns:0 frame:0
          TX packets:0 errors:24 dropped:0 overruns:0 carrier:67
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:3087675 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3087675 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1098955532 (1048.0 Mb)  TX bytes:1098955532 (1048.0 Mb)
Kind regards,
Michael