I have a 3com WiFi Access point/Firewall/Router which also supports 4 wired cat V connections.

I have been using it with windows machines for a about a year with no major problems.

I recently tried to add a wired linux machine to the network.

The machine had previously worked through the router as a wired windows xp machine.

I have now installed an old copy of Mandrake 9.0.

It's installed fine and everything seems to be working.

Except I can't get the networking to work as expected.

Using drakxconf I can configure the ethernet and that seems to run up ok. I tried using DHCP to gain a lease from the router this didn't work. I wasn't surprised by that so I assigned a static IP address outside the routers DHCP range.

The router issues leases in the range -

I assigned the static address to the linux machine and all looks good until I try to ping.

If I try to ping the router on I get no responce. If I try to ping the linux machine from a wireless windows machine I get no responce.

This is where it gets strange, although I get no responce from the linux box if I look at the arp table on the linux machine I can see the MAC addess of the windows machine that just tried to ping it.

Anyone got any ideas or think they can solve it with more info let me know.

Many Thanks.