Results 1 to 6 of 6

Thread: Help me get my Gentoo on

  1. #1

    Help me get my Gentoo on

    Really my only problem is internet. That's all. I looked through the installation instructions on the Gentoo CD, and there's no mention at all of how to set up and configure a pppoe connection (I'm with Bell Sympatico ADSL). It gives instructions for dhcp, but not pppoe. I tried downloading some pppoe utitlites from the net (the utitlites on sympatico's site, and roaring penguin), but none of them worked. My guess is that the kernel on the Gentoo cd doesn't support pppoe. Here's my question: can anyone point me in the right direction as to how to get my adsl connection up and running on the gentoo installation system? There are a lot of things that need to be downloaded from the net during the installation, and until I can get this connection up, I'm stuck in windows due to a half-installed gentoo. Thanks a lot.

  2. #2
    Advisor Outlaw's Avatar
    Join Date
    May 2001
    Clifton Park, NY

  3. #3

    Re:Help me get my Gentoo on

    Whoops. Didn't check the gentoo site :-[ Sorry 'bout that...I could have done that myself if I weren't such an idiot.

    But thank you very much for the link radar. This will probably do well.

  4. #4

    Re:Help me get my Gentoo on problem. I'll try to explain as best I can.

    A stage 3 gentoo install makes you create your partitions, create the filesystems, extract a full system onto those filesystems, then chroot to where you extracted. Just before you chroot, you're supposed to copy /etc/resolv.conf to /mnt/gentoo/etc/resolv.conf (before chroot /mnt/gentoo /bin/bash). Once you chroot to /mnt/gentoo, you can install and set up the adsl connection using emerge and roaring penguin. Once that's done, I type "adsl-start" and it tells me that it's connected. ifconfig says that a pppoe connection is up and that I have an ip address. I can ping ip addys. However, when I try to type in an url with wget, it can't resolve anything. This hints VERY strongly at a dns problem. I believe it's because sympatico sends me my dns information automatically once I log in, and /etc/resolv.conf is from the old ramdisk system (and not /mnt/gentoo), which was created before the adsl connection went up. Here's my question: I probably used to know this, but my linux skills are a little rusty. Is it possible to get the dns information that your isp sends you and put it into /etc/resolv.conf?

  5. #5

    Re:Help me get my Gentoo on

    Nevermind. I got a friend to give me the DNS. Works like a charm now. Gentoo is up and relatively running (X and KDE are currently being thrown on, soon to be followed by fluxbox and Gnome 2.0, and the software collection begins anew). Portage is absolutely fabulous thus far, and the entire system is looking very slick, and feeling very fast. First impressions of Gentoo are very positive. Thanks again for that link Radar. It really got things moving.

  6. #6
    Advisor Outlaw's Avatar
    Join Date
    May 2001
    Clifton Park, NY

    Re:Help me get my Gentoo on

    Cool. Glad I could help.

Similar Threads

  1. Welcome to Gentoo
    By JimH in forum Linux Distros
    Replies: 11
    Last Post: 03-07-2008, 05:29 AM
  2. Gentoo...
    By sujoki in forum Linux - General Topics
    Replies: 10
    Last Post: 08-19-2003, 09:00 AM
  3. Gentoo?
    By Scott_Tiger in forum Linux - General Topics
    Replies: 7
    Last Post: 05-29-2003, 10:56 PM
  4. Gentoo
    By Ashcrow in forum Linux - General Topics
    Replies: 8
    Last Post: 08-15-2002, 05:40 AM
  5. Gentoo again
    By Black666 in forum Linux - General Topics
    Replies: 3
    Last Post: 07-18-2002, 06:05 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts