Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
nvidia drivers
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: nvidia drivers

  1. #1

    nvidia drivers

    So far this weekend I've borked my redhat X install trying to install the new nvidia drivers.
    I just reinstalled redhat and before I edit the xconfig I want to know what the error messages mean.

    I get this message when installing the kernel package

    Code:
    <iel/NVIDIA_kernel-1.0-2313.rh72up_2.4.9_13.i386.rpm;echo RESULT=$?
    depmod: *** Unresolved symbols in /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol __put_user_4
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_write_config_word_Rd9cc3b03
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_write_config_dword_Rf0fbd200
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_read_config_dword_R2ca7e89f
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_read_config_byte_Re5ceea13
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol proc_root_R335ce3b5
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol create_proc_entry_Ra929423e
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol get_module_symbol_Ref198940
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol local_irq_count_R4d40375f
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol init_mm_R3cf71ae9
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol tq_immediate_R2e2d1553
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol bh_active_Rfff9d0a3
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_write_config_byte_Re84d5397
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol boot_cpu_data_R4d12d1d7
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol remove_proc_entry_Reb54c4b7
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_find_slot_R454463b5
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_find_device_R0ee75d4c
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol __wake_up_Rb2c45411
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol vmalloc_Rd6ee688f
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_devices_R3b428c78
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol mem_map_R45bda6e2
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol __pollwait_R97033cd1
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol vsprintf_R13d9cea7
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol local_bh_count_R4f976bf9
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol pci_read_config_word_R8764d15f
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: unresolved symbol register_chrdev_R612b1a58
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: insmod /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver failed
    /lib/modules/2.4.9-13/kernel/drivers/video/NVdriver: insmod NVdriver failed
    
    NVdriver installed successfully
    For the GLX package i get this error
    Code:
    <U --replacepkgs //home/daniel/NVIDIA_GLX-1.0-2313.i386.rpm;echo RESULT=$?
     --- WARNING!!
       libglx.a
       libGLcore.a
       libGL.a
       libGL.so.1.2.030402
     --- The above file(s) possibly belong to a conflicting MESA rpm.
     --- They have been renamed to xxx.<originalFile>.RPMSAVE to
     --- avoid conflicting with the files contained within this
     --- package.
     --- Please see /usr/share/doc/NVIDIA_GLX-1.0/README, section
     --- "(sec-05) FREQUENTLY ASKED QUESTIONS" for more details.
    I downloaded the redhat 7.2 single proc updated kernel package. I've gone through up2date and have all the updated packages and thats where I got the new kernel from. Anyonw know what the problem could be?

  2. #2

    Re: nvidia drivers

    If you reboot and then try startx, does it work? It does say that the nvidia driver was installed successfully, but it has problems inserting the module. Just a thought, as I had similar problems when I was trying to install lmsensors. There were all sorts of complaints whenever I tried insmod, but it always did insert the module no matter how loud it was about it.

  3. #3

    Re: nvidia drivers

    ya last time x wouldn't start and wine didnt' start either

  4. #4

    Re: nvidia drivers

    the last version of the drivers I used I had to make from source rpm but they installed perfectly with no error messages

  5. #5

    Re: nvidia drivers

    anyone at all? I heard these drivers are quite a bit better and would hate to have to go back to the old ones.

  6. #6

    Re: nvidia drivers

    rebooting and starting x does not work. What is wrong??? Can someonehelp me pleaseeeeeee

  7. #7

    Re: nvidia drivers

    hello,
    make sure yopu have the kernel source installed and try getting the .tar.gz files - these work very good for me.

  8. #8
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re: nvidia drivers

    Well, I am assuming the rpm's are built for the wrong kernel version. Since you dont want to downgrade your kernel, grab as pbharris-USA said, the tarballs and compile them yourself. That will solve any major problems you have. The new drivers kick butt for me, at least.

  9. #9

    Re: nvidia drivers

    I had the exact same problem, make sure the kernel headers are installed and grab the nvidia tar.gz (kernel module and Opengl driver).

    The first error message is caused by the nvidia kernel module not finding the correct headers. The second message is not really an error just a warning that it backed up your old drivers.

  10. #10

    Re: nvidia drivers

    I installed the kernel source. I did up2date and updated to kernel 2.4.9-13 which is the version of the drivers I downloaded. I tried the i386 and i686 both had the same result. So your saying I should try the source and not the rpms?

Similar Threads

  1. Nvidia drivers again
    By mojo jojo in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 12-05-2003, 12:28 AM
  2. nVidia Drivers
    By stryder144 in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 10-02-2003, 11:00 AM
  3. Nvidia Drivers
    By stodgel in forum Mandriva
    Replies: 1
    Last Post: 04-05-2003, 05:38 PM
  4. New NVidia drivers are out.
    By pbharris in forum Linux - Software, Applications & Programming
    Replies: 33
    Last Post: 01-19-2003, 02:59 AM
  5. Nvidia drivers
    By binary_boy in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 03-27-2002, 12:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •