Results 1 to 10 of 10

Thread: configure X with debian (nvidia?)

Hybrid View

  1. #1

    configure X with debian (nvidia?)

    hi,

    just did an install of debian woody. not too sure of the right order of things but this is how i did this. after installing the base system from cd i configured apt-get from ftp.
    i then installed xfree 86, then x-window-system. i ran xf86config during the setup of x. i installed kde and gnome.
    but....when i try to run "X" or startx i get:
    "Fatal error, no screen found"

    is this a vidoe driver issue? if so because i havent installed Nvidia drivers nor do i know how to in debian. i only see the tarball's and rpm on nvidia's site. any idea what my fix is?

    thanks
    SD

  2. #2
    Guest

    Re: configure X with debian (nvidia?)

    Anything in your messages file ?

    and check your refreshrates and your default ColorDepth in /etc/X11/XF86Config-4

  3. #3

    Re: configure X with debian (nvidia?)

    "Fatal error, no screen found"
    I have two wild guesses that might help you track down the solution:

    1. export DISPLAY=":0.0"

    Maybe your $DISPLAY env variable is not set and it doesn't like that.

    2. Check your XFree86 config file and make sure that it has a default screen size & resolution defined (it should, if you ran the X configuration script).

  4. #4

    Re: configure X with debian (nvidia?)

    hi SD,
    i am guesisng your /etx/X11/XF86config file is messed up. here is mine, it does have stuff for the nvidia drivers, change "driver nvidia" to "driver nv" and uncomment the GLcore stuff and dri stuff for default settings

    http://members.telocity.com/cph013/XF86Config-4

  5. #5

    Re: configure X with debian (nvidia?)

    hey thanx for the replies. even though i specified names(monitor, vid card) when i ran xf86config, they werent there when i went to have a look.(default, it said) anyhow, i got it down to where it says "screen found, but no usable configuration"
    im thinking maybe becasue i dont have the right vertical refresh and horiz. sync? *i dont know them from this monitor. its a sun microsystems 19" and i dont have the manual. *could i use all or part of my xf86config-4 from my mandrake system? just a thought. ok, i just printed it out and im gonna get back at it to try some more. should i have NOT used debconf during the install?

    SD

  6. #6

    Re: configure X with debian (nvidia?)

    hey, with some help from a friend it was the line:
    option "use FBDev" "True"
    this friggin line had to be commented out in order to get X to run. im now posting this successfull with mozilla on X. too bad i have no clue how to maximize the browser! hehe. now if i can get kde and gnome up and running i might be happy and start getting some serious use with debian!

    SD

  7. #7

    Re: configure X with debian (nvidia?)

    I believe that you only have the base XF86 packages installed, but no servers. Try apt-getting the xserver-xfree86 package (this is 4.1.) I've had this problem before, and I think this was the solution.

  8. #8

    Re: configure X with debian (nvidia?)

    Did you solve the problem?

  9. #9

    Re: configure X with debian (nvidia?)

    I had the same problem last night with woody. I couldn't install the nvidia drivers, tried a few different things. I persisted wihtout them and found that when running "dpkg-reconfigure xserver-xfree86" that the use kernel framebuffer device needed to be switched off ie, selected as no. I used the nv driver and all is well. I also installed wmaker, plus the xservers. HAven't got KDE2 working yet though.

    Cheers,

    Lew

  10. #10

    Re: configure X with debian (nvidia?)

    Hope all is well now Bill, I installed the nvidia.com drivers on Woody and Slack over the weekend. Just download the tarballs:

    http://205.158.109.140/XFree86_40/1.....0-2313.tar.gz

    http://205.158.109.140/XFree86_40/1.....0-2314.tar.gz

    and do the following:

    cp NVIDIA* /usr/local
    tar xvzf NVIDIA_kernel.tar.gz
    tar xvzf NVIDIA_GLX.tar.gz
    cd NVIDIA_kernel
    make install
    cd ../NVIDIA_GLX
    make install


    open /etc/X11/XF86Config-4. Uncomment the

    Load * * *"glx"

    line and change the driver line from nv to nvidia like so:

    Section "Device"
    * * *Identifier * * *"NVIDIA"
    * * *Driver * * * * * *"nvidia"
    * * *VideoRam * * *32000
    EndSection


    That's it, restart X

Similar Threads

  1. How to configure squid server in debian 6
    By gyan in forum Ubuntu / Debian
    Replies: 0
    Last Post: 09-26-2011, 07:44 AM
  2. Configure Kppp on FC6
    By omidkamangar in forum Redhat / Fedora
    Replies: 1
    Last Post: 06-21-2007, 06:25 PM
  3. What is the mouse configure applet in debian?
    By AljoshaNL in forum Linux - General Topics
    Replies: 0
    Last Post: 11-16-2005, 05:14 PM
  4. Cannot configure my dsl
    By bleeding toejam in forum Mandriva
    Replies: 5
    Last Post: 04-08-2002, 04:29 PM
  5. Configure ftp
    By benny666 in forum Linux - Hardware, Networking & Security
    Replies: 9
    Last Post: 03-04-2002, 12:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •