Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: DRI/GLX Again

  1. #11

    Re: DRI/GLX Again

    Come on! ;D

  2. #12

    Re: DRI/GLX Again

    So from your quotes you can see that it isnt using DRI.

    Have you checked the var/log/XFree86.0.log file to see what that has to say? (search for EE)

    Your lsmod says that agpgart is unused, not sure whether this is because of the radeon card not being used by XFree86 or not, but check your bootup messages (or use dmesg) and look for lines like:

    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 380M
    agpgart: Detected Via Apollo Pro chipset
    agpgart: AGP aperture is 64M @ 0xd0000000

    Obviously if you have a different chipset it will say something else on the 'Detected' line.

  3. #13

    Re: DRI/GLX Again

    Code:
    [ash@gnulinux ash]$ grep agpgart dmesg.txt 
    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 321M
    agpgart: Detected AMD Irongate chipset
    agpgart: AGP aperture is 128M @ 0xd8000000
    after a reboot I lsmoded and now agpgart is on autoclean.

    Code:
    [root@gnulinux log]# grep EE XFree86.0.log 
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) Failed to load module "px5" (module does not exist, 0)
    (EE) RADEON(0): [agp] AGP not available
    (EE) RADEON(0): [drm] failed to remove DRM signal handler
    Code:
    [root@gnulinux log]# grep EE XFree86.8.log 
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) RADEON(0): [dri] RADEONInitVisualConfigs failed (depth 8 not supported). Disabling DRI.

  4. #14

    Re: DRI/GLX Again

    Either this is lame..or there's a characher missing.

    Code:
    Section "DRI"
    Above your's only had 1 quote, was that a miss copy or is that really the way it is?

    The other possiblity is to remove the rest of the crap with 8 bit.

  5. #15

    Re: DRI/GLX Again


    Either this is lame..or there's a characher missing.
    Code:
    Section "DRI"
    Above your's only had 1 quote, was that a miss copy or is that really the way it is?
    The other possiblity is to remove the rest of the crap with 8 bit.
    Yeah, I added the closing " and it had no effect. I went ahead and removed the 8 bit stuff so that only 24 bit (my default) is there. Still no direct rendering.

    Checking lsmod again agpgart is abck to being unused :-(.

  6. #16

    Re: DRI/GLX Again

    Not sure if it makes any difference but I use the ati driver in XFree86Config rather than vga or radeon.
    My Device section looks like:

    Section "Device"

    Identifier "Radeon"
    Driver "ati"
    VendorName "ATI"
    Option "AGPMode" "2"

    EndSection

    XFree86 then identifies what sort of card I have (in this case probably a Radeon QD) and loads a radeon submodule.
    In XFree86.0.log you should have lines saying that it has identified your card:

    (II) ATI: ATI driver (version 6.4.8) for chipsets: ati, ativga
    .
    .
    .
    (--) Chipset ATI Radeon QD (AGP) found

  7. #17

    Re: DRI/GLX Again

    Since linux is like opinions...my XF86Config-4 looks slightly differant.

    Code:
     
        Identifier "Card0"
        Driver   "radeon"
        VendorName "ATI"
        BoardName  "Radeon QD"
    Arr..Much as I don't want to say it, it appears Mesa isn't installed. I say this because..

    Code:
    OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr, 
    GL_EXT_blend_func_separate, GL_EXT_clip_volume_hint, 
    GL_EXT_compiled_vertex_array, GL_EXT_histogram, GL_EXT_packed_pixels, 
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_stencil_wrap, 
    GL_EXT_texture3D, GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
    GL_EXT_texture_env_dot3, GL_EXT_texture_object, GL_EXT_texture_lod_bias, 
    GL_EXT_vertex_array, GL_MESA_window_pos, GL_MESA_resize_buffers, 
    GL_NV_texgen_reflection, GL_PGI_misc_hints, GL_SGIS_pixel_texture, 
    GL_SGIS_texture_edge_clamp


  8. #18

    Re: DRI/GLX Again

    I have Mesa-3.4.2 installed. <http://www.linuxjunior.org/YaBBImages/huh.gif>

  9. #19

    Re: DRI/GLX Again

    After wading through a few things I saw 3 differant mesa libs installed. xlibmesa3, xlibosmesa3, and xlibmesa-dev.

    In my XF86Config-4 file I have a "dbe" sadly I have no clue what it does, and apt is being less than useful.

    Another wild ass idea but I see that you have an endsection directly above a section for the DRI info. You might want to put the endsection up a line and leave one blank between the two. Not sure if it'll work but it can't hurt to try.

  10. #20

    Re: DRI/GLX Again

    I gave it a try and still no go. Argh, the humanity! It worked on an earlier install with the modified XFree86-4 that was posted but that config isn't considered valid (errors for bad syntax).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •