Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: DRI/GLX Again

  1. #1

    DRI/GLX Again

    Darn it! I can't get any decents FPS. All 3D stuff id all choppy :-[. I'm using XFree86-4.1.0 with a AGP Radeon (with the driver insmoded of course). Here is my XF86Config-4
    # This loads the DBE extension module.
      Load    "dbe"    # Double buffer extension
      Load    "extmod"
    # This loads the miscellaneous extensions module, and disables
    # initialisation of the XFree86-DGA extension within that module.
      SubSection "extmod"
       Option  "omit xfree86-dga"  # don't initialise the DGA extension
    # This loads the Type1 and FreeType font modules
      Load    "type1"
      Load    "freetype"
    # This loads the GLX module
      Load    "glx"
      Load    "dri"
      Load    "xie"
      Load    "record"
      Load    "pex5"
    <skip fonts/input devices>
    Section "Monitor"
      Identifier "My Monitor"
      HorizSync  31.5 - 82.0
      VertRefresh 40-150
    Section "Device"
      Identifier   "Card0"
      VendorName   "ATI"
      BoardName   "Radeon QD"
      Driver   "vga"
    Section "Device"
      Identifier "ATI Radeon AGP"
      Driver   "radeon"
      BoardName "Radeon QD"
      VideoRam  64000
    Section "Screen"
      Identifier "Screen 1"
      Device   "ATI Radeon AGP"
      Monitor   "My Monitor"
      DefaultDepth 24
      Subsection "Display"
        Depth    8
        Modes    "640x480" "800x600" "1024x768" "1280x1024"
        ViewPort  0 0
      Subsection "Display"
        Depth    16
        Modes    "640x480" "800x600" "1024x768" "1280x1024"
        ViewPort  0 0
      Subsection "Display"
        Depth    24
        Modes    "1600x1200"
        ViewPort  0 0
    Section "ServerLayout"
       Identifier "Simple Layout"
      Screen "Screen 1"
      InputDevice "Mouse1" "CorePointer"
      InputDevice "Keyboard1" "CoreKeyboard"
    Section "DRI
      Mode 0666

  2. #2

    Re: DRI/GLX Again

    pwetty pweeese :P

  3. #3

    Re: DRI/GLX Again

    Umm, why are you using the vga driver? You should be using the radeon driver. It might behoove you to change "vga" to "radeon".

  4. #4

    Re: DRI/GLX Again

    I tried changing it to radeon and it has the same effect. No diffrence :-(.

  5. #5

    Re: DRI/GLX Again

    was it ASCI_Blue who had the same problems... It might be mesa... no ?

  6. #6

    Re: DRI/GLX Again

    Try going to the DRI website.

  7. #7

    Re: DRI/GLX Again

    I got the latest dri/drm modules and compiled them. I can't insmod them into the kernel though (except radeon.o, that works fine...).

    [root@gnulinux drm]# /sbin/insmod radeon_state
    Using /lib/modules/2.4.9-21/kernel/drivers/char/drm/radeon_state.o
    Warning: loading /lib/modules/2.4.9-21/kernel/drivers/char/drm/radeon_state.o will taint the kernel: no license

    [root@gnulinux drm]# /sbin/insmod radeon_drv.o
    radeon_drv.o: unresolved symbol cmpxchg
    [root@gnulinux drm]#

    Also, I tried running the utility for checking the configuration and here is the output ....

    [root@gnulinux ash]# ./DRIsetup-linux-i386

    Direct Rendering Infrastructure testing program

    Checking your system.......

    Your config file is /etc/X11/XF86Config-4
    Your module path is /usr/X11R6/lib/modules
    You are running in GLX Indirect Rendering Mode
    The kernel module has not been loaded
    [root@gnulinux ash]#

  8. #8

    Re: DRI/GLX Again

    I think that radeon_drv.o is actually an XF4 driver, not a kernel module. Try putting it into /usr/X11R6/lib/modules/drivers

  9. #9

    Re: DRI/GLX Again

    I too use a radeon with linux, sadly the open source drivers arent up to the standards of nvidias closed ones yet :/
    I get about maybe 30% lower framerate under linux thatn win 98

    I assume you have direct rendering enabled ? use glxinfo to find out,

    Just reread your last post which says direct rendering disabled, are you laoding the radeon kernel module (use lsmd to check )

    Also you need to make sure the agp module is being used by the kernel (use dmesg and you should see something about agp)

    A good checklist is here:

  10. #10

    Re: DRI/GLX Again

    [ash@gnulinux ash]$ /sbin/lsmod 
    Module         Size Used by
    agpgart        26144  0 (unused)
    sr_mod         14936  0 (autoclean)
    emu10k1        51268  0 (autoclean)
    soundcore        4196  4 (autoclean) [emu10k1]
    binfmt_misc       6052  1
    radeon         94008  0
    tulip         37696  2
    ipchains        36424  1
    ide-scsi        7904  0
    scsi_mod        94648  2 [sr_mod ide-scsi]
    ide-cd         26560  0
    cdrom         29568  0 [sr_mod ide-cd]
    usb-ohci        18144  0 (unused)
    usbcore        49920  1 [usb-ohci]
    ext3          59808  2
    jbd          39076  2 [ext3]
    [ash@gnulinux ash]$ glxinfo 
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: No
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
      GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    client glx vendor string: SGI
    client glx version string: 1.2
    client glx extensions:
      GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    GLX extensions:
      GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
    OpenGL vendor string: VA Linux Systems, Inc.
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 Mesa 3.4.2
    OpenGL extensions:
      GL_ARB_multitexture, GL_EXT_abgr, GL_EXT_blend_color, 
      GL_EXT_blend_minmax, GL_EXT_blend_subtract
    glu version: 1.3
    glu extensions:
      GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
      visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
     id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
    0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    0x25 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
    0x26 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
    I upgraded to XFree86-4.2.0 to see if it was a quick fix and nothing happened. Same slow problem.

    I tried using the actual x modules from the dri sourceforge site and they just cause the X server to crash complaining about not having a specific obj in radeon_drv.o or radeon.o.

    I seem to always run int oDRI problem :-(.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts