Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
x trouble with RH 7.3
Results 1 to 6 of 6

Thread: x trouble with RH 7.3

  1. #1

    x trouble with RH 7.3

    i've just tried installing RH 7.3 on an extra computer, and i can't seem to get X working. the install goes fine, and when it asks me if i want to test my settings, everything shows up fine. when i reboot, though, x won't work. if i set it for graphical login (this is for my parents) the monitor turns off, on, off, on, off, on, etc. when x tries to start. why would it work during anaconda, but not on reboot? the graphics cards is an ATI Rage Fury Maxx (dual ATI Rage 128s) and the monitor is a crappy 15" something. i've tried changing all the settings for the exact on the monitor, and i've tried the ATI Rage that it defaults to as well as the ATI Rage (generic) setting, but that doesn't help. there is no specific entry for Rage Fury Maxx (and i'm pretty sure the only difference is there are two GPUs). if this is a graphics card problem, and no one can figure it out (so far i can't) i can always just drop in an old card that i know works, but i'd rather use this one if i can. again, what is the most confusing is that when anaconda sets up x, and asks to test, the desktop shows up fine...but reboot gives me an unusable computer (since it tries to go straight to x, but can't). any ideas?

  2. #2
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re: x trouble with RH 7.3

    Drop into a CLI screen and look for your X logfile (in your /var/log directory)

    Post it here Ill figure it out. It may be rather obvious, perhaps not. Please do look at it before you post and see if the error makes sense.

    If X doesnt load right, or dies for some reason, you will have a log of at least some data to help figure out why.

  3. #3

    Re: x trouble with RH 7.3

    Run 'setup' or 'xf86config' again, and reset the video. I had the same trouble. X worked find, but once it came to running the DM, it would flash the screeen several times, and then stop. Of course once you think about it, the kernel is being replaced, and the drivers are not being compiled into it.

  4. #4

    Re: x trouble with RH 7.3

    i would post the logfile, but i can't even get to a command line (for the convenience of my parents, it is set to grapical login). i also can't run xf86configurator (or whatever it is called) because, again, i can't get to the command line. usually it clicks the monitor on and off until i get tired of waiting and hit cntrl-alt-delete to shutdown and reboot. i can't cntrl-alt-f1 (or anything else) to another virtual terminal...i guess there aren't any. i can't even cntrl-z to kill the attempt to start the x server. the keyboard won't respond to anything except cntrl-alt-delete (numlock light won't come on, neither will capslock). i sat there and watched it click the monitor for a few minutes until i decided that it wasn't going to quit (at least 3 dozen times) and don't want to mess up the monitor so i quit. i have zero use of the computer as is, unless you guys can tell me some way to get to the command line (grub is the bootloader, but the command line option from there is limited to about 20 commands...ls isn't even one of them). i may have to just reinstall (for the third or fourth time) and keep trying a different video card (is there a generic setting?). oddly, once or twice it wouldn't do this...it would give me the typical X gray screen with the big x cursor, but no login and the mouse and keyboard wouldn't respond at all (and i can't tell why it did that two times and not the other 12). in these cases i've just had to hit the reset button.

  5. #5

    Re: x trouble with RH 7.3

    hit ctrl+alt+f1 - you should drop to a command line.

    are you uisng Xconfigurator?

  6. #6

    Re: x trouble with RH 7.3

    cntrl-alt-f1 gives me no love...the x setup i did was in anaconda when i installed the os oringinally...even tested it and it worked fine...but upon reboot we get the monitor dance...on, off, on, off, on, off, on, off, ad nauseum...i can't get a command line even...i guess i'll just have to reinstall and hope to find a default video card setting, or just change the video card...i think that's what i'll do

Similar Threads

  1. I am having some trouble
    By dmiller185 in forum Windows - General Topics
    Replies: 2
    Last Post: 10-18-2006, 01:30 AM
  2. USB HDD trouble
    By demian in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 08-20-2003, 11:57 PM
  3. Trouble with Pan
    By Onewingdove in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 05-05-2002, 01:00 PM
  4. FTP Trouble
    By eweborg in forum Linux - General Topics
    Replies: 7
    Last Post: 03-05-2002, 12:58 AM
  5. Anyone having trouble with...
    By Spot in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 11-01-2001, 06:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •