Results 1 to 3 of 3

Thread: ip tables question

  1. #1

    ip tables question

    ok heres my situation
    I am attempting to get IP masq to work on my rh 7.1 box
    i followed all the steps exactly as stated in the ip masq how-to, compling a new kernel, patching it with ip tables, and its still not running. when i run the rc.firewall script i get a whole mess of errors. the errors all basicall say the same thing, that the ip tables mod cant be found, and the ip tables version 1.2.1 is nowhere to be found. I applied the version 1.2.3. what am i doing wrong?

    by the way i can ping both the internal and external nic's of my linux box from computers on the internal network, if i need to tell you more about my set up just ask, i would be glad to tell

    thank you soooo soo much


  2. #2

    Re: ip tables question

    Did you compile iptables support built-in to the kernel, or as modules? Look in /lib/modules/2.4.2(i think for RH71)/kernel for the modules. If you find them there, do a

    modprobe [name of module]
    for each of the modules you compiled. You can have them start automatically by adding the above line, for each module to your start-up scripts, in /etc/rc.local or something similar. (Its been a long time since I ran Redhat. Can't remember the exact layout of the start-up scripts)

    Once the modules are loaded, your iptables script should run.

    Also, make sure your script is looking for iptables in the right place. Should be in /usr/sbin/iptables. I have a line in my script as follows:

    Then, each rule gets called with

    IPTABLES [rest of rule]

  3. #3

    Re: ip tables question

    Have you disabled ipchains? Red Hat still comes with ipchains installed by default for some unknown reason.

    chkconfig --level 0123456 ipchains off
    Should do it. And to save you rebooting to stop the service:
    service ipchains stop
    And then to get iptables to run:

    chkconfig --level 235 iptables on
    service iptables start
    Of course that might be totally the wrong reason *;D but thats how I solved it on my box.

Similar Threads

  1. IP tables
    By saswata in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 11-11-2007, 11:48 AM
  2. Tutorial on IP tables
    By saswata in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 10-11-2007, 12:20 AM
  3. IP Tables
    By explorer in forum BSD
    Replies: 2
    Last Post: 08-02-2007, 03:57 PM
  4. IP Tables Sanity Check
    By Gahwani in forum Linux - General Topics
    Replies: 5
    Last Post: 09-23-2002, 05:37 PM
  5. Php MySql and Tables
    By coltrane in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 02-13-2002, 10:19 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts