Results 1 to 8 of 8

Thread: Home networking problem

  1. #1

    Home networking problem

    For months I have been attempting to set up a small home network. Currently have three computers in the network. Pc1 is Core 1 with 2 ethernet cards. One connect to LAN and the other to SBC/DSL. It took a while but can connect to the internet and read e-mail. pc3 is a linux computer RHL 7:3. I can ping back and forth between pc1 and pc3 but I can not access the internet from pc3. Pc 2 is a windows ME computer. I can not ping pc1 or pc3 nor can either of the linux compters ping pc2. PC2 respondes with Request timed out message when I attempt to ping either of the linux pc's. I am using the following private address:

    pc1 192.168.2.130
    pc2 192.168.2.131
    pc3 192.168.2.132
    gateway is 192.168.1.31 is provided by sbc as static eth ipadress
    My lan is connected through a hub (linksys) All lights are lit and steady.
    sbc requires PPPoE which I have on pc1

    Any ideas as to which direction I should go?

    Thanks
    Richmond

  2. #2
    Senior Member
    Join Date
    May 2004
    Location
    Pakistan
    Posts
    253

    Re:

    Dear roneill,
    Hello,

    pc1 192.168.2.130
    pc2 192.168.2.130
    pc3 192.168.2.131
    This is the problem that you assign same IP address on Windows Me (PC1) Machine and your Fedora Core 1 Machine (PC2). You need to do setup like this.

    Fedora Core 1 Setup

    eth0 IP Address (SBC/DSL) : 192.168.1.31
    eth1 IP Address (LAN) : 192.168.2.130
    Default Gateway (LAN) : 192.168.1.31

    Linux Machine Setup

    eth0 IP Address (LAN) : 192.168.2.131
    Default Gateway (LAN) : 192.168.2.130

    Windows Me Setup

    IP Address (LAN) : 192.168.2.132
    Default Gateway (LAN) : 192.168.2.130

    Best Regards.
    Färrükh Ähmëd

  3. #3
    Thanks for the response, actually I had mistype the address for pc2 . Everything is set up exactly as you listed that it should be. I have run route print command in the Me machine to check the setting. All seems ok. I have run ifconfig -n and route on the Linux machines still unable to ping pc2 from either pc1 or pc3.

    Could there be a problems with ME communications? How would I check that. I have reinstalled ME and still the same problems.

    Any Ideas?

    Richmond

  4. #4
    Senior Member
    Join Date
    May 2004
    Location
    Pakistan
    Posts
    253

    Re:

    Dear roneill,
    Salam,

    First of all make sure your Cable is working fine. Secondly do check in your Linux Box that you are not running any Firewall on it.

    # iptables -L -n --line
    # iptables -t nat -L -n --line


    If you find any thing then just issue this command.

    # iptables -F
    # iptables -t nat -F


    Best Regards.
    Färrükh Ähmëd

  5. #5
    I tried your suggestion and found nothing. The cable is good. Lites are on, both on the computer and at the hub.

    I ran the two commands you suggested even though I found nothing. Attempted to ping pc2 and had 100% packet lost.

    Richmond

  6. #6

    forward switch

    Hi roneill

    I believe your would like to use your PC1 (fedora) as a NAT gateway , right?

    Forwarding must be enabled for any of that stuff to work .. the IPtables stuff is right, but first flip the forwarding switch :

    on PC1 set forwarding on:
    A)
    echo "1" > /proc/sys/net/ipv4/ip_forward (temporary -wont be there on boot)

    B)
    /etc/sysctl.conf for permanent switch ( always on boot) :
    net.ipv4.conf.default.rp_filter = 1

    the second option B) is what you want , but of course the switch lives in 2 places.

    Hope that works

    if its your first time with Iptables ... take your time , it can be deep and confusing at first.. not that Im an expert or anything.

    good luck , and have fun

    usefull links
    http://www.linuxhomenetworking.com/l...bles-intro.htm
    http://www.yo-linux.com/TUTORIALS/Li...rkGateway.html

  7. #7
    That is the way the sysctl.conf file is configured (see dump of file below)
    Actually I have killed all firewalls to attempt to get either pc1 or pc3 to copmlete a ping of pc2. Can not make it work. I ran tcpdump and get the who has call but do not get an answer. I am totally confused as to why the computers are not talking. If tcpdump (running on pc1 is getting a request from either pc2 or pc3 at least enough to ask who has x.x.x.x. tell pc2 or pc3 depending on which way I have pinged then there can not be a cable, or ethernet card problem can there? It must all be in the way I have things configured.

    In one computer I have two ethernet cards. one eth0 to my homenetwork. address 192.168.2.130 bcast 192.168.2.255 mask 255.255.255.0 the other isgw1 eth1 configured to dsl (sbc) ip address set to what I was given bys sbc the bcast is 192.168.1.255 and mask is 255.255.255.0.

    I can get on line from that machine. It is how I am responding to your answer. What I cant do is ping pc2 a windows me machine. It is configured as pc2 192.168.2.131 a third machine is pc3 eth0 192.168.2.132. Pc 1 and pc3 can ping each other neither can ping pc2. gw1 can ping pc3, gw1 or anything on the internet but not pc2. pc2 can ping itself or 127.0.0.0 but nothing else.

    Any ideas?
    Richmond


    # Kernel sysctl configuration file for Red Hat Linux
    #
    # For binary values, 0 is disabled, 1 is enabled. See sysctl(8) and
    # sysctl.conf(5) for more details.

    # Controls IP packet forwarding
    net.ipv4.ip_forward = 1
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    iptables -A FORWARD -s 192.168.2.0/24 -j ACCEPT
    iptables -A FORWARD -d 192.168.2.0/24 -j ACCEPT
    iptables -A FORWARD -s ! 192.168.2.0/24 -j DROP

    # Controls source route verification
    net.ipv4.conf.default.rp_filter = 1

    # Controls the System Request debugging functionality of the kernel
    kernel.sysrq = 1

    # Controls whether core dumps will append the PID to the core filename.
    # Useful for debugging multi-threaded applications.
    kernel.core_uses_pid = 1

    (END)

  8. #8
    Senior Member
    Join Date
    May 2004
    Location
    Pakistan
    Posts
    253

    Re:

    Dear roneill,
    Hello,

    Code:
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    iptables -A FORWARD -s 192.168.2.0/24 -j ACCEPT
    iptables -A FORWARD -d 192.168.2.0/24 -j ACCEPT
    iptables -A FORWARD -s ! 192.168.2.0/24 -j DROP
    This would not be in your /etc/sysctl.conf it should be in /etc/rc.d/rc.local

    Best Regards.
    Färrükh Ähmëd

Similar Threads

  1. Squid and home networking
    By thinux in forum Redhat / Fedora
    Replies: 10
    Last Post: 01-13-2010, 08:46 AM
  2. Home networking, how?
    By corekernel in forum Windows - General Topics
    Replies: 4
    Last Post: 01-22-2007, 09:50 PM
  3. home networking
    By deepa in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 11-01-2006, 02:06 PM
  4. Home networking fun
    By kornp in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 09-19-2005, 05:10 PM
  5. Troubleshooting Home Networking
    By CoolJsa14 in forum Windows - General Topics
    Replies: 0
    Last Post: 01-05-2005, 10:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •