Results 1 to 6 of 6

Thread: iptables problem

  1. #1

    iptables problem

    eth0 = 216.x.x.x real connection to the internet. Working
    eth1 = gate to lan / win word
    I am trying to get iptables to work on slack8
    I used the script from the PET section on sharing.

    # Load the NAT module (this pulls in all the others). 
    /sbin/modprobe iptable_nat 
    /sbin/modprobe ip_conntrack_ftp 
    /sbin/modprobe ip_nat_ftp 
    # MASQUERADE the connection (-j MASQUERADE). 
    /sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE 
    # Turn on IP forwarding 
    echo 1 > /proc/sys/net/ipv4/ip_forward
    Thats script gets called at boot time by rc.local.
    After I reboot i do iptables -L and get error see below.
    root@serverx:~# iptables -L                         
    iptables v1.2.2: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    Any ideas. I am coming off of ipchains.
    Thanx fellas

  2. #2

    Re:iptables problem

    /sbin/modprobe ip_tables

  3. #3

    Re:iptables problem

    ran that same error.
    added that to my script to call at boot time and same error.
    Anymore ideas.

  4. #4

    Re:iptables problem

    Are you sure that iptables support is compiled into your kernel ?

  5. #5

    Re:iptables problem

    Not sure.
    I installed it via pkgtool off of the slack install cd.
    How can i check.

  6. #6
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:iptables problem

    [quote author=groundzero link=board=4;threadid=3614;start=0#36768
    Perhaps iptables or your kernel needs to be upgraded.
    That was what made me realize I needed it compiled in properly. Recompile with the proper options included. AFAIK, these are not options that can be made as modules, just turned on/off in the kernel.

Similar Threads

  1. OpenVPN\IPtables routing problem!! Please help me out
    By Pumbaa in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 01-25-2012, 10:59 AM
  2. linux firewall, iptables forwarding problem
    By weiwei in forum Redhat / Fedora
    Replies: 1
    Last Post: 05-29-2011, 04:58 PM
  3. iptables http forwarding problem
    By sirstan in forum Security
    Replies: 1
    Last Post: 04-23-2008, 11:24 AM
  4. Iptables problem sending mails
    By Tekorei in forum Security
    Replies: 4
    Last Post: 02-13-2006, 12:47 PM
  5. Linux IPTables/Routing Problem
    By Mephisto in forum Security
    Replies: 3
    Last Post: 08-15-2005, 10:01 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts