Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
CUPS forwarding problems
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: CUPS forwarding problems

  1. #1

    CUPS forwarding problems

    It seems that a lot of other people are having fun playing with CUPS so I thought I'd give it a try. It set it up along with Samba on my server and was able to print to it from my Win98 box.

    The trouble comes when I try to print from MY lfs box. I selected the printer location as ipp://192.168.1.3:631/printers/HP_DJ_400 (My server ip and the printers name in CUPS) But when I try to print, CUPS queues the print job (According to the error_log) but in the interface it just tells me its 'processing'

    I have also noticed that if I try to use 'Configure Printer' from the interface, it blurts out 'client-error-not-found' on the page.

    I have only left the server as it was when I set it up for samba/cups so maybe I missed something?


  2. #2

    Re: CUPS forwarding problems

    And another thing, I can't access http://192.168.1.3:631 from any other pc so maybe that might be why my lfs box can't access the printer?

  3. #3

    Re: CUPS forwarding problems

    After much mucking around I've come to the conclusion that my linux pc can not access the CUPS printer. All it says on the web interface is 'Connecting to hostname' (Where hostname is the hostname of the server) Do I need to do something to allow my linux pc to access it?


  4. #4

    Re: CUPS forwarding problems

    I remmebered what you need to do... *This might also help pharris *You need to go to you printer server and change the seeting so it will let you access cups from other computers. *When I get a chance I will post my cups config files at:
    http://gabe.mine.nu/~gmoreno/cups

  5. #5

    Re: CUPS forwarding problems

    Thanks gmoreno. I'll give it a try and hopefully it works!

    Now, I have to try to get my samba shares mounted or have them over nfs. This will be fun ;-)

    Cheers

  6. #6

    Re: CUPS forwarding problems

    thanks gmoreno!

  7. #7

    Re: CUPS forwarding problems

    It worked! Except, it doesn't print out what I want ;-)

    Here is what I get:

    %!PS-Adobe-1.0
    %%BoundingBox: 0 0 595 842
    %%Creator: Qt 3.0.3
    %%Creat.
    ion Date: Sun M......

    Any idea why this is?

  8. #8
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re: CUPS forwarding problems

    You need Post Script drivers. Head over to Adobe site and download PS drivers for your printer.

  9. #9

    Re: CUPS forwarding problems

    Thanks!! Printing now works brilliantly. To summarise my problem, I didn't have access to the server and I had selected the 'raw' driver on both the server and client. Changing the client driver to 'HP Deskjet' on the client solved the problem (I didn't think of that because the HP driver didn't support my printer on the server and wouldn't print.)

    Cheers

  10. #10

    Re: CUPS forwarding problems

    hi gmoreno,
    could you please keep those posted. i can not connect to you server right now.
    thanks!


    arrgg!!!
    Forbidden
    You don't have permission to access /~gmoreno/cups/printers.conf on this server.

    Apache/1.3.24 Server at gabe.mine.nu Port 80
    could ya do a chmod 644 ~gmoreno/cups/printers.conf please

Similar Threads

  1. Slackware 10 + CUPS
    By Schotty in forum Linux - General Topics
    Replies: 11
    Last Post: 07-28-2004, 02:50 AM
  2. Cups printing
    By x0xCRIZx0x in forum Linux Distros
    Replies: 2
    Last Post: 07-16-2002, 02:47 AM
  3. CUPS + RH7.2 HOWTO
    By vhg119 in forum Linux - General Topics
    Replies: 5
    Last Post: 02-12-2002, 11:44 PM
  4. CUPS - help
    By binary_boy in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 01-03-2002, 11:32 AM
  5. CUPS vs lpr
    By in forum Linux - General Topics
    Replies: 1
    Last Post: 12-16-2001, 05:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •