Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Is it impossible......?
Results 1 to 4 of 4

Thread: Is it impossible......?

  1. #1

    Is it impossible......?

    To print to a printer on a WIn98 computer from Linux???

    I finally have Samba working perfectly (at least I assume so). I have no problem mounting the WIN98 shares and Win98 has no problem seeing the Linux box. There is an Epson C80 on the Win98 computer that I want to use badly. I know it works fine in LInux and I went and downloaded the gimp-print 4.2.0 drivers for it.

    Ok, heres what I have done: I installed new CUPS, 1.1.12 and gimp-print 4.2.0 drivers, no errors, looks like a good install to me. I have used kcontrol center (I use KDE/Mandrake 8.1 BTW) to config the printer. I chose SMB shared printer, scanned the network, selected the EPSON and chose the C80 drivers. I then click test page and it says, page sucessfully sent to printer, BUT NOTHING EVEN PRETENDS TO HAPPEN after that. No errors, no lights blinking on the printer and of course no test page .....

    I have went to the localhost:631 CUPS admin and it looks good in there too. No errors when I click test, says printer is idle and accepting jobs. Says its located at smb://WORKGROUP/WIN98/EPSON (which it is). In /home/rick420/mnt/WIN98 I can mount the computer no problem as well.

    My question is--WHAT AM I DOING WRONG again? It took me forever to get Samba working 100% of the time (as oppossed to the 50-50 chance I was getting before) and I thought this printer would be a piece of cake with the kcontrol tool......ANy ideas??

  2. #2

    Re: Is it impossible......?

    have you tried printing from the command line? Sometimes when I run into printer problems, I open a shell and send something to the printer like:

    echo test | lp

    and see if I get any errors. If don't, I restart lpd and see if that gives me any errors. If the job spools to the spooler without problems, then your problem may be with the windows permissions set on the printer. I've used the printtool GUI a lot to set up my smb printers and experience the same thing, a jobs says its complete, but never leaves the spooler and never returns an error. Sometimes going to the command line will give you more of a clue as to where things are failing.

  3. #3

    Re: Is it impossible......?

    OK I got a good update for once! My linux skills are improving I think..

    Heres the new situation:

    After messing with permissions on everything from WIN98, to /dev/lp0 /dev/printers/0 etc. I got it printing test pages! Now the problem is the driver. I used the mandrake control center to set up the printer, but there was no driver in there for the C80. So I chose the C40 and got it printing a blurry, messed up test page--but at least I know its printing now. So then I opened up http://localhost:631 and tried modifying the printer from there. In there was alot more drivers, but the C80 drivers dont seem to be workign correctly. All the other drivers for the Epson printers look like this: EPSON Stylus C60, CUPS+GIMP-print v4.2.0 (en), (sp), etc. The C80 drivers look like this: Epson Stylus C80, Foomatic, gimp-print. When I select the C80 driver, I cant even print a test page, but any other driver does print one although messed up.

    SO, basically I need to get the correct C80 drivers in there and Im set! Problem is how do I do that??? Thanks again guys

  4. #4
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re: Is it impossible......?


Similar Threads

  1. Counting desktop Linux users is impossible
    By cloverm in forum General Chat
    Replies: 2
    Last Post: 09-20-2002, 01:26 AM
  2. Slack and Kernel Compile:IMPOSSIBLE?
    By johnqpublic in forum Linux Distros
    Replies: 11
    Last Post: 11-03-2001, 08:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •