Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 41

Thread: Help!

  1. #21

    Re: Help!

    I was more disappointed for you since you have spent many hours/days/weeks on this. If you lived in Toronto, I would certainly offer whatever assistance I could give.

    Just a suggestion here... How about trying another distro just to see if it works out of the box. If it did work, then you would be able to have a look at the default kernel config, /etc/modules.conf and other settings to see what is needed to get it working.

    I've just installed the latest Caldera and the following is in the default .config (kernel 2.4.13). I did post some of the settings from this .config before and the more I look at it, the more I think it might work. Most distros heavily patch the default kernel before releasing their distro, so the newest kernel (2.4.17) may not have all the kernel options available.

    What I think may be necessary.

    #
    # Code maturity level options
    #
    CONFIG_EXPERIMENTAL=y

    #
    # Loadable module support
    #
    CONFIG_MODULES=y
    CONFIG_MODVERSIONS=y
    CONFIG_KMOD=y

    #
    # General setup
    #
    CONFIG_NET=y *** THIS
    CONFIG_X86_IO_APIC=y
    CONFIG_X86_LOCAL_APIC=y
    CONFIG_PCI=y *** THIS
    # CONFIG_PCI_GOBIOS is not set
    # CONFIG_PCI_GODIRECT is not set
    CONFIG_PCI_GOANY=y
    CONFIG_PCI_BIOS=y
    CONFIG_PCI_DIRECT=y
    CONFIG_PCI_NAMES=y
    CONFIG_EISA=y
    CONFIG_MCA=y
    CONFIG_HOTPLUG=y *** MAYBE THIS

    #
    # PCMCIA/CardBus support
    #
    CONFIG_PCMCIA=m
    CONFIG_CARDBUS=y
    CONFIG_I82092=y
    CONFIG_I82365=y
    CONFIG_TCIC=y

    #
    # Plug and Play configuration
    #
    CONFIG_PNP=m
    CONFIG_ISAPNP=m
    # CONFIG_PNPBIOS is not set

    #
    # Network device support
    #
    CONFIG_NETDEVICES=y

    SOME FROM HERE


    # Wireless LAN (non-hamradio)
    #
    CONFIG_NET_RADIO=y
    CONFIG_STRIP=m
    CONFIG_WAVELAN=m
    CONFIG_ARLAN=m
    CONFIG_AIRONET4500=m
    CONFIG_AIRONET4500_NONCS=m
    CONFIG_AIRONET4500_PNP=y
    CONFIG_AIRONET4500_PCI=y
    # CONFIG_AIRONET4500_ISA is not set
    # CONFIG_AIRONET4500_I365 is not set
    CONFIG_AIRONET4500_PROC=m
    CONFIG_AIRO=m
    CONFIG_HERMES=m
    CONFIG_PLX_HERMES=m

    #
    # Wireless Pcmcia cards support
    #
    CONFIG_PCMCIA_HERMES=m
    CONFIG_AIRO_CS=m
    CONFIG_NET_WIRELESS=y

    #
    # PCMCIA network device support
    #
    CONFIG_NET_PCMCIA=y
    CONFIG_PCMCIA_3C589=m
    CONFIG_PCMCIA_3C574=m
    CONFIG_PCMCIA_FMVJ18X=m
    CONFIG_PCMCIA_PCNET=m
    CONFIG_PCMCIA_NMCLAN=m
    CONFIG_PCMCIA_SMC91C92=m
    CONFIG_PCMCIA_XIRC2PS=m
    CONFIG_ARCNET_COM20020_CS=m
    CONFIG_PCMCIA_IBMTR=m
    CONFIG_PCMCIA_XIRCOM=m
    CONFIG_PCMCIA_XIRTULIP=m
    CONFIG_NET_PCMCIA_RADIO=y
    CONFIG_PCMCIA_RAYCS=m
    CONFIG_PCMCIA_NETWAVE=m
    CONFIG_PCMCIA_WAVELAN=m
    CONFIG_AIRONET4500_CS=m

    #
    # PCMCIA character devices
    #
    CONFIG_PCMCIA_SERIAL_CS=m ??????

    Others in networking/filters of course.

    If you would like to try Caldera to see if the WPC11 works, you can get the install iso from

    ftp://ftp.iso.caldera.com/pub/OpenLi....1/Workstation

    You only need CD1 for the install. 1a is extras and 2 is source.

    I would be interested to see if the wpc11 works with another distro.

  2. #22

    Re: Help!

    ok well I did find something that may or may not help ???

    There are some parms I can pass, but not sure exactly how to do it
    The module i82365 I believe goes to my PCI to ISA Bridge
    I ran a script called dump_pirq that comes with pcmcia and this is the info I got.

    Interrupt router at 00:07.0: Intel 82371AB PIIX4/PIIX4E PCI-to-ISA bridge
    PIRQ1 (link 0x60): irq 9
    PIRQ2 (link 0x61): irq 10
    PIRQ3 (link 0x62): irq 11
    PIRQ4 (link 0x63): irq 9
    Serial IRQ: [disabled] [quiet] [frame=21] [pulse=4]
    Level mask: 0x0e00 [9,10,11]

    I know I can pass the IRQ to the pcmcia manager, but not sure to pass 9,10, or 11 *sigh*

    I believe my wireless card is on 10.
    I tried to do a modprobe of tcic (the other white meat) but that didn't result any better than i82365

    There is another little util called probe that is supposed to find my controller but as you see below not such luck

    [root@localhost cardmgr]# probe
    PCI bridge probe: not found.
    Intel PCIC probe: not found.
    Databook TCIC-2 probe: not found.

    this is from var/log/messages after modprobing the card module
    eb 6 03:09:33 localhost kernel: Databook TCIC-2 PCMCIA probe: not found.
    Feb 6 03:09:46 localhost kernel: Intel PCIC probe: not found.
    Feb 6 03:17:39 localhost kernel: init_module: prism2_plx.o: 0.1.10 Loaded
    Feb 6 03:17:39 localhost kernel: init_module: dev_info is: prism2_plx
    Feb 6 03:17:39 localhost kernel: PCI: Found IRQ 10 for device 00:09.0
    Feb 6 03:17:39 localhost kernel: A PLX PCI/PCMCIA interface device found, phymem:0xdf000000, phyio=0xc800, irq:10, mem: 0xd0905000, io:0xc800
    Feb 6 03:17:39 localhost kernel: A PCMCIA WLAN adapter was found.
    Feb 6 03:17:39 localhost kernel: ident: nic h/w: id=0x800c 1.0.0
    Feb 6 03:17:39 localhost kernel: ident: pri f/w: id=0x15 1.0.4
    Feb 6 03:17:39 localhost kernel: ident: sta f/w: id=0x1f 1.0.3
    Feb 6 03:17:39 localhost kernel: MFI:SUP:role=0x00:id=0x01:var=0x01:b/t=1/1
    Feb 6 03:17:39 localhost kernel: CFI:SUP:role=0x00:id=0x02:var=0x02:b/t=1/1
    Feb 6 03:17:39 localhost kernel: PRI:SUP:role=0x00:id=0x03:var=0x01:b/t=1/3
    Feb 6 03:17:39 localhost kernel: STA:SUP:role=0x00:id=0x04:var=0x01:b/t=1/6
    Feb 6 03:17:39 localhost kernel: PRI-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
    Feb 6 03:17:39 localhost kernel: STA-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
    Feb 6 03:17:39 localhost kernel: STA-MFI:ACT:role=0x01:id=0x01:var=0x01:b/t=1/1
    Feb 6 03:17:39 localhost kernel: Prism2 card SN: 99SA01000000

    md, I've tried caldera in the past but didn't really like them much their updates were out of date before it made it to their website
    I think if worse comes to worse, maybe I'll try SuSE
    So far mailing list has been worthless
    Plenty of OTHER problems being solved of course lol
    Still workin' on it

  3. #23

    Re: Help!

    progress?
    Dunno

    Ok got rid of the error for i82365 device not found.
    I tried every other freakin' module that this thing compiles and one WORKED!
    i82092 plugs in ok
    So I did that and rmmod prism2_plx, insmod prism2_plx (make sure it knows its there)

    NOW
    Not quite out of this yet lol

    [root@localhost linux]# /etc/rc.d/init.d/pcmcia reload
    Shutting down PCMCIA services:.
    Starting PCMCIA services: modulesinsmod: a module named pcmcia_core already exists
    insmod: a module named i82092 already exists
    /lib/modules/2.4.17/pcmcia/ds.o: init_module: Operation not permitted
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters cardmgr.

    Still having problems with this damn ds.o

    Also in var/log/messages
    Feb 6 04:35:40 localhost kernel: ds: no socket drivers loaded!
    Feb 6 04:35:40 localhost cardmgr[3924]: starting, version is 3.1.31
    Feb 6 04:35:40 localhost cardmgr[3924]: no pcmcia driver in /proc/devices
    Feb 6 04:35:40 localhost cardmgr[3924]: exiting
    Feb 6 04:38:55 localhost kernel: ds: no socket drivers loaded!

    so not sure if the chicken or the egg came first
    whether the problem with no pcmcia driver in /proc/devices is the problem, or if its the ds no socket drivers loaded.

    However its 5am, and kinda lookin' towards the bed and its lookin back at me... scary eh? lol
    Any ideas be glad to hear them

    ok wait just noticed something else
    too tired to deal with it tonight
    I've compiled and installed pcmcia 3.1.31
    HOWEVER
    When I do a test_setup (a script that comes with pcmcia) it seems that kernel card services 3.1.22 is running...
    So that maybe the ds.o problem.
    SO I will work on recompiling the kernel w/o the pcmcia module included (seeing as I am recompiling a newer version anyways)

    <--- going to bed lol
    I'll probably start compiling tonight so whenever I get going tomorrow or when I get home from work I can start on it again lol
    Ya know its nice having a problem to work on, but geeez gimme a break LOL
    g'nigh....errr morning

  4. #24

    Re: Help!

    ok...
    so I thought about it, if I select not to compile pcmcia/cardbus support it wont let me compile the i82092 modules either.

    SO I tried another method
    Theoretically this was compiled as a module and indeed pcmcia_core module is running

    SO I rmmod all the related modules to this beast
    then stopped the service, and rmmod pcmcia_core
    I recompiled pcmcia-3.1.31 and make install
    (yes did make clean, and re-did make config)

    However, when I restart services it still says 3.1.22 kernel services *sigh*
    How do I get rid of that little bastage? lol
    I thought stopping services and removing the module (It did not show up in lsmod) would allow me to overwrite it but still not going anywhere grrr lol

    Again, any help is appreciated.
    I'm REALLY goign to bed this time!!

  5. #25

    Re: Help!

    I'm off to work now and will read your updates during the day and post anything I can think of when I get home.

    The Caldera suggestion was due to what I saw in the kernel default config. The new version (3.1.1) has the 2.4.13 kernel and is heavily patched. I thought it may work (out of the box) and would give you some help to get Mandrake working with the card. Do you have an extra partition you could use just for testing?


  6. #26

    Re: Help!

    unfortunately no
    I only have a 4 gig HD for linux, and I have that partitioned to swap, home, /

    if I can update pcmcia that MIGHT just clear up the ds.o problem and get cardmgr to get up and running which will help out a bit in the problem.


  7. #27

    weird...

    after compiling pcmcia-cs-3.1.31 ... I can't find any .o files relating to pcmcia... how is that?


    -- edit --
    ok scratch that I fingered that one out
    Instead of compiling for the currently running kernel I compiled against the source which recompiled the core module and all other pcmcia modules with it which worked great... but didn't fix the problem
    *sigh*

    Feb 6 14:09:03 localhost kernel: Linux PCMCIA Card Services 3.1.31
    Feb 6 14:09:03 localhost kernel: kernel build: 2.4.17 unknown
    Feb 6 14:09:03 localhost kernel: options: [pci] [apm]
    Feb 6 14:09:03 localhost kernel: ds: no socket drivers loaded!
    Feb 6 14:09:03 localhost cardmgr[7389]: starting, version is 3.1.31
    Feb 6 14:09:03 localhost cardmgr[7389]: no pcmcia driver in /proc/devices
    Feb 6 14:09:03 localhost cardmgr[7389]: exiting
    [root@localhost pcmcia-cs-3.1.31]#

    thankfully there are no guns in this house LOL
    well off to work I go...

    thanks for trying folks... this battle just may go down in flames yet lol

  8. #28

    Re: Help!

    Sorry as I had Monday and Tuesday off, I was extremely busy at work today and didn't have much time for anything else. Not even lunch.

    Hopefully I'll be able to help out a little more tomorrow.

    Don't give up yet. It has to work somehow.


  9. #29

    Re: Help!

    Not a problem, maybe I'll take a hiatus from it for a bit...
    LOL
    My boss just told me he'd buy me a new computer if I write an app for our blackberry (www.blackberry.net if you're not sure of what I'm referring to)...
    Apparently they looked up for some software to do a similar job and the company wanted 110k for it

    Some of the functionality of the app was redundant, and some of it was worthless so maybe I'll just put some time into that JUST in case he's even remotely serious LOL

    Anyways, thanks a lot for the help anything is appreciated I certainly can't expect others lives to revolve around my problem... damnit ;D

  10. #30

    Re: Help!

    here is something to try - passing the interupt:
    http://people.debian.org/~mrd/vaio_r...lk/node13.html

    i still really think tehre is an option we are not passing correctly....

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •