Results 1 to 10 of 10

Thread: Default Mount Point

  1. #1

    Default Mount Point

    I've killed my /etc/fstab file. I wanna copy a new /etc/fstab from fd0 onto my Fedora Core 3 system.

    I cannot edit my existing /etc/fstab from linux rescue, because the root filesystem is not mounted.

    What is the command to mount the root filesystem??


    # mount /whatismyrootfscalled? /whereismyrootfsmounted?

    # cd /dev/fd0 /media/floppy

    # cp fstab /etc/fstab


    Thanks people =)

  2. #2
    Guest

    Re:Default Mount Point

    This varies from system to system. But it's probably /dev/hda or something.

  3. #3

    Re:Default Mount Point

    yea - if it is linux only then probably mount -t ext3 /dev/hda1 /mountpoint


  4. #4
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:Default Mount Point

    If you go into the reesuce mode of the FC3 install disc, it should automount all linux partitions. Then you can just chroot to that (/mnt/sysimage/) and make any modifications. I have used the rescue mode several times, from fixing grub to get reinstalled, to removing flaky kernels I have tested out.

  5. #5

    Re:Default Mount Point

    If you go into the reesuce mode of the FC3 install disc, it should automount all linux partitions. Then you can just chroot to that (/mnt/sysimage/) and make any modifications. I have used the rescue mode several times, from fixing grub to get reinstalled, to removing flaky kernels I have tested out.

    That's what I needed to hear! I'll give that a try, thanks for your advice.

  6. #6

    Re:Default Mount Point

    Code:
    The rescue environment will now attempt to find you linux installation and mount it under the directory /mnt/sysimage.  You can then make any changes required to your system.  If you want to proceed with this step choose 'Continue'.  You can also choose to mount your file systems read-only instead of read-write by choosing 'Read-Only'.
    Code:
    If for some reason this process fails you can choose 'Skip' and this step will be skipped and you will go directly to a command shell.
    Code:
    Searching for Fedora Core 3 installations....
    Code:
    Rescue:
    
    An error occurred trying to mount some or all of your system.  Some of it may be mounted under /mnt/sysimage.
    
    Press <return> to get to shell.  The system will reboot automatically when you exit from the shell.
    Here's what I tried in the shell:

    Code:
    # chroot /mnt/sysimage
    chroot: cannnot execute /bin/sh: No such file or directory
    There is no /media directory present? Where can I mount fd0 to copy my 'new and improved' fstab file?

    Thanks again =)

  7. #7

    Re:Default Mount Point

    Ok first try to just plain old:
    Code:
    cd /mnt/sysimage
    Not chroot. Then you should be able to see /etc inside this mount point by doing an ls. To get your floppy drive mounted you'll want to do an ls /mnt and see if there is a dir called floppy or something similar. If there is do a:
    Code:
    mount /dev/fd0 /mnt/floppy
    if not make that dir first by doing:
    Code:
    mkdir /mnt/floppy
    Then issue the mount /dev/fd0 command above after you have created the dir. This is all assuming that the filesystem got mounted. I mean it did say that some or all of the filesystems were not mounted. Its worth a shot though.

  8. #8

    Re:Default Mount Point

    Thanks, I'll give it a shot!

  9. #9

    Re:Default Mount Point

    OK, here's the latest:

    Code:
    Checking root filesystem
    fsck.ext3: Is a directory while trying to open /
    [FAILED]
    
    *** An error occurred doing the filesystem check.
    *** Dropping you to a shell; the system will reboot
    *** when you leave the shell.
    *** Warning -- SELinux is active.
    *** Disabling security enforcement for system recovery.
    *** Run 'Systemforce 1' to re-enable.
    Give rootpassword for maintenance
    (or type Control-D to continue): rtpasswd
    (Repair filesystem) 1 # mount -t vfat /dev/fd0 /media/floppy
    (Repair filesystem) 2 # cd /media/floppy
    (Repair filesystem) 3 # cp fstab /etc
    cp: overwrite '/etc/fstab', overriding mode 0644? yes
    cp: cannot create regular file '/etc/fstab': Read-only filesystem

  10. #10

    Re:Default Mount Point

    humms - looks like something can not find the root filesystem - after it gets to the point where it says this
    (or type Control-D to continue): rtpasswd run fdisk to see the partitions - don't write anything!! hit q when done - something like fdisk /dev/hda

Similar Threads

  1. Can a mount point address a folder?
    By chatt in forum Linux - General Topics
    Replies: 2
    Last Post: 01-17-2008, 01:32 AM
  2. redhat default passwords for the default inbuilt users
    By kaushalsp in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 12-31-2004, 04:49 AM
  3. 1 mount point on 2 different drives?
    By boblucci in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 01-25-2004, 06:31 AM
  4. My point exactly
    By boblucci in forum General Chat
    Replies: 3
    Last Post: 10-11-2002, 07:11 PM
  5. creating mount point for dos/windows directory on dual boot
    By rioguia in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 07-03-2002, 02:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •