Results 1 to 8 of 8

Thread: mysql prob

  1. #1

    mysql prob

    I am trying to setup an admin user in mysql to log in as. I have tried several different things, but no joy on anything yet. the command I did to add user was:
    grant all on * to mark identified by 'password';

    This then tells me that it went ok and I log out as root to log back in as mark. I issue the command:
    ./mysql -h localhost -u mark -p

    it comes up with Enter password :
    I enter my password and it says access denied. Any one got any ideas?

  2. #2

    Re: mysql prob


    grant all on *.* to mark identified by 'password';

    I spent ages with a simalar prob, this sorted it.


  3. #3

    Re: mysql prob

    Nope thats not it either. tried it several times with a few minor diffs each time. Im pretty much at a loss as to what to do now. ??? it will let me log in as root, but not as anything else.

  4. #4

    Re: mysql prob

    Mmmmn..... sounds like the same problem I had, the only other thing I did was create a completely new user and did the *.* thing. You could try a new user but I can't figure out for the life of me why that would make a difference. I know SQL has loads of ACL stuff, maybe the add step with one * does something on a different ACL that means you can't do the *.* thing. (can you tell I'm realy clutching at straws here?)

  5. #5

    Re: mysql prob

    I hear ya. Im just playing around for the most part. I have mysql,php, and apache installed on a laptop at work that I am playing with (Im at work now). I will try it at home on my puter, and if it does it there, then ???

  6. #6

    Re: mysql prob

    The one at home did the same thing. ??? ??? My brain hurts.

  7. #7
    redhead's Avatar
    Join Date
    Jun 2001
    Copenhagen, Denmark

    Re: mysql prob

    Could it be, that mysql want's the password encrypted, so you'll have to specify it with:
    grant all on *.* to mark identified by PASSWORD('password');

  8. #8

    Re: mysql prob

    Ok, that worked. The only difference with what I was doing is I did not add the word Priviledges in the grant statement. Thanks for the help!!

Similar Threads

  1. Problem starting mysql conflicts with the RPM "mysql-5.0.27-1.fc6"
    By kamakshiganesh in forum Redhat / Fedora
    Replies: 2
    Last Post: 10-26-2007, 04:35 AM
  2. CPU Prob FC5
    By mojo jojo in forum Redhat / Fedora
    Replies: 5
    Last Post: 03-24-2006, 04:51 AM
  3. Compile prob with YD 2.2
    By Kernel_Killer in forum Linux Distros
    Replies: 4
    Last Post: 07-12-2002, 03:53 AM
  4. ssh prob
    By Black666 in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 07-06-2002, 09:38 PM
  5. I lied,one more prob.
    By johnqpublic in forum Linux - General Topics
    Replies: 18
    Last Post: 07-22-2001, 04:18 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts