Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Compiling MPlayer gives errors

  1. #1

    Compiling MPlayer gives errors

    i did some searching and read that .asx files are only for micro$oft and will only work with the windows media player. now if quick time will work, real player will work, and xmovie(and many others to play mpegs) do you think mr. bill will ever help us out? ummm, no is my guess.


    if anything is wrong in my post please correct me

  2. #2

    Re: asx files in linux?

    i'm not sure about this but mplayer might be able to play those files
    i think it also supports asf

  3. #3

    Re: asx files in linux?

    Yep as Ralinx said mplayer play them

  4. #4

    Re: asx files in linux?

    do you think mr. bill will ever help us out?
    not unless they put a gun to his head
    and even then i'm not sure he would

  5. #5

    Re: asx files in linux?

    I can guarantee that he won't.

    The whole point of developing the proprietary asf/wmf standard was so that people would have to use windows in order to watch them. It's just one of the many ways that Mr. Bill is trying to eradicate linux/others. If he released a linux program that could play them, he'd be shooting himself in the foot.

    But his plan sort of backfired anyway, because mplayer _does_ play them, if you compile in the win32 codecs (not hard, just rtfm before you compile).

  6. #6

    Re: asx files in linux?

    dang it.......and mplayer was the only media player i had a hard time compiling.
    i tried the tarball and the rpm as well. guess its back to the drawing board to give it another shot. :


  7. #7

    Re: asx files in linux?

    Your best bet is the tarball.

    Remember, if you have trouble running it once it's compiled, read the error message carefully the most common error message actually contains instructions on how to fix the error ;D

  8. #8

    Re: asx files in linux?

    i will be posting back with error messages i assure you!!! hehe
    too bad mplayer's site has been down for the last hour. oh well, tomorow is another day

  9. #9

    Re: asx files in linux?

    Ok. Whatever you do, don't go to the mplayer mailing list for help, they will likely just scream "RTFM!!!" at you. I (and likely others here, as well) can probably walk you though any problems you may have

  10. #10

    Re: asx files in linux?

    ok, heres the message i get when i run make
    __________________________________________________ __________

    gcc: installation problem, cannot exec 'cpp0: no such file or directory

    __________________________________________________ __________

    on MPlayers support page it says this :
    "The facts : MPlayer's compile process needs the --disable-gcc-checking to proceed upon detecting a GCC version of 2.96 (apparently it needs this option on egcs too"

    i have gcc 3.0 anyhow for whatever that matters and i wonder if i really should downgrade to 2.95.2 like the manual says.............

    but i tried a few different commands to disable gcc checking during the make but i dont know what the command is exactly. also a search through rpm manager shows nothing about cpp0 so what could be the problem? thanks


Similar Threads

  1. errors while compiling device drivers
    By yeah in forum Redhat / Fedora
    Replies: 1
    Last Post: 09-08-2007, 08:52 AM
  2. MPlayer & mp3
    By gabbath in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 05-08-2005, 05:52 AM
  3. Kernel Compiling Errors
    By N0thing in forum General Chat
    Replies: 3
    Last Post: 01-16-2005, 07:15 PM
  4. compiling fluxbox thru cvs, got errors
    By S_D_Willie in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 07-07-2002, 07:26 AM
  5. Errors compiling Gaim
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 03-22-2002, 02:17 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts