Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Woody went limp :(

  1. #1

    Woody went limp :(

    My Debian Woody install went limp on me after removing X and Mesa. When I try to reinstall X using apt-get it tells me about some module that has two paths or something and dies. I tried compiling 4.2 myself and I get 4 lines of xauth: command not found xinint: command not found and another of xauth command not found.

    Is it time to?

    1. Hose system, reformat the drive reinstall lots o'stuff from source?

    2. Try to fixee fixee makee all better?

  2. #2

    Re: Woody went limp :(

    2. fixee fixee definatelee.

    you should be able to fix X pretty easily, i am not sure about mesa.

  3. #3

    Re: Woody went limp :(

    Hrm..The mesa stuff should be as easy as recompiling. It's the X part that's got me stuck.

  4. #4

    Re: Woody went limp :(

    hi ASCI,
    what i did with potateo was grab off the binaires from www.xfree86.org and use the install script, it is not in the form of a package but it did work quite well. it is either that or apt-get -remove <packname> then reinstall them all. the nice thing about getting them from xfree86.org is that it is one big package which include most of out favorite apps. (xterm, font server, etc...). of course you can get the source if you like.

  5. #5

    Re: Woody went limp :(

    pb my friend, I've been one step ahead of you. I used apt to remove X and when I reinstall using apt-get it gives me some weird error about two links going to the same place. When using the sh Xinstall.sh script it installs fine but gives me the latter part of my problem not being able to find xauth and xinit.

    Okay I got smart this time and wrote down the errors I'm getting when I use apt. The first one is before I decided to remove some file.

    Code:
    Duplicate symbol TT_freetype_version in /usr/X11R6/lib/modules/fonts/libxtt.a:xttmodule.o 
    Also defined in /usr/X11R6/lib/modules/fonts/libfreetype.a
    
    Fatal server error: 
    Module load failure.
    Solved that by deleting the libxtt.a file which of course gave me another error.

    Code:
    Cannot open default font 'fixed'
    This seems a bit easier because now there's no doubles. Continuing to work on fixing this for now, also seems 4.2 needs me to edit my path, since when I tried xinit it said that I needed /usr/X11R6/bin in my path and pointed at a valid X server or somesuch. Probably a man page on xfree86's page for doing that?

  6. #6

    Re: Woody went limp :(

    hi ASCI,
    add th path element to /etc/profile to make it global for all users, my woody profile looks like this:

    PATH="/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/usr/X11R6/bin"

    xfonts-75dpi, xfonts-100dpi and xfonts-base are the only packages you really need to get up and running (i think, probably the 75 or 100 would be okay).

    anywho... you are probably done already

  7. #7

    Re: Woody went limp :(

    Arrr..well I managed to get 4.2.0 installed with the install script only to get the double link error again. Sigh, looks like it might be time to hose it all. :-/

  8. #8

    Re: Woody went limp :(

    arrgg!
    well, its probably quicker...

  9. #9

    Re: Woody went limp :(

    Indeed it would be. However I think I might try to install X from the install script again. I got smart and kept all of it. ;D

  10. #10

    Re: Woody went limp :(

    When I installed Xfree86 from the install script I realized two things today. 1. It doesn't have Radeon listed in it's video card selection (being 4.2 it should) 2. it wants to create XF86Config, not XF86Config-4. When using apt I see it creates both files and lets me select Radeon when chosing my video card. Why doesn't the install script let me do the same?

Similar Threads

  1. nic problems w/ Woody
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 12-22-2004, 01:05 AM
  2. Debian Woody
    By Timothy_Miller in forum Linux - General Topics
    Replies: 10
    Last Post: 06-05-2002, 04:28 AM
  3. Working Woody ISO
    By ASCI_Blue in forum Linux - General Topics
    Replies: 4
    Last Post: 04-06-2002, 07:22 AM
  4. How do you mix woody and sid?
    By in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 01-28-2002, 07:17 PM
  5. debian Woody
    By agar in forum Linux - General Topics
    Replies: 3
    Last Post: 12-09-2001, 12:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •