Results 1 to 9 of 9

Thread: Errors compiling Gaim

  1. #1

    Errors compiling Gaim

    Hi I decided to compile gaim so that I could compile it with the protocols I want to be built in but now I get this error. I think it is some kinda perl error. I am running debian what packages do I need for me to be able to finish compiling gaim. I thought I had all the neccesary perl packages.

    Code:
    gcc -g -O2 -I/usr/local/include -I/opt/include -I.. -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DDEBIAN -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl/5.6.1/CORE -DLOCALEDIR=\"/usr/local/share/locale\" -DLIBDIR=\"/usr/local/lib/gaim/\"  -o gaim -export-dynamic about.o aim.o applet.o away.o browser.o buddy.o buddy_chat.o conversation.o core.o dialogs.o gaimrc.o gtkimhtml.o gtkspell.o gtkticker.o html.o idle.o list.o md5.o module.o multi.o perl.o plugins.o prefs.o proxy.o prpl.o server.o sound.o ticker.o util.o -lnsl -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -L/usr/lib -lesd -laudiofile -lm protocols/oscar/liboscar.a protocols/toc/libtoc.a -rdynamic -L/usr/local/lib /usr/lib/perl/5.6.1/auto/DynaLoader/DynaLoader.a -L/usr/lib/perl/5.6.1/CORE -lperl -ldl -lm -lcrypt -lXss 
    /usr/bin/ld: cannot find -lperl
    collect2: ld returned 1 exit status
    make[3]: *** [gaim] Error 1
    I also looked in for /usr/lib/perl/5.6.1/CORE and I do have it.

    Thanks for your help

  2. #2

    Re: Errors compiling Gaim

    do you have make installed?

    while on the subject, i just compiled this as well. (ver. 0.54) and i didnt get the sounds with it which is annoying. anyone know where they are kept and what format they are in? i guess i will be looking at gaim's site. >

    SD

  3. #3

    Re: Errors compiling Gaim

    nevermind. i just used aim's sounds and changed the sound preferences to command and it works ;D

  4. #4

    Re: Errors compiling Gaim

    I do have make and I have compilied LFS with it.

  5. #5

    Re: Errors compiling Gaim

    Hmmm...

    Are you doing this as root or as a normal user? AFAIK the ld command only works for root.

    Did you go through the INSTALL file and the README file for any version dependancies?

    Did you ./configure before make?

    Sorry, I cant be of much help. I've compiled GAIM on my Slackware box without any hassles... so they're the only things I can think of...

    TTFN,
    ScRapZ_1 :P

  6. #6

    Re: Errors compiling Gaim

    Did run ./configure and make as root still no luck.. BTW what is -lperl

  7. #7

    Re: Errors compiling Gaim


    BTW what is -lperl
    You know... I have no idea. My system doesnt seem to have it. Mabye its a switch for a script or something.

    Lets try from the start... give us all the deatails:

    1) You download the source (cvs or tarball?)
    2) ...
    3) ...
    ...
    ...

    TTFN,
    ScRapZ_1 :P

  8. #8

    Re: Errors compiling Gaim

    is there a package at all for gaim that you can apt-get?

    if not, try here :

    http://packages.debian.org/testing/net/gaim.html

    SD

  9. #9

    Re: Errors compiling Gaim

    There is but I want to compile it with the plugins built in.

Similar Threads

  1. errors while compiling device drivers
    By yeah in forum Redhat / Fedora
    Replies: 1
    Last Post: 09-08-2007, 08:52 AM
  2. Kernel Compiling Errors
    By N0thing in forum General Chat
    Replies: 3
    Last Post: 01-16-2005, 07:15 PM
  3. Gaim v0.67
    By sujoki in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 08-22-2003, 09:17 PM
  4. compiling fluxbox thru cvs, got errors
    By S_D_Willie in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 07-07-2002, 07:26 AM
  5. Compiling MPlayer gives errors
    By in forum Linux - Software, Applications & Programming
    Replies: 18
    Last Post: 01-16-2002, 06:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •