Results 1 to 4 of 4

Thread: Installing gnome-libs on LFS

  1. #1

    Installing gnome-libs on LFS

    I'm trying to install the gnome-libs
    on LFS-3.2 but I get this message...

    checking for umode_t... no
    checking for dbopen... no
    checking for dbopen in -ldb... no
    checking for dbopen in -ldb1... no
    checking for __db185_open in -ldb-3... no
    configure: error: Your db library is missing db 1.85 compatibility mode

    I did find the source for DB-1.85 but I get
    a lot of make errors when I compile it on both LFS
    and the host (Slack 8.0).

    I tried the gnome-db but its dependencies lead me
    back to "you need gnome-libs installed".

    So I thought I would see if any have seen this before.

    Thanks for any help or a link to some more info.

    Onewing.

  2. #2
    Guest

    Re: Installing gnome-libs on LFS

    I found that when installing the db, you need the 1.85 version - backward comp. isn't enough..

    and I'm on LFS to..

    http://hints.linuxfromscratch.org/hints/gnome.txt but I assume that this is what you are using.

  3. #3

    Re: Installing gnome-libs on LFS

    Ok I just DL the db.1.85.4 and in
    db.1.85.4/PORTS/linux I run make all
    this is what I get...

    In file included from ../../hash/hash.c:55:
    ../../hash/hash.h:106: field `__errno_location' declared as a function
    ../../hash/hash.c: In function `flush_meta':
    ../../hash/hash.c:508: parse error before `('
    ../../hash/hash.c: In function `hash_get':
    ../../hash/hash.c:539: parse error before `('
    ../../hash/hash.c: In function `hash_put':
    ../../hash/hash.c:556: parse error before `('
    ../../hash/hash.c:560: parse error before `('
    ../../hash/hash.c: In function `hash_delete':
    ../../hash/hash.c:577: parse error before `('
    ../../hash/hash.c:581: parse error before `('
    ../../hash/hash.c: In function `hash_seq':
    ../../hash/hash.c:732: parse error before `('
    make: *** [hash.o] Error 1

    this was the only source I could find for 1.85

    I seem to have a block here. You think I'm working
    with the wrong file here (db-1.85.4)?

    Did I miss something in the LFS install,I dont recall
    installing a db.

  4. #4

    Re: Installing gnome-libs on LFS

    Sorry did not see all of your post Lovechild.

    No this is just a fly by the seat of the pants thing.

    I guess I should take a look.

    I'm not trying to install gnome I just want to
    use some apps that need gnome-libs.

Similar Threads

  1. Help Installing GNOME
    By shebang in forum Linux - Software, Applications & Programming
    Replies: 16
    Last Post: 02-12-2004, 11:04 PM
  2. Installing Gnome
    By Wolverine in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 03-11-2003, 08:03 PM
  3. error installing packages "krb5-libs" ; AND NVIDIA troubles
    By SaTaNcLaUz in forum Linux - General Topics
    Replies: 23
    Last Post: 11-14-2002, 09:26 PM
  4. Installing Gnome apps without gnome.....
    By CP in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 10-31-2002, 12:20 AM
  5. Installing gnome 2
    By Static in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 07-12-2002, 04:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •