Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Disabling xinit at bootup
Results 1 to 8 of 8

Thread: Disabling xinit at bootup

  1. #1
    Guest

    Disabling xinit at bootup

    I clicked on the wrong thing, now x starts at bootup with the fancy little login screen. How do I disable that? I looked in the rc.d files, but didnt see anything related. Also looked in the control panel but nada there either.

  2. #2

    Re: Disabling xinit at bootup

    Take another look in those rc.d dirs. See if you can see something called xdm (or maybe it'll be kdm, or wdm etc... some sort of gui display manager).
    If it's there that will be the thing starting X and showing the login screen.

    A possiblilty worth considering is that maybe the change you made was to the default run level. Ring any bells?

    Actually now I think of it, you said it was a fancy login screen. Probably not xdm then

  3. #3
    Guest

    Re: Disabling xinit at bootup

    Sorry, should have also said it was redhat 7.2 , my bad. Yeah, its probably something like that, couldnt remember what it was called. I will look when I get home for the xdm in the rc.d files. I did notice that I was in run level 5, which I thought was odd, that I usually started in run level 3, so I might try that also.

  4. #4
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re: Disabling xinit at bootup


    Sorry, should have also said it was redhat 7.2 , my bad. *Yeah, its probably something like that, couldnt remember what it was called. *I will look when I get home for the xdm in the rc.d files. *I did notice that I was in run level 5, which I thought was odd, that I usually started in run level 3, so I might try that also.
    that would be it!! change the run level to 3 and you should be good to go!!

  5. #5

    Re: Disabling xinit at bootup

    hello,
    changing the runlevel from 5 to 3 should fix ya right up.

  6. #6

    Re: Disabling xinit at bootup


    Sorry, should have also said it was redhat 7.2 , my bad. Yeah, its probably something like that, couldnt remember what it was called. I will look when I get home for the xdm in the rc.d files. I did notice that I was in run level 5, which I thought was odd, that I usually started in run level 3, so I might try that also.
    vim /etc/inittab change the default from 5 to 3, and you will be set... don't have to change anything else.

  7. #7
    Guest

    Re: Disabling xinit at bootup

    Roger that. *The runlevel thing has always confused me, and I have never had the time to set down and read about it. *Know that you guys have mentioned it, it does make sense though. *For more info, here is what I am trying to do. Apparently you can export the display of a computer by using ssh with the -X option. I keep getting a magic-cookie error with some other stuff (at work, so I cant tell you the exact error). I dont know if you have to be in a regular screen instead of x, but I figured that would be a good place to start. Im trying to do this so I can free up some deskspace by getting rid of the monitor on my firewall/gateway and my web/php/mysql server.

  8. #8

    Re: Disabling xinit at bootup

    Ah, yeah.

    All you have to do is ssh -X user@host ; then call some gui app, like gftp or something, and the display will come back to your box. IT's not like you get a login screen and then run the full gui, although you *might* be able to do that... *shrug*

    init level 0 == halt/poweroff
    level 1 == single user mode (maintanince)
    level 2 == part of boot up
    level 3 == normal run mode
    level 4 == unused
    level 5(on linux) == level 3, but with gui login
    level 6 == reboot level

Similar Threads

  1. Improved KDE bootup time
    By jro in forum General Chat
    Replies: 3
    Last Post: 12-22-2005, 03:31 AM
  2. eth0 initialization & bootup failure
    By destinationme in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 01-06-2005, 12:42 AM
  3. linux wont pass bootup
    By aromes in forum Linux - General Topics
    Replies: 2
    Last Post: 09-19-2003, 05:15 PM
  4. slackware bootup
    By nimbus in forum Linux - General Topics
    Replies: 11
    Last Post: 06-18-2003, 01:43 AM
  5. How do I get rid of Mandrake bootup screen?
    By BruceLeroy in forum Linux - General Topics
    Replies: 2
    Last Post: 01-09-2002, 07:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •