Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
kernel odyssey...need help
Results 1 to 10 of 10

Thread: kernel odyssey...need help

  1. #1

    kernel odyssey...need help

    Hello all. Well Iíve been trying to recompile my kernel. I only have 2.4.8 downloaded and am waiting on the latest flavor, but I thought I would practice the compiles b/c ive never got on to work properly.
    ok, specs:

    PIII 500
    384MB
    Via Apollo PRO133 (I can give you the exact chip numbers, but I don't think it matters)
    4X AGP
    TNT2 16MB
    X 4.0.1
    SuSE 7.1
    Kernel 2.4.0


    ok, problems:

    When I run games that require hardware acceleration, it is quite evident that the game is software accelerated. So I looked at if AGP is working. And then I asked LNO how to do this. someone said to "cat /proc/nv/card0" well I don't have a nv listing in my /proc directory. but I suspect that I do not have it working. I thought maybe it was a module and tried lsmod, no AGP module. then I tried both insmod and modprobe agpgart.o and they both said that module agpgart was not found. so I tried to compile the newer 2.4.8. and include agp as a module. still no agpgart.o found or agpgart w/o the .o.

    I recompiled three times and no luck. I do not get any compile errors and I have used both make menuconfig and make xconfig, no luck and actually with the new kernels lsmod gives me no listed modules. even though I am sure I told it to use agp support as a module.

    Iíve looked around on xfree86.org (with google) for supported chip sets and conflicts, I found nothing to help me. I have also looked at the latest Nvidia readme 2313 and they say they have fixed a conflict with the VIA KT133 chipset that allows their NVagp module to be used. does this mean that all VIA chipsets have conflicts with AGP.

    I was playing with modprobe and saw that it references a file /etc/modules.conf. In it in my stock kernel configuration, I see agpgart and below it is "options agpgart agp_try_unsupported=1" and when I run "modprobe agpgart" it is loaded, I guess I did something wrong last night. . but when I try to run tuxracer it is still software accelerated.

    Here are the questions:

    1) Is my chipset supported?
    2) In stock form how do I get something to use agpgart and be accelerated after the module is loaded?
    3) Why don't I have a /proc/nv/card0 listing. Is it standard in X, or specific to if i have Nvidia's drivers installed?


    On a side note, I canít get my sound to work either after a kernel compile. But that is the next step in the kernel compile odyssey.

    Thanks, Brian


  2. #2

    Re: kernel odyssey...need help

    Since I could not answer your same question you posted at LNO (my account has been corrupted again), I will post here.

    I have the same via chipset though I have a Matrox G450.

    In the kernel config, I selected

    CONFIG_AGP=m
    # CONFIG_AGP_INTEL is not set
    # CONFIG_AGP_I810 is not set
    CONFIG_AGP_VIA=y
    # CONFIG_AGP_AMD is not set
    # CONFIG_AGP_SIS is not set
    # CONFIG_AGP_ALI is not set
    # CONFIG_AGP_SWORKS is not set
    CONFIG_DRM=y
    # CONFIG_DRM_TDFX is not set
    # CONFIG_DRM_GAMMA is not set
    # CONFIG_DRM_R128 is not set
    # CONFIG_DRM_RADEON is not set
    # CONFIG_DRM_I810 is not set
    CONFIG_DRM_MGA=m
    # CONFIG_DRM_SIS is not set
    # CONFIG_MWAVE is not set

    and also used try unsupported as you did. Mine works fine with X4.1.

    Have a look at the "How I did it" from LNO on Nvidia. Looks to be quite helpful. I just got another new pc at work (PIII-1Gz with a TNT2 and will try that article from LNO.

    http://www.linuxnewbie.org/cgi-bin/u...2&t=000641

    Hope this helps.

  3. #3

    Re: kernel odyssey...need help

    Hey Thor,
    the /proc/nv/card0 listing is just if you have the NVdirver loaded, it will tell you if agp is enabled or not, much like I have listed below. It will not work or be listed if you don't have the NVidia driver loaded. Do you have alias char-major-195 NVdriver in your /etc/modules.conf file?



    Code:
    [pbharris:~/nvidea]:cat /proc/nv/card0 
    ----- Driver Info ----- 
    NVRM Version: NVIDIA NVdriver Kernel Module 1.0.2313 Tue Nov 27 12:01:24 PST 2001
    Compiled with: gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)
    ------ Card Info ------
    Model:    GeForce2 MX/MX 400
    IRQ:     11
    Video BIOS:  03.11.01.30
    ------ AGP Info -------
    AGP status:  Enabled
    AGP Driver:  AGPGART
    Bridge:    Via Apollo Pro KT133
    SBA:     Supported [disabled]
    FW:      Unsupported [disabled]
    Rates:    2x 1x [2x]
    Registers:  0x1f000203:0x00000102
    [pbharris:~/nvidea]:

    mike - you lost another account???? thats unbelievable. mine still works, i rarely post there anymore though.

  4. #4

    Re: kernel odyssey...need help

    Paul... It's the same account I lost around a month ago. I've emailed whats_his_name 3 times with no response and since the LNO email is not working, I cannot receive a new password if I register again.

  5. #5

    Re: kernel odyssey...need help

    Hello Pb,

    I switched to mandrake 8.1 b/c it has X4.1 and i have to rebuild my system soon, New drive and Graphics card, so i thought i would load it up and play. well, i down loaded the Drake rpms from NVidia and installed them, i can get X to load, but only when i include the Option "NvAGP" "0". which is no AGP. with AGP enabled, either NV or agpgart, i just get a little white dot ithe upper left hand area of teh screen and the computer locks up. requireing a hard reboot.

    Any Ideas?

    Brian

  6. #6

    Re: kernel odyssey...need help

    Sorry, Mdwatts.

    I have also written down your kernel info for future complies. Thanks for the input.

    If you have any input to my problem with drake, i would gladly accept it.

    Brian

  7. #7

    Re: kernel odyssey...need help

    As I was saying earlier, I just got a tnt2 in my new pc at work the day before I started my vacation and I haven't had a chance to configure it correctly using the proper nvidia drivers. I did install Caldera OpenLinux Workstation 3.1 and the tnt2 was detected and setup. On Wednesday I'm planning to upgrade to X4.1 and install the nvidia drivers.

    Did you try what pbharris posted and the How I did it from LNO?

    Besides the nvidia driver website and what others have posted both here and at Linuxnewbie, I only have

    http://www.nvnews.net/cgi-bin/ultimatebb.cgi

    bookmarked to use as future reference. You may find something there to help.

  8. #8
    Senior Member
    Join Date
    May 2002
    Posts
    394

    Re: kernel odyssey...need help

    As far as getting your kernel compiled I would patch up to 2.4.17 or download the 2.4.17 and work with it. Instead of using such an old kernel.

    As far as your nvidia card goes, I would follow the instructions that nvidia has on their website for their drivers. I found their how-to very good and it left me with no questions.

  9. #9

    Re: kernel odyssey...need help

    hello thor,
    is NVdriver listed when you type /sbin/lsmod | grep NV ? If so then there really should be a /proc/nv/card0 listed, if not then it is not getting loaded properly and you are using the default XF86 driver.
    here is a kinda old version of my xfree86 config file but it works really good, check out the differences between it and what you have, maybe something is out of wack which has nothing to do with AGP.

    http://members.telocity.com/cph013/XF86Config-4

  10. #10

    Re: kernel odyssey...need help

    PB, I figured out how to get X to load with the nvidia driver. i have to "modprobe NVdriver" first, or else x fails with a fatal error about no useable screens found. Then i have a /proc/nv/card0 entry.
    But X only loads when i set "Option "NvAGP" "0", which disables AGP totally. with normal the normal "nv" driver from XFree86 i can load the agpgart module, but when i run a 3D tron game that came with Drake and run lsmod, it says that agpgart is not being used and the games tells me it gets at most about 20 fps and the action is all choppy. I have had problems in the past with this card and directX(system freezes in Q2 and Theif), i wonder if the card is bad, or it just doesn't like my motherboard.

    There is a documented problem in the NVIDIA release notes about the TNT2 cards. The fix requires that you compile the kernel module, bu that requires system kernel headers and drake does not install the kernel source and SuSE doesn't either, so i need to compiel my own kernel, and there seems to be know end to the headaches with kernel compiles. i'll try mdwatts sugestions today.

Similar Threads

  1. Yes - Yes, it is. Kernel 2.6.9
    By pbharris in forum Linux - General Topics
    Replies: 6
    Last Post: 10-27-2004, 07:47 PM
  2. What kernel are you using?
    By paradox in forum Linux - General Topics
    Replies: 13
    Last Post: 09-02-2003, 03:47 AM
  3. kernel...
    By sujoki in forum Linux - General Topics
    Replies: 4
    Last Post: 08-30-2003, 04:38 PM
  4. Red Hat's kernel
    By trickster in forum Linux - General Topics
    Replies: 7
    Last Post: 09-30-2002, 01:25 AM
  5. kernel.org ?
    By civ1492 in forum General Chat
    Replies: 4
    Last Post: 12-04-2001, 11:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •