Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
kernel compiled and works fine but modem is borked
Results 1 to 4 of 4

Thread: kernel compiled and works fine but modem is borked

  1. #1
    Senior Member
    Join Date
    May 2002
    Posts
    394

    kernel compiled and works fine but modem is borked

    I just upgraded to 2.4.17 and everything seems to be working fine except for my modem. It is a pci hardware modem that works fine with the 2.2.17-reiserfs kernel. So, I assume that the problem is with how I compiled the kernel.

    What could have I messed up, I thought that I enabled everything that I needed. Like the PCI bus and PPP and Serial devices. Also, the parallel port was enabled.

    When I do a
    setserial /dev/ttyS2 uart 16550A port 0xe000 irq 10

    (which is what I used for the 2.2.17 kernel)

    It says the address is busy.

    Any ideas?

  2. #2
    Senior Member
    Join Date
    May 2002
    Posts
    394

    Re: kernel compiled and works fine but modem is bo

    hmmm...anyone?

  3. #3
    Senior Member
    Join Date
    May 2002
    Posts
    394

    Re: kernel compiled and works fine but modem is bo

    Okay, here is some more info.

    I checked the log and I noticed that my modem was coming up as ttyS04 which isn't a directory or file on my system.

    I then noticed that com 1 and com 2 came up as ttyS00 and ttyS01 but after the system was up they went to ttyS0 and ttyS1.

    Does anyone know whats up here?

    oh btw..... I cant makedev ttyS04 it says it doesnt know how.....

  4. #4
    Senior Member
    Join Date
    May 2002
    Posts
    394

    Re: kernel compiled and works fine but modem is bo

    I fixed it...... here is what I did. After I noticed that com 1 and com 2 came up as ttyS00 and ttyS01 and then changed to ttyS0 and ttyS1 after the system was up. I decided to cd into /dev and ./MAKEDEV ttyS4 and then everything worked fine. But, I guess in the future this wont be need to be done because the kernel will figure everything out itself (if you compile in that option) but, you can choose the option now and its experiemental. But, I was too lazy to compile my kernel again.

Similar Threads

  1. Compiled Kernel but cannot boot
    By shebang in forum Linux - General Topics
    Replies: 28
    Last Post: 04-05-2004, 12:09 PM
  2. modem works intermintenly
    By xe1mak in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 01-17-2004, 07:35 PM
  3. Can't get kernel compiled with NTFS
    By Rastar in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 05-28-2003, 09:35 PM
  4. Java works fine in netscape but not konqueror
    By jmcook in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 10-23-2002, 02:37 AM
  5. modem trouble post kernel recompile
    By cj171 in forum Linux - General Topics
    Replies: 13
    Last Post: 09-22-2002, 02:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •