Results 1 to 4 of 4

Thread: vsftp issue

  1. #1
    Associate
    Join Date
    Jul 2004
    Location
    Sydney, Australia
    Posts
    12

    vsftp issue

    Hello,

    I am running VSFTPD on FC2 machine and i am connected to LAN, I am trying to FTP the neighbour machine ftp://neighbourmachine i get all the contents from /var/ftp/pub displayed. I need to password protect it, how do i it ? it's not an anonmyous access.

    any idea ? I don't see any option in /etc/vsftpd/vsftpd.conf. Please advise

  2. #2
    Senior Member
    Join Date
    May 2004
    Location
    Pakistan
    Posts
    253

    Re:

    Dear markwaugh,
    Hello,

    I am running VSFTPD on FC2 machine and i am connected to LAN, I am trying to FTP the neighbour machine ftp://neighbourmachine i get all the contents from /var/ftp/pub displayed. I need to password protect it, how do i it ? it's not an anonmyous access.
    Just Disable Anonymouse Access !! and If Anonymouse Access is Disabled then how you access the FTP server ?

    Best Regards.
    Frrkh hmd

  3. #3

    vsftpd.conf

    Hello, Mark

    Maybe the following could help you out:

    I am running VSFTPD on FC2 machine and i am connected to LAN, I am trying to FTP the neighbour machine ftp://neighbourmachine i get all the contents from /var/ftp/pub displayed. I need to password protect it, how do i it ? it's not an anonmyous access.
    1. copy the original vsftpd.conf, in case, later on you need it again.
    [root@tomahawk g00rkha]# cp /etc/vsftpd.conf /etc/vsftpd.conf.old

    2. then do vi vsftpd.conf
    [root@tomahawk g00rkha]# vi /etc/vsftpd.conf

    3. Edit the conf as follows:
    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are very paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    #
    # Allow anonymous FTP?
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    These two set-ups enable local user accounts to do uploading files during a vsftpd session
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    local_umask=022

    Here is the set-up for restricting all regular users to their home directory when using vsftpd
    chroot_local_user=YES

    4. Type Esc then :q to quit from vi.

    5. Do the following:
    [root@tomahawk g00rkha]# /etc/init.d/xinetd restart

    Basically, the above tutorial will disable anonymous users and restrict only to local user accounts can login to your vsftp then those local user accounts restrict to their home directories.

    Hope my short tutorial would help you.

    Cheers,
    g00rkha :lol:

  4. #4
    Senior Member
    Join Date
    May 2004
    Location
    Pakistan
    Posts
    253

    Re:

    Dear g00rkha,
    Hello,

    [root@tomahawk g00rkha]# /etc/init.d/xinetd restart
    vsftpd have nothing to do with xinetd

    Best Regards.
    Frrkh hmd

Similar Threads

  1. ssh issue
    By pigpenstud01 in forum Redhat / Fedora
    Replies: 1
    Last Post: 05-02-2008, 09:42 PM
  2. VSFTP on Fedora 8
    By Spyke in forum Redhat / Fedora
    Replies: 1
    Last Post: 03-21-2008, 08:16 AM
  3. Ogg to MP3 issue
    By Schotty in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 06-17-2005, 05:00 AM
  4. need some advice for web techs in the field via fedora/vsftp
    By gulfsurfer in forum Linux - General Topics
    Replies: 1
    Last Post: 02-22-2005, 08:42 AM
  5. vsFTP on Redhat 8
    By BamaFeva in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 10-27-2002, 12:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •