Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Stupid KDE headers
Results 1 to 9 of 9

Thread: Stupid KDE headers

  1. #1

    Stupid KDE headers

    Code:
    checking for KDE... configure: error: 
    in the prefix, you've chosen, are no KDE headers installed. This will fail.
    So, check this please and use another prefix!
    I get this while trying to install kmud or kxicq from source. What do I need to get KDE headers?


  2. #2

    Re: Stupid KDE headers

    Hi ASCI, i would hate to be kmud ... okay bad joke
    anywho...
    qt-devel
    kdelibs-devel
    kdesupport-devel should do it for you.


  3. #3

    Re: Stupid KDE headers

    *cackle*

    This is kxicq! :P

    I don't suppose there's a way to install just those 3 libs is there? Apt-get wants to install 18 files. :-/

  4. #4

    Re: Stupid KDE headers

    you could use dpkg and install them like that after you download the three files. type dpkg --help for useage, i use apt-get, you may need what else apt-get is wanting to get.

  5. #5

    Re: Stupid KDE headers

    I'm having problems finding that kdesupport library, already have the qt stuff installed and he's a humorous thing. The kdelibs-dev doesn't want to play nice with qt3 tools...to remove qt3 tools I need to remove libqt3-dev.

    __________________________________________________ __________

    Went back to qt2, still working on the others though.

    Code:
    checking for KDE headers installed... configure: error: your system is not able to compile a small KDE application!
    Check, if you installed the KDE header files correctly.
    Must be missing one file or apt borked an install. Still unable to find kdesupport file.

  6. #6
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re: Stupid KDE headers

    Have you tried removing the packages and reinsatlling them? Also check to see if your paths are okay. That may have something to do with it. Your system may be looking for the files which are there, just not where it is expected to be.

    I had some weird crap like that on my old slack setup at work. I used GNOME till I figured out the paths werent right. Serves me right though for not doing the upgrade correctly.

  7. #7

    Re: Stupid KDE headers

    I don't know about kxicq, but I do know that kmud requires the KDE 1 libraries, not KDE 2 or 3. You will need to have those installed to compile it. Your best bet is just to use the binary version.

  8. #8

    Re: Stupid KDE headers

    I worked with the binary version of kmud for a bit, but it got annoying that I couldn't make a windowmaker menu button to run it. A moot point really but a turn off for me.

    The path's stuff is something no one has given me an answer on. What's supposed to be there?

  9. #9
    Guest

    Re: Stupid KDE headers

    the following (among others) is in my path: /usr/local/kde2/bin
    so u just need to add the path to the bin directory for kde to your path

    also, make sure that the path to the lib directory of kde is in ur /etc/ld.so.conf
    on my system it's this: /usr/local/kde2/lib

    also make sure the lib directory for QT is in there: /usr/local/qt/lib (on my system)

    if u have to add those to /etc/ld.so.conf make sure to run ldconfig afterwards as root or else the changes won't be picked up

Similar Threads

  1. Kernel Headers
    By omidkamangar in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 01-14-2007, 04:56 AM
  2. I've been very stupid!
    By Tantrums in forum Windows - General Topics
    Replies: 1
    Last Post: 07-10-2006, 11:01 PM
  3. Sendmail - Masquerading and headers
    By TheEdge in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 11-29-2004, 09:03 PM
  4. Ask a stupid question, get a stupid answer.
    By Stuart in forum General Chat
    Replies: 17
    Last Post: 10-02-2003, 12:39 AM
  5. libGLU.so.1, NVIDIA & Kernel Headers
    By teknik0s in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 04-27-2003, 04:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •