Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: No Sound in Xine with ECS K7S5A

  1. #1
    Junior Member
    Join Date
    Jan 2002
    Posts
    84

    No Sound in Xine with ECS K7S5A

    I installed Xine rpms, it installed fine and can play the videos and divx but there is no sound

    I know this boards has a problem with linux and sound but I dont know how to set it up

    How do I

    ECS K7S5A
    RH 7.2

  2. #2
    Guest

    Re: No Sound in Xine with ECS K7S5A

    is it one of those boards with on-board sound?

  3. #3
    Junior Member
    Join Date
    Jan 2002
    Posts
    84

    Re: No Sound in Xine with ECS K7S5A

    yes

    It says I havr no sound server installed or configured so it sait it to null

    A PCI sound card was found in your * * *x * * * * * * * * *
    * * * * * * * * *x system. The details are: * * * * * * * *x * * * * * * * * *
    * * * * * * * * *x * * * * * * * * * * * * * * * * * * * * x * * * * * * * * *
    * * * * * * * * *x * * *Model: Silicon Integrated Systems *x * * * * * * * * *
    * * * * * * * * *x [SiS]|unknown device 1039:7012
    lqqqqqqu PCI Probe Results tqqqqqqk * * * * * * * * * * *
    * * * * * * * * * * *x * * * * * * * * * * * * * * * * x * * * * * * * * * * *
    * * * * * * * * * * *x The Silicon Integrated Systems *x * * * * * * * * * * *
    * * * * * * * * * * *x [SiS]|unknown device 1039:7012 *x * * * * * * * * * * *
    * * * * * * * * * * *x is not supported. * * * * * * * x * * * * * * * * * * *
    * * * * * * * * * * *x * * * * * * * * * * * * * * * * x * * * * * * * * * * *
    * * * * * * * * * * *x * * * * * * lqqqqk * * * * * * *x * * * * * * * * * * *
    * * * * * * * * * * *x * * * * * * x Ok x * * * * * * *x * * * * * * * * * * *
    * * * * * * * * * * *x * * * * * * mqqqqj *
    I guess the on board sound is not working and I dont have a sound card. *I know there are some people who got sound out of this board but I dont know how


  4. #4
    Junior Member
    Join Date
    Dec 2001
    Posts
    65

    Re: No Sound in Xine with ECS K7S5A

    i've tried xine. it was too much of a hassle, i couldn't even get a picture much less sound. i use avifile for divx avi's and such, and ogle for dvd's. both work pretty flawlessly.

  5. #5

    Re: No Sound in Xine with ECS K7S5A

    i've tried xine. it was too much of a hassle, i couldn't even get a picture much less sound. i use avifile for divx avi's and such, and ogle for dvd's. both work pretty flawlessly.
    Some just don't have much luck with certain software. Xine works great for me. Xine 0.98 plus the d4d plugin always compiles cleanly on my system and the picture/sound quality is just as good as anything on Windows.

    Kaiser_Sose...

    I did a Linux Google search for ECS K7S5A and got quite a few hits concerning the Sis-735 onboard sound. It doesn't look promising.

    One was from Alan Cox

    > I've already talked with SiS. They are insisting that they will write the
    > drivers themselves, they dont want to release datasheets to anyone. The
    > reply I got (Thu, 25 Oct 2001) they said they are working on OSS drivers
    > in-house, and ALSA drivers are next.

    I guess in the mean time SIS board are best avoided. Who knows if they'll
    ever actually deliver
    You could try the Google search yourself as I didn't read all of them.

    http://www.google.com/linux

    Also try a search for the specific SiS sound chipset.

  6. #6
    Junior Member
    Join Date
    Jan 2002
    Posts
    84

    Re: No Sound in Xine with ECS K7S5A

    I found this but I dont know how to aplly it or install it

    http://www.uwsg.indiana.edu/hypermai...12.3/0580.html

  7. #7

    Re: No Sound in Xine with ECS K7S5A

    Normally you would apply a patch to the kernel source using

    cd /usr/src/linux

    patch -p1 < /path/to/name_of_patch

    and then recompile the kernel.

    I'm not sure what you would do in a case like this.

    Perhaps you replace /usr/src/linux/drivers/sound/i810_audio.c with the text from the patch OR the patch requires to be incorporated into the existing i810_audio.c.

    I'm sure someone here will know what needs to be done.

  8. #8
    Guest

    Re: No Sound in Xine with ECS K7S5A

    yep, apply the patch to the kernel source, reconfigure it so that it compiles the support for the sound, and then recompile & install the kernel

  9. #9
    Junior Member
    Join Date
    Jan 2002
    Posts
    84

    Re: No Sound in Xine with ECS K7S5A

    yep, apply the patch to the kernel source, reconfigure it so that it compiles the support for the sound, and then recompile & install the kernel
    Do you know how to do this and do you kmow if this patch works

    /me dont know how

  10. #10

    Re: No Sound in Xine with ECS K7S5A




    Do you know how to do this and do you kmow if this patch works

    /me dont know how
    Sure - download the patch (lets call it sispatch.gz) and copy to /usr/src/ . - uncompress it (gunzip sispatch.gz) - lets say the uncompressed file is now called sispatch


    then just like mdwatts said only make sure you are in the directorty /usr/src/linux type
    patch -p1 < /usr/src/sispatch - a bunch of stuff will fly by and hopefully no errors. the build your kernel - here is a PET on doing this:
    http://www.linuxjunior.org/cgi-bin/p...splay&id=9

    hope that helps.

Similar Threads

  1. Xine PET
    By trickster in forum Linux - General Topics
    Replies: 9
    Last Post: 07-11-2003, 01:47 AM
  2. Xine and dvd's
    By 10Dedfish in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 04-23-2003, 08:14 PM
  3. XINE
    By babbing in forum Redhat / Fedora
    Replies: 12
    Last Post: 02-20-2003, 06:54 PM
  4. dvd using Xine
    By beanman2k in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 11-13-2002, 07:22 AM
  5. xine
    By pinehead in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 04-04-2002, 06:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •