Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Emacs annoyance.

  1. #1
    Aaron_Adams
    Guest

    Emacs annoyance.

    I use emacs and vi, so don't pester me! ;D

    When I save in emacs it always creates a back up file, by appending a ~ to the name of the file. As "safe" as this is, it's #$@!ing annoying, and clutters up my folders. Does anyone have any idea how to stop that? The only way I have to fix it right now is '$ ls *~ | xargs rm'

    There must be a better way.

  2. #2
    JimH
    Guest

    Re: Emacs annoyance.

    Add this to your ~/.emacs

    (custom-set-variables
    ;; custom-set-variables was added by Custom -- don't edit or cut/paste it!
    ;; Your init file should contain only one such instance.
    '(make-backup-files nil))

    As per the warning if you already have a "custom-set-variables" entry just add '(make-backup-files nil) to it.

    For version 20.x look under Help
    For Version 21.x look under Options

    Jim H

  3. #3

    Re: Emacs annoyance.

    Thankyou ;D

    now i can do that too
    whatdoyougetwhenyoumultiplysixbynine??

  4. #4
    Aaron_Adams
    Guest

    Re: Emacs annoyance.

    I suppose I could have looked it up, but figured asking was easier. Thank you kindly.

  5. #5
    JimH
    Guest

    Re: Emacs annoyance.

    Sometimes when it comes to trying to figure out how to customize emacs it is easier to ask. I knew the answer to this one. ;D

    Jim H

  6. #6
    Aaron_Adams
    Guest

    Re: Emacs annoyance.

    Low and behold, I have no ~/.emacs

    How interesting. The search begins.

  7. #7
    JimH
    Guest

    Re: Emacs annoyance.

    Low and behold, I have no ~/.emacs

    How interesting. The search begins.
    Whoa! I guess slack doesnt have any default customizations. Either create the ~/.emacs file yourself or use the emacs menu to change the setting and let emacs do it for you.

    Jim H

  8. #8
    Aaron_Adams
    Guest

    Re: Emacs annoyance.

    Done and done.

  9. #9
    Aaron_Adams
    Guest

    Re: Emacs annoyance.

    So today I decide I am finally sick of the default 2 space tabs. I find the option and change it, and all is well. I set for current session and future sessions. Low and behold, the option doesn't stay. In my ~/.emacs file it says it is set to 4, but everytime it opens it is set back to 2.

    Bugger off emacs!

  10. #10
    JimH
    Guest

    Re: Emacs annoyance.

    Which one are you trying to change:

    The amount of spaces the cursor moves when you hit tab?
    '(tab-width 4)

    The default amount of spaces emacs indents when you hit tab within a function?
    '(standard-indent 2)

    Jim H

Similar Threads

  1. Happiness with 7.10, but one small annoyance
    By JoeyJoeJoe in forum Ubuntu / Debian
    Replies: 0
    Last Post: 11-23-2007, 04:51 PM
  2. Emacs
    By cga in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 10-18-2003, 10:03 PM
  3. cga and Emacs
    By cga in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 08-26-2003, 01:28 PM
  4. Annoyance -- Freezing
    By Lalartu in forum Linux - General Topics
    Replies: 6
    Last Post: 03-26-2003, 06:39 AM
  5. Emacs 21 RPM's for RH 7.2
    By JimH in forum Redhat / Fedora
    Replies: 7
    Last Post: 10-28-2001, 12:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •