Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Problem Installing aureal drivers
Results 1 to 9 of 9

Thread: Problem Installing aureal drivers

  1. #1

    Problem Installing aureal drivers

    Hi,

    I have a Turtle Beach Montego II A3D320V.

    I'm trying to get it to work under slackware 7.1.0.

    I downloaded the drivers from:

    http://sourceforge.net/projects/aureal

    The docs say that it works for the au8810 au8820 and au8830 chipsets (Aureal Vantage, Vortex 1 and Vortex 2 chipsets) and there is an install option for each one. My first question is: how can I find out which one I have?

    I tried all three using 'gmake install'
    I got the following message:

    cc -D__KERNEL__ *-DMODULE -DAU8830 -mpentiumpro *-O6 -fomit-frame-pointer -Wall -pipe -I/usr/src/linux/include * -c -o au_audio.o au_audio.c
    make cc: Command not found
    make *** [au_audio.o] Error 127

    What is that all about and what do I need to do to install the drivers properly?

    Thanks

  2. #2

    Re: Problem Installing aureal drivers

    hello,
    i am not sure how you can determine which card you have besides looking at it, there should be numbers on th IC which tell you which one you have.

    on the other issue it looks like either gcc is not installed.

  3. #3

    Re: Problem Installing aureal drivers

    Hi,

    I downloaded the gcc package for slackware 7.1.0 and ran pkgtool as root to install it. I got no error messages.

    But when I run gmake I get the same error message. Is there a way to make sure the installation was successful?

    What should I do next? Thanks.

  4. #4

    Re: Problem Installing aureal drivers

    you can test it out by compiling a simple c program
    e.g here is a file called empty.c

    main()
    { }

    type cc -o empty empty.c and if nothimh gets returned it is okay.

    another problem is that the makefile may not have gcc to be defined as cc.

  5. #5

    Re: Problem Installing aureal drivers

    pbharris,

    I created the empty.c file as per your speficications.

    When I type *cc -o empty empty.c, I get ' command not found.'

    When I type gcc *-o empty empty.c, I get:

    gcc: installation problem, cannot exec `as': No such file or directory

    -------------

    You said that makefile may not have gcc to be defined as cc.
    How would I define gcc as cc in the makefile?

    Here is the makefile if it is helpful:

    ------------

    # Makefile for Vortex au88xx driver
    #
    # Copyright (c) 1999 Aureal Inc.
    # Copyright (c) 2000 Warren Chartier
    # Modified to adapt the new source tree by Nikos Kalogridis
    #
    # Environment:
    # * * *AUCHIP * * * * * *- AU8830 (default), AU8820, or AU8810
    # * * *AUSMP * * * * * *- empty (default) or -D__SMP__
    #
    # This program is free software; you can redistribute it and/or modify
    # it under the terms of the GNU General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # This program is distributed in the hope that it will be useful,
    # but WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. *See the
    # GNU General Public License for more details.
    #
    # You should have received a copy of the GNU General Public License
    # along with this program; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
    #
    # Contact: http://aureal.sourceforge.net

    ifndef AUCHIP
    AUCHIP = AU8830
    endif

    ifeq ($(AUCHIP),AU8830)
    NAME = au8830
    ASP_OBJ = asp30.o
    endif

    ifeq ($(AUCHIP),AU8810)
    NAME = au8810
    ASP_OBJ = asp10.o
    endif

    ifeq ($(AUCHIP),AU8820)
    NAME = au8820
    ASP_OBJ = asp20.o
    endif

    VER * *= $(shell uname -r)
    MODDIR = /lib/modules/$(VER)/misc
    CONF * = $(wildcard /etc/modules.conf)
    ifeq ($(strip $(CONF)),)
    CONF * = /etc/conf.modules
    endif

    INCLUDEDIRS = -I/usr/src/linux/include

    #
    # CPU types, Uncomment one only!
    #
    #CFCPU = 486
    #CFCPU = pentium
    CFCPU = pentiumpro

    #
    # If you have an SMP system uncomment the following (experimental)
    #
    #AUSMP = -D__SMP__

    #
    # Debug/Optimization
    #
    #CFDEBUG = -g -DDEBUG=1 -DDEBUG_AU -D__VerboseMode
    CFOPT = -O6 -fomit-frame-pointer

    # Do Not Modify Anything Below This Line!

    CFLAGS * * *= -D__KERNEL__ $(AUSMP) -DMODULE -D$(AUCHIP) -m$(CFCPU) $(CFDEBUG) $(CFOPT) -Wall -pipe $(INCLUDEDIRS)

    CFILES = au_audio.c au_midi.c au_core.c au_sndstat.c au_mixer.c au_utils.c au_vortex.c
    OFILES = $(CFILES:.c=.o)

    $(NAME).o: $(OFILES) $(ASP_OBJ)
    * * *$(LD) -m elf_i386 -r $^ -o $@

    compile: $(NAME).o

    install: compile
    * * * mv -f $(CONF) $(CONF).old
    * * * gawk -f mod_conf $(CONF).old > $(CONF)
    * * * echo "alias sound $(NAME)" >> $(CONF)
    * * * echo "alias midi $(NAME)" >> $(CONF)
    * * * mkdir -p $(MODDIR)
    * * * cp -f $(NAME).o $(MODDIR)
    * * * -/sbin/depmod -a
    * * * -/sbin/rmmod $(NAME)
    * * * -/sbin/modprobe $(NAME)

    install10:
    * * *$(MAKE) install AUCHIP=AU8810

    install20:
    * * *$(MAKE) install AUCHIP=AU8820

    rebuild10:
    * * *$(MAKE) rebuild AUCHIP=AU8810

    rebuild20:
    * * *$(MAKE) rebuild AUCHIP=AU8820

    rebuild: clean install

    clean:
    * * *rm -f $(NAME).o $(OFILES)

    drebuild:
    * * *$(MAKE) rebuild VERBOSE=YES
    * * *
    drebuild10:
    * * *$(MAKE) rebuild10 VERBOSE=YES

    drebuild20:
    * * *$(MAKE) rebuild20 VERBOSE=YES


  6. #6

    Re: Problem Installing aureal drivers

    Hello,
    this would done with a CC = gcc possibly with some other flags, but seeing that gcc fails on the simplist C program i can think of then i would says that some thing is not installed - namely some deveopment tools, e.g. gcc-objc or perhaps some headers...


  7. #7

    Re: Problem Installing aureal drivers

    Hi,

    I downloaded (for two hours * ) the development tools that slackware said were necessary to compile- including the one you suggested.

    When I input:
    gcc -o empty empty.c

    I get the following back:
    cpp: /tmp/ccOia6o3.i: No space left on device

    Despite this failure I tried 'make install' with the aureal drivers anyway and added CC = gcc.

    I got the following back from linux (LONG):

    In file included from au_audio.c:49:
    au_vortex.h:39: linux/config.h: No such file or directory
    au_vortex.h:44: linux/version.h: No such file or directory
    au_vortex.h:46: parse error
    au_vortex.h:50: linux/autoconf.h: No such file or directory
    au_vortex.h:57: linux/kernel.h: No such file or directory
    au_vortex.h:58: linux/module.h: No such file or directory
    au_vortex.h:59: linux/version.h: No such file or directory
    au_vortex.h:60: linux/config.h: No such file or directory
    au_vortex.h:61: linux/string.h: No such file or directory
    au_vortex.h:62: linux/ioport.h: No such file or directory
    au_vortex.h:63: linux/sched.h: No such file or directory
    au_vortex.h:64: linux/delay.h: No such file or directory
    au_vortex.h:65: linux/sound.h: No such file or directory
    au_vortex.h:66: linux/malloc.h: No such file or directory
    au_vortex.h:67: linux/soundcard.h: No such file or directory
    au_vortex.h:68: linux/pci.h: No such file or directory
    au_vortex.h:69: asm/io.h: No such file or directory
    au_vortex.h:70: linux/poll.h: No such file or directory
    au_vortex.h:71: asm/uaccess.h: No such file or directory
    au_vortex.h:72: linux/utsname.h: No such file or directory
    au_vortex.h:74: parse error
    au_vortex.h:77: asm/spinlock.h: No such file or directory
    au_vortex.h:80: parse error
    au_vortex.h:118: parse error
    au_vortex.h:146: parse error
    au_vortex.h:197: parse error
    au_audio.c:50: linux/version.h: No such file or directory
    au_audio.c:63: parse error
    au_audio.c:606: parse error
    au_audio.c:666: parse error
    au_audio.c:690: parse error
    au_audio.c:767: parse error
    au_audio.c:825: parse error
    au_audio.c:838: parse error
    au_audio.c:859: parse error

    ...

    [I cut out the middle so that linuxjunior will let me post a message]

    ...
    au_audio.c:1105: parse error before `*'
    au_audio.c: In function `au_handle_timer':
    au_audio.c:1107: `dev' undeclared (first use this function)
    au_audio.c:1121: warning: implicit declaration of function `wake_up_interruptible'
    make: *** [au_audio.o] Error 1

    What should I do now? How do I get around the space problem for the empty program and what does make install need me to do next to get it to work?

    Thanks!

  8. #8

    Re: Problem Installing aureal drivers

    hi infohawk,
    well - it looks like the partition which /tmp is on is full, do a df -h to verify this. what ever it is clean up /tmp and anything else you can,

    the other errors look like drivers are looking for the linux kernel source in /usr/src - if you have the CDs slackware came on you can install the kernel source package. There are probably a one, maybe two thousand undefined things causing the parse errors, these would be defined in the kernel source headers.

    i know a few poeple who gotten these working with the drivers you are using - i know it seems like a pain in the ___ getting these drivers up and running...

    hopefully there are not too many more steps

  9. #9

    Re: Problem Installing aureal drivers

    Pbharris,

    I think it's time for me to graduate to a real distro.

    Up until now I've been using Dragonlinux, which is based on slackware 7.1.0. Anyway, Dragonlinux runs on a loop file so that there is no need to repartition. The problem is there is no quick way for me to get more room. I'm sure I could get more room, but I'd prefer to just get a new distro and make a new partition because dragonlinux has some other limitations as well for me.

    [i know a few poeple who gotten these working with the drivers you are using - i know it seems like a pain in the ___ getting these drivers up and running... *

    hopefully there are not too many more steps *
    Don't worry-- I'm not gonna give up as long as all the help keeps coming. *

    Thanks for your help. Every step taught me something new about linux. I need a full distro so I don't have to always download components I will need later and I need a partition for linux so I don't have to worry about space. I just need to get the cds (from the mail since my connection is slow) and then I will get back to these audio drivers--

    In the meantime I'm gonna see if I can do stuff with my laptop and linux.

    THanks for all your help, I'll post again when I'm trying to install the drivers on my new partition or when I need help with my laptop. Thanks again.

Similar Threads

  1. Nvidia drivers (rpm) install problem
    By lewis in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 09-27-2002, 05:25 AM
  2. Installing Kernel Source for Nvidia drivers.
    By beatlejuice321 in forum Linux - Software, Applications & Programming
    Replies: 7
    Last Post: 09-02-2002, 06:17 PM
  3. installing modem drivers
    By HuFlungDung in forum Suse
    Replies: 1
    Last Post: 08-05-2002, 08:06 PM
  4. New NVIDIA drivers and compile problem!
    By pbharris in forum Linux - General Topics
    Replies: 27
    Last Post: 07-20-2002, 09:40 PM
  5. problem with new nvidia drivers
    By agar in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 03-10-2002, 04:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •