Hi,
I have a first linux machine running this version:

Linux version 2.4.21-37.EL (bhcompile@tweety.build.redhat.com) (gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-53)) #1 Wed Sep 7 13:35:21 EDT 2005

There are dhcpd and xinetd services running, and I want to use them for loading linux via tftp on a second machine.

The second machine is connected to the first one via ethernet to through "eth1" interface. The eth1 has IP 192.168.1.1.

When the second machine boots, it gets correctly the IP 192.168.1.222 from dhcp server, but then the tftp fails for timeout.

Running tcpdump on the first machine, I get this:

21:51:22.368091 192.168.1.222.2070 > 192.168.1.1.tftp: [udp sum ok] 46 RRQ "/tftpboot/diskless/pxelinux.0" (ttl 20, id 2, len 74)
4500 004a 0002 0000 1411 2272 c0a8 01de
c0a8 0101 0816 0045 0036 dbc3 0001 2f74
6674 7062 6f6f 742f 6469 736b 6c65 7373
2f70 7865 6c69 6e75 782e 3000 6f63 7465
7400 7473 697a 6500 3000
21:51:22.368113 192.168.1.1 > 192.168.1.222: icmp: 192.168.1.1 udp port tftp unreachable for 192.168.1.222.2070 > 192.168.1.1.tftp: [udp sum ok] 46 RRQ "/tftpboot/diskless/pxelinux.0" (ttl 20, id 2, len 74) [tos 0xc0] (ttl 64, id 59628, len 102)
45c0 0066 e8ec 0000 4001 0cbb c0a8 0101
c0a8 01de 0303 8174 0000 0000 4500 004a
0002 0000 1411 2272 c0a8 01de c0a8 0101
0816 0045 0036 dbc3 0001 2f74 6674 7062
6f6f 742f 6469 736b 6c65 7373 2f70 7865
6c69 6e75 782e 3000 6f63 7465 7400 7473
697a 6500 3000

It looks like a firewall problem, but I have disabled it without success.

Here is the contents of /etc/xinet.d/tftp:

[eswteam@itl6073d eswteam]$ cat /etc/xinetd.d/tftp
# default: off
# description: The tftp server serves files using the trivial file transfer \
# protocol. The tftp protocol is often used to boot diskless \
# workstations, download configuration files to network-aware printers, \
# and to start the installation process for some operating systems.
service tftp
{
socket_type = dgram
protocol = udp
port = 69
wait = yes
flags = IPv6 IPv4
user = nobody
server = /usr/sbin/in.tftpd
server_args = /tftpboot
disable = no
# per_source = 11
# cps = 100 2
}

Thanks who anyone will help me!!
Alberto