Results 1 to 3 of 3

Thread: Getting connected to internet

Hybrid View

  1. #1

    Question Getting connected to internet

    I have recently got hold of an old server that I have decided to take on as a project.

    I loaded CentOS 6.2 and was able to get it connected to the internet via my existing broadband router. So far, so good.

    My plan is to replace this router with a more componentised approach based on this server. To this end I bought an ADSL2+ modem (TP-Link TD-8616). I got this setup using my Windows laptop – so I know that it is correctly configured and working. My ISP is running PPPoA as follows
    VPI/VCI: 0/38
    Encapsulation: VC/MUX
    DNS: Auto (provided by ISP)
    MTU: 1432

    Now I just have to get it working from CentOS. Although I generally can find what I need on the net I have really struggled with finding a good description of what to do next – though I have spent many hours researching. (The plan is to add a second NIC later and then configure DHCP and iptables.)

    The best guess I have from what I have been reading is that I need to setup ppp0 to “wrap” around eth0. After a lot of searching the only real way that I think that I have found to do this is by installing the Roaring Penguin pppoe. (I am slightly concerned that it seems to be PPPoE rather than PPPoA – but I don’t suppose that is really any different from Windows, so I proceeded anyway.)

    I download and installed this and setting it up (pppoe-setup) seemed straight forward enough. When I do ‘ifup ppp0’ then I see that I have an IP address which I assume has come from the ISP. However, I am not confident about this because the internet light on the modem continues to flash and, unsurprisingly really, I can’t ping anything out on the internet.

    My best guesses are
    1. I did see some reference to making sure that eth0 isn’t configured to start on boot – but it is far from clear to me whether that was relevant or not since much of the documentation that I have found is VERY old
    2. It may be that I have to setup some routing – but this isn’t really an area that I have looked into in any great detail as yet

    I can certainly go into more detail as/when someone takes up the challenge to try and point me in the right direction, but I thought I would get this posted now and see who is prepared to take this journey with me . Posting updates once I get home gets a lot harder because I will then have to keep switching between the modem (for testing) and the router (for accessing web).

    Cheers

    Joe

  2. #2
    Hi Joe,

    Honestly, I had only heard about PPPoE, but good to know about another network solution such as PPPoA , anyway...after a google search I found a configuration file that included a library called "pppoatm.so"

    https://gist.github.com/1321472

    but..I looked for it in my CentOS box(6.0), and only found a kernel module called pppoatm.ko, so I loaded the module without any issue, awfully I have no PPPoA to go further, but you might want to work with that module loaded and check the options available for the ppp0 configuration file (I have not checked the one from the link above as I dont have PPPoA, but you might want to try it)

    Here are some details about the module:
    #uname -r
    2.6.32-71.el6.i686
    #find / -iname "*pppoa*"
    /lib/modules/2.6.32-71.el6.i686/kernel/net/atm/pppoatm.ko
    #modprobe pppoatm
    #lsmod | grep pppoatm
    pppoatm 3823 0
    ppp_generic 21336 1 pppoatm
    atm 39042 1 pppoatm

    I hope this helps you out!, good luck, and I'll stay tuned for the result

    Regards,
    protocentux

  3. #3
    After leaving the problem for a couple of days I returned to it this morning. The first thing to note was that I found that this topic is covered in Ch.03 in much more detail than I remembered from previous reading. I think I must have spent so much time worrying and reading about other areas that it had slipped my mind.

    Anyway, I immediately recognised the references to the Roaring Penguin PPPoE implementation - so I figured that had to be a good place to start. I simply worked through the setup and everything kicked into life I'm pleased to say. I don't really know what I did differently this time as I didn't seem to have done anything that I hadn't on previous attempts.

    Now I can move on to the other areas that I want to work on.

Similar Threads

  1. Acessing Internet: xbuntu-->Vista-->WAN-->Internet
    By dog0 in forum Ubuntu / Debian
    Replies: 2
    Last Post: 12-06-2008, 04:55 AM
  2. can't stay connected
    By pinetar in forum Windows - General Topics
    Replies: 1
    Last Post: 12-08-2006, 01:21 PM
  3. dial-up won't stay connected very long
    By dragon5 in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 05-27-2003, 06:20 PM
  4. Getting Mandrake 9 connected to network & internet
    By GeminiID in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 11-19-2002, 01:40 PM
  5. Internet.com is at it again
    By cloverm in forum General Chat
    Replies: 15
    Last Post: 12-18-2001, 03:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •