Results 1 to 1 of 1

Thread: Ubuntu Installation - preseed / partman not partitioning disk

Threaded View

  1. #1
    Administrator Associate gr8rcake's Avatar
    Join Date
    May 2004

    Ubuntu Installation - preseed / partman not partitioning disk

    Issue: Preseeding appears to work up until the partitioning of the disk /dev/sda. At his point I get a "no root partition is defined" message.

    If the:

    d-i partman/choose_partition select finish
    d-i partman/confirm boolean true

    lines are commented out, the screen displays any existing partitions on the disk and doesn't present a "next" button.

    It appears as if the installer is reading the disk, but not writing the new partition table to the disk.

    I have tried this in both LVM and regular modes. It doesn't appear to be due to the partitioning scheme, as I have tried dozens of different ones from web.

    I have replaced the entire partition section with web examples, with the same results.

    If I wipe out the partition table beforehand with:

    # dd if=/dev/zero of=/dev/sda count-1 bs=512

    I get the same symptoms, except in the case where the above partman statements are commented out, a blank display of partitions is presented.

    The partition tables definitely don't get written. The original OS can always boot after the preseed failures.

    Fedora kickstart works perfectly on the system. I have also successfully used ntfsclone on the system to install windows using a livecd.

    Realising this is a fake RAID system, I have tried the dmraid options in grub and preseed file with no change in the symptoms.


    My grub boot options are

    priority=critical preseed/url=http://server/seedfile.seed  interface=auto netcfg/dhcp_timeout=60 auto=true ip=dhcp

    System Info

    OS: Ubuntu 11.10
    HW: Acer AM3410 desktop PC (Fake RAID)

    I am getting the initrd and linux files from this directory of the installation CD


    I am using this ISO as the source CD for the initrd and linux kernel files


    The preseed file looks like this:

    d-i debian-installer/locale string en_USd-i console-setup/ask_detect boolean false
    d-i console-setup/layoutcode string us
    d-i netcfg/choose_interface select eth0
    d-i netcfg/disable_dhcp boolean true
    d-i netcfg/get_nameservers string
    d-i netcfg/get_ipaddress string
    d-i netcfg/get_netmask string
    d-i netcfg/get_gateway string
    d-i netcfg/confirm_static boolean true
    d-i netcfg/get_hostname string unassigned-hostname
    d-i netcfg/get_domain string unassigned-domain
    d-i netcfg/wireless_wep string
    d-i mirror/country string manual
    d-i mirror/http/hostname string
    d-i mirror/http/directory string /ubuntu
    d-i mirror/http/proxy string
    d-i clock-setup/utc boolean true
    d-i time/zone string US/Pacific
    d-i clock-setup/ntp boolean true
    d-i clock-setup/ntp-server string
    d-i partman-auto/disk string /dev/sda
    d-i partman-auto/method string regular
    d-i partman-lvm/device_remove_lvm boolean true
    d-i partman-md/device_remove_md boolean true
    d-i partman-lvm/confirm boolean true
    d-i partman-auto/purge_lvm_from_device boolean true
    d-i partman-lvm/confirm_nooverwrite boolean true
    d-i partman-auto-lvm/guided_size string max
    d-i partman-auto/choose_recipe select boot-root
    d-i partman-lvm/device_remove_lvm boolean true
    d-i partman-auto/purge_lvm_from_device boolean true
    d-i partman-auto-lvm/new_vg_name string vg00
    d-i partman-auto-lvm/new_vg_name_exists string
    d-i partman-lvm/vgcreate string vg00
    d-i partman-auto/expert_recipe string                         \
          boot-root ::                                            \
                  4096 4096 4096 ext4                             \
                          $primary{ } $bootable{ }                \
                          method{ format } format{ }              \
                          use_filesystem{ } filesystem{ ext4 }    \
                          mountpoint{ /boot }                     \
                  .                                               \
                  100 1000 100000000 ext4                         \
                          $defaultignore{ }                       \
                          $primary{ }                             \
                          method{ lvm }                           \
                          device{ /dev/sda }                      \
                          vg_name{ vg00 }                         \
                  .                                               \
                  4096 2 100000000 ext4                           \
                          method{ format } format{ } $lvmok{ }    \
                          in_vg{ vg00 }                           \
                          lv_name{ vg00-lv01 }                    \
                          use_filesystem{ } filesystem{ ext4 }    \
                          mountpoint{ / }                         \
                  .                                               \
                  4096 4096 300% linux-swap                       \
                          method{ swap } format{ }                \
    d-i partman/default_filesystem string ext4
    d-i partman-partitioning/confirm_write_new_label boolean true
    d-i partman/choose_partition select finish
    d-i partman/confirm boolean true
    d-i partman/confirm_nooverwrite boolean true
    d-i passwd/root-login boolean true
    d-i passwd/make-user boolean false
    d-i passwd/root-password password r00tme
    d-i passwd/root-password-again password r00tme
    d-i user-setup/encrypt-home boolean false
    tasksel tasksel/first multiselect lamp-server, print-server
    d-i pkgsel/include string openssh-server build-essential
    d-i pkgsel/updatedb boolean true
    d-i grub-installer/only_debian boolean true
    d-i grub-installer/with_other_os boolean true
    d-i finish-install/reboot_in_progress note
    Any assistance would be very welcome. I've been banging my head against the wall for a week. Ouch!
    Last edited by gr8rcake; 11-13-2011 at 02:56 PM. Reason: Cleaned up code section in prior post to make it easier to read

Similar Threads

  1. Ubuntu 12.04 LTS Setting Up Network between Xp/7 and Ubuntu 12.04LTS
    By tobiasleesc in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 03-02-2014, 02:46 AM
  2. partitioning
    By xorox in forum BSD
    Replies: 2
    Last Post: 09-18-2007, 11:57 AM
  3. Partitioning
    By The Kelvinater in forum Windows - General Topics
    Replies: 1
    Last Post: 10-18-2006, 12:11 AM
  4. SUN/BSD disk partitioning
    By x in forum BSD
    Replies: 2
    Last Post: 05-13-2003, 09:36 PM
  5. Partitioning
    By kornp in forum Linux - General Topics
    Replies: 7
    Last Post: 08-20-2002, 08:49 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts