Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Unable to startx -  no screens found
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Unable to startx -  no screens found

  1. #1

    Unable to startx -  no screens found

    I get the following error when I run startx. I have debian woody. I ran the X configurer under woody several times. I always get the following error:

    What do I have to do to get passed this? Thanks.

    [beginning of error]

    This is a pre-release version of XFree86, and is not supported in any
    way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
    to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
    please check the latest version in the XFree86 CVS repository
    (http://www.XFree86.Org/cvs)

    XFree86 Version 4.1.0.1 / X Window System
    (protocol Version 11, revision 0, vendor release 6510)
    Release Date: 21 December 2001
    If the server is older than 6-12 months, or if your card is
    newer than the above date, look for a newer version before
    reporting problems. (See http://www.XFree86.Org/FAQ)
    Build Operating System: Linux 2.4.13 i686 [ELF]
    Module Loader present
    (==) Log file: "/var/log/XFree86.0.log", Time: Mon Feb 25 06:59:32 2002
    (==) Using config file: "/etc/X11/XF86Config-4"
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) ServerLayout "Simple Layout"
    (**) |-->Screen "Screen 1" (0)
    (**) | |-->Monitor "My Monitor"
    (**) | |-->Device "ATI Rage 128"
    (**) |-->Input Device "USB Mice"
    (**) |-->Input Device "Keyboard1"
    (**) XKB: rules: "xfree86"
    (**) XKB: model: "microsoft"
    (**) XKB: layout: "us"
    (EE) No core pointer device specified
    (EE) Unable to determine the screen layout
    (EE) Error from xf86HandleConfigFile()

    Fatal server error:
    no screens found

    When reporting a problem related to a server crash, please send
    the full server output, not just the last messages.
    This can be found in the log file "/var/log/XFree86.0.log".
    Please report problems to submit@bugs.debian.org.

    X connection to :0.0 broken (explicit kill or server shutdown).

    [end of error]


    Tell me if you want to see my config file or know any other information. Thanks.

  2. #2
    Guest

    Re: Unable to startx - *no screens found


    (EE) Unable to determine the screen layout

    this seems to be your REAL problem... am I right ?
    Did you define your default color depth and etc. ?

  3. #3
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re: Unable to startx - *no screens found

    It looks like your video card in not configured properly. Go ahead and post your config file.

  4. #4

    Re: Unable to startx - *no screens found

    (**) |-->Screen "Screen 1" (0)
    (**) | * |-->Monitor "My Monitor"
    (**) | * |-->Device "ATI Rage 128"
    (**) |-->Input Device "USB Mice"
    (**) |-->Input Device "Keyboard1"
    (**) XKB: rules: "xfree86"
    (**) XKB: model: "microsoft"
    (**) XKB: layout: "us"
    (EE) No core pointer device specified
    (EE) Unable to determine the screen layout
    (EE) Error from xf86HandleConfigFile()
    The only problem I see is that you don't have your mouse setup properly. I've never used a USB mouse before so I don't know how to get it going.
    After you fix the mouse problem, everything else should be OK.

  5. #5
    Guest

    Re: Unable to startx - *no screens found

    Here's my /etc/X11/XF86Config-4 --- I hope it help you, I have USB mouse setup correctly, but I figured that your distro did that for you... I had to do that by hand, since I run LFS

    Section "Files"

    * *RgbPath * * *"/usr/X11R6/lib/X11/rgb"
    * *ModulePath *"/usr/X11R6/lib/modules"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/misc/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/Speedo/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/Type1/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/CID/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/75dpi/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/100dpi/"
    * *FontPath * *"/usr/X11R6/lib/X11/fonts/TrueType/"

    EndSection

    Section "ServerFlags"

    * *# This *allows *the *server *to start up even if the
    * *# mouse device can't be opened/initialised.
    * *AllowMouseOpenFail

    EndSection

    Section "InputDevice"

    * *Identifier "Keyboard1"
    * *Driver * * *"Keyboard"
    * *Option "AutoRepeat" *"250 30"

    * *Option "XkbRules" "xfree86"
    * *Option "XkbModel" "pc105"
    * *Option "XkbLayout" "dk"

    EndSection

    Section "InputDevice"

    * *Identifier *"Mouse1"
    * *Driver * * *"mouse"
    * *Option "Protocol" * *"IMPS/2"
    * *Option "Device" * * *"/dev/input/mice
    * *Option "ZAxisMapping" "4 5"

    EndSection

    Section "Module"

    * *Load * * *"dbe"
    * *Load * * *"glx"
    * *Load * * *"Xrender"
    * *Load * * *"xie"
    * *Load * * *"pex5"
    * *Load * * *"record"

    * *SubSection * * *"extmod"
    * *EndSubSection

    * *Load * * *"type1"
    * *Load * * *"freetype"

    EndSection

    Section "Monitor"
    * *Identifier "Generic|High Frequency SVGA, 1024x768 at 70 Hz"
    * *VendorName "Unknown"
    * *ModelName *"Unknown"

    * *HorizSync 27-61.5
    * *VertRefresh 55-90

    EndSection

    Section "Device"
    * *Identifier *"NVIDIA GeForce 256 (generic)"
    * *VendorName *"Unknown"
    * *BoardName * "Unknown"
    * *Driver * * *"nvidia"
    * *VideoRam * *32768
    * *BusID * * *"PCI:1:0:0"
    * *Option * * *"DPMS" * * * *"on"
    * *Option * * *"AGPMode" * * *"2"
    * *Option * * *"NvAGP" * * * * * *"3"
    EndSection



    Section "Screen"
    * *Identifier "screen1"
    * *Device * * *"NVIDIA GeForce 256 (generic)"
    * *Monitor * * "Generic|High Frequency SVGA, 1024x768 at 70 Hz"
    * *DefaultColorDepth 24
    * *Subsection "Display"
    * * * *Depth * * * 8
    * * * *Modes * * * "1024x768" "800x600" "640x400"
    * * * *ViewPort * *0 0
    * *EndSubsection
    * *Subsection "Display"
    * * * *Depth * * * 16
    * * * *Modes * * * "1024x768" "800x600" "640x480"
    * * * *ViewPort * *0 0
    * *EndSubsection
    * *Subsection "Display"
    * * * *Depth * * * 24
    * * * *Modes * * * "1024x768" "800x600" "640x480"
    * * * *ViewPort * *0 0
    * *EndSubsection
    * *Subsection "Display"
    * * * *Depth * * * 32
    * * * *Modes * * * "1024x768" "800x600" "640x480"
    * * * *ViewPort * *0 0
    * *EndSubsection
    EndSection


    Section "ServerLayout"
    * *Identifier "layout1"
    * *Screen * * "screen1"

    * *InputDevice "Mouse1" "CorePointer"

    * *InputDevice "Keyboard1" "CoreKeyboard"

    EndSection

  6. #6

    Re: Unable to startx - *no screens found

    Hi, thanks for the answers...

    http://us.f1.yahoofs.com/users/71bf9...OmqL<br /> R_P

    Here should be my config file. The link looks weird and temporary so tell me if it doesn't work and I'll find another way to post it.

    The forum software told me it was too long to post here.

    Thanks.

  7. #7
    Mentor
    Join Date
    Jun 2001
    Posts
    1,672

    Re: Unable to startx - *no screens found

    That link is forbidden. Try cut to config file in half and make two posts.

  8. #8
    Guest

    Re: Unable to startx - *no screens found

    email the config file to me and I'll put it on my school server, I have unlimited webspace and a decent connection - don't worry about it !

    --edit--- forgot the email

    lovechild at foolclan.com

  9. #9

    Re: Unable to startx - *no screens found

    # ************************************************** ********************
    # Refer to the XF86Config(4/5) man page for details about the format of
    # this file.
    # ************************************************** ********************

    # ************************************************** ********************
    # Module section -- this *section *is used to specify
    # which dynamically loadable modules to load.
    # ************************************************** ********************
    #
    Section &quot;Module&quot;

    # This loads the DBE extension module.

    * *Load * * * *&quot;dbe&quot; * * * *# Double buffer extension

    # This loads the miscellaneous extensions module, and disables
    # initialisation of the XFree86-DGA extension within that module.
    * *SubSection *&quot;extmod&quot;
    * * *Option * *&quot;omit xfree86-dga&quot; * # don't initialise the DGA extension
    * *EndSubSection

    # This loads the Type1 and FreeType font modules
    * *Load * * * *&quot;type1&quot;
    * *Load * * * *&quot;freetype&quot;

    # This loads the GLX module
    # * *Load * * * &quot;glx&quot;

    EndSection

    # ************************************************** ********************
    # Files section. *This allows default font and rgb paths to be set
    # ************************************************** ********************

    Section &quot;Files&quot;

    # The location of the RGB database. *Note, this is the name of the
    # file minus the extension (like &quot;.txt&quot; or &quot;.db&quot. *There is normally
    # no need to change the default.

    * *RgbPath * * *&quot;/usr/X11R6/lib/X11/rgb&quot;

    # Multiple FontPath entries are allowed (which are concatenated together),
    # as well as specifying multiple comma-separated entries in one FontPath
    # command (or a combination of both methods)
    #
    # If you don't have a floating point coprocessor and emacs, Mosaic or other
    # programs take long to start up, try moving the Type1 and Speedo directory
    # to the end of this list (or comment them out).
    #

    # * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/local/&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/misc/&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/75dpi/:unscaled&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/100dpi/:unscaled&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/Type1/&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/Speedo/&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/75dpi/&quot;
    * *FontPath * &quot;/usr/X11R6/lib/X11/fonts/100dpi/&quot;

    # The module search path. *The default path is shown here.

    # * *ModulePath &quot;/usr/X11R6/lib/modules&quot;

    EndSection

    # ************************************************** ********************
    # Server flags section.
    # ************************************************** ********************

    Section &quot;ServerFlags&quot;

    # Uncomment this to cause a core dump at the spot where a signal is
    # received. *This may leave the console in an unusable state, but may
    # provide a better stack trace in the core dump to aid in debugging

    # * *Option &quot;NoTrapSignals&quot;

    # Uncomment this to disable the &lt;Crtl&gt;&lt;Alt&gt;&lt;BS&gt; server abort sequence
    # This allows clients to receive this key event.

    # * *Option &quot;DontZap&quot;

    # Uncomment this to disable the &lt;Crtl&gt;&lt;Alt&gt;&lt;KP_+&gt;/&lt;KP_-&gt; mode switching
    # sequences. *This allows clients to receive these key events.

    # * *Option &quot;Dont Zoom&quot;

    # Uncomment this to disable tuning with the xvidtune client. With
    # it the client can still run and fetch card and monitor attributes,
    # but it will not be allowed to change them. If it tries it will
    # receive a protocol error.

    # * *Option &quot;DisableVidModeExtension&quot;

    # Uncomment this to enable the use of a non-local xvidtune client.

    # * *Option &quot;AllowNonLocalXvidtune&quot;

    # Uncomment this to disable dynamically modifying the input device
    # (mouse and keyboard) settings.

    # * *Option &quot;DisableModInDev&quot;

    # Uncomment this to enable the use of a non-local client to
    # change the keyboard or mouse settings (currently only xset).

    # * *Option &quot;AllowNonLocalModInDev&quot;

    EndSection

  10. #10

    Re: Unable to startx - *no screens found

    # ************************************************** ********************
    # Input devices
    # ************************************************** ********************

    # ************************************************** ********************
    # Core keyboard's InputDevice section
    # ************************************************** ********************

    Section &quot;InputDevice&quot;

    Identifier &quot;Keyboard1&quot;
    Driver &quot;Keyboard&quot;
    # For most OSs the protocol can be omitted (it defaults to &quot;Standard&quot.
    # When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
    # uncomment the following line.

    # Option &quot;Protocol&quot; &quot;Xqueue&quot;

    Option &quot;AutoRepeat&quot; &quot;500 30&quot;

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option &quot;Xleds&quot; &quot;1 2 3&quot;

    # Option &quot;LeftAlt&quot; &quot;Meta&quot;
    # Option &quot;RightAlt&quot; &quot;ModeShift&quot;

    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults). For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option &quot;XkbModel&quot; &quot;pc102&quot;
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option &quot;XkbModel&quot; &quot;microsoft&quot;
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option &quot;XkbLayout&quot; &quot;de&quot;
    # or:
    # Option &quot;XkbLayout&quot; &quot;de&quot;
    # Option &quot;XkbVariant&quot; &quot;nodeadkeys&quot;
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option &quot;XkbOptions&quot; &quot;ctrl:swapcaps&quot;

    # These are the default XKB settings for XFree86
    # Option &quot;XkbRules&quot; &quot;xfree86&quot;
    # Option &quot;XkbModel&quot; &quot;pc101&quot;
    # Option &quot;XkbLayout&quot; &quot;us&quot;
    # Option &quot;XkbVariant&quot; &quot;&quot;
    # Option &quot;XkbOptions&quot; &quot;&quot;

    # Option &quot;XkbDisable&quot;

    Option &quot;XkbRules&quot; &quot;xfree86&quot;
    Option &quot;XkbModel&quot; &quot;microsoft&quot;
    Option &quot;XkbLayout&quot; &quot;us&quot;

    EndSection


    # ************************************************** ********************
    # Core Pointer's InputDevice section
    # ************************************************** ********************

    #Section &quot;InputDevice&quot;
    Section &quot;InputDevice&quot;
    Identifier &quot;USB Mice&quot;
    Driver &quot;mouse&quot;
    Option &quot;Protocol&quot; &quot;IMPS/2&quot;
    Option &quot;Device&quot; &quot;/dev/input/mice&quot;
    Option &quot;ZAxisMapping&quot; &quot;4 5&quot;
    Option &quot;Buttons&quot; &quot;5&quot;
    EndSection


    # Identifier and driver
    #
    # Identifier &quot;Mouse1&quot;
    # Driver &quot;mouse&quot;
    # Option &quot;Protocol&quot; &quot;PS/2&quot;
    # Option &quot;Device&quot; &quot;/dev/input/mice&quot;

    # When using XQUEUE, comment out the above two lines, and uncomment
    # the following line.

    # Option &quot;Protocol&quot; &quot;Xqueue&quot;

    # Baudrate and SampleRate are only for some Logitech mice. In
    # almost every case these lines should be omitted.

    # Option &quot;BaudRate&quot; &quot;9600&quot;
    # Option &quot;SampleRate&quot; &quot;150&quot;

    # Emulate3Buttons is an option for 2-button Microsoft mice
    # Emulate3Timeout is the timeout in milliseconds (default is 50ms)

    # Option &quot;Emulate3Buttons&quot;
    # Option &quot;Emulate3Timeout&quot; &quot;50&quot;

    # ChordMiddle is an option for some 3-button Logitech mice
    # Option &quot;ChordMiddle&quot;


Similar Threads

  1. TROUBLESHOOT: "Unable to open initial console"...PC UNABLE TO BOOT IN LINUX
    By sandeepundale in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 08-17-2006, 08:30 PM
  2. Vile white screens
    By deimos in forum Linux - General Topics
    Replies: 0
    Last Post: 12-20-2005, 07:57 PM
  3. no screens found
    By deepfreeze in forum Linux - Software, Applications & Programming
    Replies: 10
    Last Post: 08-27-2002, 04:35 AM
  4. fatal error: no screens found
    By S_D_Willie in forum Linux - General Topics
    Replies: 7
    Last Post: 03-26-2002, 11:55 AM
  5. PHP exploit found!  DANGER!
    By Killer_Penguin in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 02-27-2002, 03:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •