Results 1 to 2 of 2

Thread: 1 user can't login in LDAP

  1. #1

    1 user can't login in LDAP

    Using openSUSE 11.4 (x86_64) as LDAP/SAMBA server. Clients use win2k/xp/vista/7 to connect. Until a few days ago everything worked fine. Users would connect to domain and work.
    The other day a lady wrote the password wrong 5 times and got her account blocked. I unlocked it, removing the 'L' flag and set badpasswordcount=0 using YaST2, and got her a new password. Alas, still can't login. Says user/password incorrect. All the other users are fine however.
    Tried creating a new user, this one can't login either.

    Any ideas how to fix? Or work-arounds?

  2. #2

    LDAP and SAMBA out of sync

    OK, so there are two problems here.
    1) Winbox takes time to fetch domain info... no idea how to fix or anything, but waiting 5min after starting up helps. Not a big problem, can be ignored.

    2) ldap and samba are not in sync. Changing password with LDAP gets me nowhwere, whereas sambapasswd does the trick.
    pdbedit also shows all the updated info (e.g. SambaBadPasswordCount when I purposely enter it wrongly a few times), whereas LDAP shows outdated info.
    Question is, why does it not sync? And, how do I get it to sync once again?

    Sorry for me spamming the forums!

Similar Threads

  1. chown <ldap user> <dir>, permission denied
    By djekels in forum Linux - General Topics
    Replies: 1
    Last Post: 03-15-2006, 11:30 PM
  2. single user login. no login at startup
    By donovan in forum Linux - General Topics
    Replies: 3
    Last Post: 01-12-2005, 08:57 AM
  3. Problem with new user login
    By geoffp in forum Announcements and Suggestions
    Replies: 3
    Last Post: 10-11-2003, 05:10 AM
  4. Changing user login to GUI
    By rolltidega in forum Redhat / Fedora
    Replies: 4
    Last Post: 10-16-2002, 08:23 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts