Results 1 to 5 of 5

Thread: Can't login to root

  1. #1

    Can't login to root

    Trying to access smbpasswd file to debug networking, I need root to be able to edit that file.

    But my system doesn't seem to give me the option of booting up in root. How do I make it do this ??

    BTw, sometimes recently it's been asking for the root password before it will boot up normally, which seems strange.

    System is Suse 10.2, latest updates present.

    I need to sort this before I can move on to get the network working again.

  2. #2
    Log in, and use 'sudo -s' to give you a root shell, but with your account password. Also, you can give yourself permission by using 'su'.

    Did you have to set a root password when you setup the account? A lot of GUI login managers will disallow root access, but you can change it to allow it. In KDE there is a whole section for the login manager, and enable it to allow root. Of course, it's not a good practice to log into X as root at all.

    If you did set a root password, you can run the GUI tool with the 'kdesu' command, and it will authenticate before it starts it.
    arrogance breeds ignorance

    Screaming Electron, Full of BSD Goodness

  3. #3
    Thanks . I understand some of this.

    I did have to set a root password when I installed Suse. I take your comment that it's better to open a new shell for root than to log in from the start as root.

    Now the simple question:- having got the root shell open and running, what is the command I need to text-edit a file such as smbpasswd please ?

    A related question - can I find an individual file and reload it from the installation discs? If so, what is the procedure ?

  4. #4
    Finding that file would be an extreme pain. As for editing the smbpasswd, you don't really have to edit it with an editor. You can use the smbpasswd command to accomplish this.

    As root:

    $ smbpasswd -a user1 # add "user1" to the smbpasswd file
    $ smbpasswd -e user1 # enable the "user1" account
    $ smbpasswd -x user1 # delete "user1" from the smbpasswd file

    You can find more options, just by typing 'smbpasswd' in the terminal, without adding anything else.
    arrogance breeds ignorance

    Screaming Electron, Full of BSD Goodness

  5. #5
    Newbie okieman46's Avatar
    Join Date
    Dec 2009
    Location
    Somewhere, Oklahoma
    Posts
    2
    You can also use the command man smbpasswd for more info as well

Similar Threads

  1. root login
    By wireddad in forum Linux - General Topics
    Replies: 3
    Last Post: 06-23-2003, 05:36 AM
  2. login as root
    By nimbus in forum Linux - General Topics
    Replies: 3
    Last Post: 06-11-2003, 11:19 PM
  3. X is automatically killed for user or root login
    By Sathya in forum Redhat / Fedora
    Replies: 2
    Last Post: 01-10-2003, 02:19 AM
  4. Prevent root login with ssh
    By friskydrifter in forum Redhat / Fedora
    Replies: 2
    Last Post: 12-06-2002, 10:02 AM
  5. Telnet/FTP & Root login
    By Oxjockey in forum Redhat / Fedora
    Replies: 7
    Last Post: 12-06-2002, 01:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •